Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2004
  • Last Modified:

Installing Netware 3.12 from scratch on SATA Drive

This is a related question:

I now have my DELL SC440 server with two SATA drives.  I am doing something different than Nick did.  I am trying to install it from scratch as opposed to imaging the old server's SCSI drive onto the new server's SATA drive.

I am having trouble getting DOS 6.2.2 to format a slice of the unformatted hard drive into a C:\ drive. It begins and goes through the process then gives a message saying that 'errors were detected' and that the hard drive format is incompatible with DOS 6.2.2.

I have tried installing a few ways:
Method A:
A.1 Inserting a 6.2.2 boot disk and booting
A.2 switching in DOS setup disk #1 into floppy drive and running FDISK
A.3 formatting 200MB as Drive C:
A.4 running setup from Setup Disk #1 - this tells me that the format of C is not good and it should reformat it.
A.5 attempt to reformat via the setup program and it fails

I then booted with Partition Magic 8.0 disks and remove drive C:

Method B:  
B.1 Insert DOS 6.2.2 startup disk (now with all of Setup Disk #1 files on it)
B.2 After booting, the setup program runs automatically.
B.3 Attempt to format space as Drive C( though it doesn't ask about how big to make the partition).  Setup fails.


I may go at it again starting with FDISK to get the partition size right.  Maybe I'll create the partition with Partition Magic.  Should it be FAT16?

Does anyone have any experience installing DOS onto SATA from scratch?  

Thank you in advance for your help.
0
TerryWeir
Asked:
TerryWeir
2 Solutions
 
debuggerauCommented:
Yes, Couple of things:

You would need IDE emulation on your motherboard to enable the BIOS support, that should be present.

It wouldn't surprise me either that the dimensions of your hard drive exceed DOS's supported dimensions. Try a smaller disk...

What happens if you attempt to install manually?
fdisk, format, copy...

And then boot?



0
 
BudDurlandCommented:
There's probably a "compatibility mode" setting in the machine's BIOS. You may not be able to use the RAID capability.  I checked the Dell web site; NetWare and OES Linux are not supported on that model.
0
 
TerryWeirAuthor Commented:
I took a look at the BIOS settings this morning, but didn't see anything about compatibility mode or emulation, but I will take another look with a keener eye.

This server is actually sold with Novell Linux as an option, but I went with no OS to do my own installation.  There is another member on this board, nickpoulos who has this server running a 3.12 installation that he imaged from an older SCSI drive.  It should work in theory.  I need to keep digging.

I will try to simply use the utilities on the disk, fdisk, format, and then try setup.  Maybe I can break it down one step at a time.
0
Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

 
maquesCommented:
I don't really understand the question. Do you have problem with the fdisk/format or with the "setup" process? Because it can be pretty much separated and can be used to see what is the real issue.

I create DOS partition sort of frequently, without any problem.
The process is:
- I boot DOS (floppy or another HDD), do fdisk, create a partition, set it active, exit, reboot.
- Then boot DOS again, format c: /s (transferring system files).
From then on, the harddisk can boot to DOS.
You shouldn't have any problem doing the above steps, if you can, then you don't have any problem with BIOS/HDD/MB/DOS, whatever. If you can't do any of these steps, then let us know where you fail and any details which can help [exact error message, etc.]

Then - if I need - I copy whatever utilities I need (usually from another existing \DOS directory).
If setup can't do this for you, then you should/could do it manually or find out why setup fails, however if the 1st section can be done, then the only problem is with "setup" process, not with DOS/HDD/BIOS.

debuggerau:
"It wouldn't surprise me either that the dimensions of your hard drive exceed DOS's supported dimensions. Try a smaller disk..."
There is no such thing. DOS will use the maximum it can, and will not / can not care how big is your disk. Actually It will as big as DOS's max, 2GB that is.
0
 
TerryWeirAuthor Commented:
I went through the individual steps that maques prescribed:
Boot with floppy disk
FDISK - 1 - format partition as primary C:\ drive  150MB
FDISK - 2- set C:\ as active
Reboot
format c: /s

that all works and the C:\ drive contains IO.SYS, MSDOS.SYS, DRVSPACE.BIN, and COMMAND.COM

When I eject the floppy and reboot via CTRL-ALT-DEL, I get the message:
"Non-system disk or disk error
Replace and press any key when ready"

It will only boot from the A:\ drive floppy disk.  It is not recognizing C:\ as having the correct files.  Any ideas?
0
 
maquesCommented:
I assume that is the only disk, so ordering can't be a problem.
I also assume that this is the first partition, as BIOS/DOS won't boot from above 2GB, eg. if you have a 16GB linux or whatever partition at the beginning of the disk, the second partition - being above 1024 cylinders /2GB boundary - will not be able to boot.

If so, try booting from the floppy and issue a
fdisk /mbr
this should rewrite the master boot record in case it is corrupted for some reason.
Also make sure that fdisk displays the partition active (might be you set it and somehow it didn't  get set)
0
 
TerryWeirAuthor Commented:
There is a partition from DELL that is in front of the C:\ partition.  It is 2GB.  That must be the issue.  I will see if I can use Partition Magic to move the partitions or copy them to juggle it around.  Perhaps I can just resize the 2GB partition.  It doesn't have much in it.
0
 
maquesCommented:
Surely that is the problem - which you failed to mention in the original problem description... :-|
If you don't need the partition, just remove it.
Or put an empty disk.
Otherwise creating a DOS partition is pretty much "fail-safe". Those good old days...
0
 
TerryWeirAuthor Commented:
That did the trick.  I was able to get DOS installed and booted.  I just resized the DELL partition down to 100MB and the system booted right up and asked for the DOS setup disks.

Now that the easy part is over ;-)  I'll start working on the actual Netware instal using macques ideata.ham.  I'll be sure to post when I run into the inevitable problems that I can't get past alone
0
 
TerryWeirAuthor Commented:
Thank you for your help.  Despite all of my computer experiences, I have never actually had to install MSDOS from scratch.  The new hardware introduced more than its share of uncertainty.  I am on track again now!
0
 
maquesCommented:
Good luck... and thanks for the fish... I mean, the points...
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now