Solved

How to disable redirect to port 8333

Posted on 2008-10-01
9
8,059 Views
Last Modified: 2012-05-05
Hi

I was just wondering how I can disable ssl redirect, and just use port 8222?
The server and its clients are all located on an (to others) inaccessible LAN segment, so I don't see the need for ssl.
I just want the best performance.
0
Comment
Question by:Ole_Brun
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
9 Comments
 
LVL 7

Expert Comment

by:BogdanSUA
ID: 22619559
here's some notes from the release notes:

The default VI Web Access HTTP connection port is 8222 and the default HTTPS port is 8333. If you use these defaults, or any values other than 80 (HTTP) and 443 (HTTPS), you must specify the port number when you connect to VMware Server using VI Web Access. You must also allow connection to these ports through your firewall.
An example URL to connect to VI Web Access is http://server_host:8222 
If you want to use ports 80 (HTTP) and 443 (HTTPS), override the default values during installation.
Note: If you are running IIS or Apache web server on the default ports, specify alternate HTTP and HTTP ports when prompted by the Windows installer or vmware-config.pl. Alternatively, stop IIS's default Web site or any other Web site running on these ports. On Linux, shut down Apache or any other application using these ports and make sure they are not configured to restart automatically.

So maybe you can try vmware-config.pl

Is your host Windows or Linux?
0
 
LVL 7

Expert Comment

by:BogdanSUA
ID: 22619574
Pages 37-43 of the below PDF also go into deeper detail:

http://www.vmware.com/pdf/vmserver2.pdf
0
 

Author Comment

by:Ole_Brun
ID: 22626740
Thanks for the reply!

I have seen that document, and on page 48 it is stated:
"When you connect remotely, you are automatically redirected to the secure http
(https) port."
This is what I want to avoid. I do not want to be redirected to the https port.
I am running Windows btw.
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 
LVL 7

Expert Comment

by:BogdanSUA
ID: 22629309
You'd have to break it in your TOMCAT config file that VMware installs.

Doing so will render your installation not operable with the vmrun command which can be used for scripting tasks via command line.  Are you super sure that you want to do this?

Its not really consuming a lot of resources if all its doing is listening.

And if you're the only one using it just access http://server:8222.  Pretty sure that doesnt redirect you.  I can test it out later tonight when I get home.
0
 

Author Comment

by:Ole_Brun
ID: 22632510
Hi

Accessing http://server:8222 redirects to 8333.
It is not just the performance overhead that is the problem. I don't like that it asks me for client certificate each time. IE7 also complains about the certificate and advices me not to open the page...
But these things are maybe easy to fix!?
0
 

Expert Comment

by:JoeQca
ID: 22660158
I am looking for the same solution, I did notice however that you can hit port 8308 and ui works but I did find it a bit buggy. Also you need to use the complete URL http://servername:8308/ui/#. I am digging in the config files to see if their is a way to disable https redirect as well will try to report back.
0
 

Author Comment

by:Ole_Brun
ID: 22661147
Sounds good!
I think it is strange that this apparently is not supported in Server 2.0 since this always was a part of Server 1.0. One checkbox was all you needed to uncheck.
0
 

Accepted Solution

by:
JoeQca earned 250 total points
ID: 22662991
Well, I think I got it, their is an xml file you will need to modify (proxy.xml).  The default location of this file in windows is:
C:\Documents and Settings\All Users\Application Data\VMware\VMware Server\hostd\
for each endpoint list their is and access mode setting: <accessMode>...setting....</accessMode>
change this setting for all of them to: httpAndHttps and this should do the trick. Once done restart the server or just the VMWare services and all should be running under both ports, http 8222 and https 8333.
Let me know how this goes.
0
 

Author Comment

by:Ole_Brun
ID: 22666741
That did the trick!
Thank you heaps!
This should have been in the manual.
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Clone VM Automation 3 95
Extending VM Disk to be larger than 2 TB ? 11 171
No IP Address Assigned to VM 10 147
Virtual Machine Disk Consolidation is Needed ? 16 36
HOW TO: Install and Configure VMware vSphere Hypervisor 6.5 (ESXi 6.5), Step by Step Tutorial with screenshots. From Download, Checking Media, to Completed Installation.
In this article, I will show you HOW TO: Create your first Windows Virtual Machine on a VMware vSphere Hypervisor 6.5 (ESXi 6.5) Host Server, the Windows OS we will install is Windows Server 2016.
Teach the user how to edit .vmx files to add advanced configuration options Open vSphere Web Client: Edit Settings for a VM: Choose VM Options -> Advanced: Add Configuration Parameters:
Teach the user how to join ESXi hosts to Active Directory domains Open vSphere Client: Join ESXi host to AD domain: Verify ESXi computer account in AD: Configure permissions for domain user in ESXi: Test domain user login to ESXi host:

736 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question