Eclipse and compiling with old JDK (j2sdk1.4.2_18)

I need to compile my project with an old compiler (j2sdk1.4.2_18). However, Eclipse don't like to start up with 1.4.2. It compalins about incompabilities and wants to have at least 1.5.0.

How do I handle that?
mdolandAsked:
Who is Participating?
 
mnrzConnect With a Mentor Commented:
as far as I know Eclipse works with any version of JDK
go to Window >> Preferences  and select Java and then Compiler
there is a "Compiler compliance level" you can change it to 5.0, 1.4 or even 1.3

0
 
mdolandAuthor Commented:
Thanks alot.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.