?
Solved

Microsoft Windows 2003 Remote Desktop has stopped working

Posted on 2008-10-01
20
Medium Priority
?
1,113 Views
Last Modified: 2013-11-21
I have a client that has been using Remote Desktop with Windows 2003 Server for about two years now very successfully. Two days ago, in the afternoon, Remote Desktop stopped working, in that it began saying "This computer can't connect tot he remote computer".
I initially thought it was the update to the end users machine, a Microsoft Update, but I have checked on different machines with the same result.

If I open up remote desktop on the server itself and make it connect to itself it of course works great.

I have looked for changes but I just don't see anything glaring at me. If anyone has come across this, or if you can give me things to check I'll be happy to check them and give you what I have.

The clients are down until I get this fixed, so it is worth the 500 points as it is a down system.

Thank you everyone!!!

Shon
0
Comment
Question by:sscottincanyon
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 6
  • 2
  • +3
20 Comments
 
LVL 10

Accepted Solution

by:
tboy6423 earned 400 total points
ID: 22613756
We had a silmilar problem and it had to do with a microsoft update on the users machines...if you use Windows Firewall (even if you don't ) check this first, the update wiped out all of our exceptions so Remote desktop and File sharing was disabled. You may want to start there, I cannot remember what update it was but re-checking the exceptions Remote Desktop and File Sharing worked.
0
 

Assisted Solution

by:gblund
gblund earned 400 total points
ID: 22613856
also the sp3 to xp disables the function in ie. you should go in the ie, functions "administer add on programs" and choose to activate the Microsoft RDP Client control.
0
 
LVL 2

Author Comment

by:sscottincanyon
ID: 22613875
Hey tboy:
I also experienced this with another client, and looked at it just to make sure because it did through me off last time. I just checked on my machine and the firewall is off and the exceptions are correct.

Thank you :) I hope to see more solutions coming,

Shon
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
LVL 2

Author Comment

by:sscottincanyon
ID: 22614010
GBlund, I checked this and everything is as you said it should be.

Just to add on, I can connect to any other clients RDP/Windows 2003 server without issue, it is just this one that rejecting the connection.

If you would like to try it from your machine, e-mail me and I will send you the credentials so you can verify.

Thank you,
Shon
0
 
LVL 10

Expert Comment

by:tboy6423
ID: 22614015
Is the Firewall still running in services? or is it disabled and stopped?
0
 
LVL 16

Assisted Solution

by:speshalyst
speshalyst earned 400 total points
ID: 22614018
On the Remote Machine.. verify if  the "allow remote users to connect remotely to this computer"  has been disabled by any chance
you can get there by right-mouse Mycomputer>Properties>remote
 
 
0
 
LVL 2

Author Comment

by:sscottincanyon
ID: 22614232
These are all great suggestions, please keep them coming!!!

I have checked the remote computer and it is still enabled for remote connections and control.

Tboy: The firewall is not running at all.

Thank you everyone!!
SHon
0
 
LVL 10

Expert Comment

by:tboy6423
ID: 22614290
0
 
LVL 16

Expert Comment

by:speshalyst
ID: 22614389
0
 
LVL 2

Author Comment

by:sscottincanyon
ID: 22614409
The version on this client is 6.1, to make sure I ran the update from the link you supplied Tboy and it stated that the version I had was newer than the one being installed.

Shon
0
 
LVL 2

Author Comment

by:sscottincanyon
ID: 22614496
Speshalyst: Thank you for the additional link within the exchange, I am currently using administrator, RDC port 3389 is open on the routher. and remote access is enabled. I will certainly check out remote desktop on the web that was mentioned there. However, since I have all those set correctly too, sadly, that was not the solution.

Again, thank you for keeping them coming, I know there is a solution it is just hitting the right one.

Shon
0
 
LVL 10

Expert Comment

by:tboy6423
ID: 22614686
Is .net 3.0 installed on that client?
0
 
LVL 10

Expert Comment

by:tboy6423
ID: 22614759
0
 
LVL 2

Author Comment

by:sscottincanyon
ID: 22615002
Just to restate, I may not be communicating clearly. On this client I can connect to any and all other Remote Desktop Connection, it is just this one in particular. With this one connection, I cannot connect to it from any other computer.

I hope that makes more sense,

Shon
0
 
LVL 10

Expert Comment

by:tboy6423
ID: 22616106
yep understand perfectly..you can connect out, but cannot connect RDP to that particular client. it's strange...I will see what else it may be..
0
 
LVL 39

Expert Comment

by:ChiefIT
ID: 22621602
SP2 has a little quirk that requires two reboots before RDP will work again. Reboot the server.
0
 

Assisted Solution

by:JOSHUABT
JOSHUABT earned 400 total points
ID: 22627696
Check if you have installed Terminal server component.
Sometimes, people install TS and enjoy 120 days grace period and forget about it until it expires.
If you have installed, you have to either purchase the TS CAL license or uninstall TS component.
If will go back to RDP server with default 2 licenses.

Hope it works.
0
 
LVL 39

Assisted Solution

by:ChiefIT
ChiefIT earned 400 total points
ID: 22640329
There is a couple quirks with SP2 and RDP. One of them is TS stops listening on the default port. Here you go, you might want to check this out.

http://www.lan-2-wan.com/2003-SP2.htm
0
 
LVL 2

Author Comment

by:sscottincanyon
ID: 22746826
It turns out that I had to replace the router. I thank everyone for their input.

Have a great night,

Shon R. Scott
0
 
LVL 2

Author Closing Comment

by:sscottincanyon
ID: 31501935
I know that you all had some very valuable input and I don't like just closing a question, so I am awarding you equally with a grade of A. Moderators, if this isn't a usual practice and isn't acceptable please let me know and I/you change it?

Thank you for all the help!!
Shon R. Scott
0

Featured Post

Tech or Treat!

Submit an article about your scariest tech experience—and the solution—and you’ll be automatically entered to win one of 4 fantastic tech gadgets.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Welcome to my series of short tips on migrations. Whilst based on Microsoft migrations the same principles can be applied to any type of migration. My first tip Migration Tip #1 – Source Server Health can be found listed in my profile here: http:…
On July 14th 2015, Windows Server 2003 will become End of Support, leaving hundreds of thousands of servers around the world that still run this 12 year old operating system vulnerable and potentially out of compliance in many organisations around t…
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…
Suggested Courses

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question