[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 352
  • Last Modified:

Forcing email to go through a smart host versus internally

I work for an org that controls the main domain name.  For sake of example we will call it cookie.com.

If you wanted to email me you would just sent me an email at heathy@cookie.com.  Now the org I work for only gives you a POP/IMAP account with 500MB quota, so I run an exchange server for my user group so they have have more things than just plan email and a low quota.

For sake of example the exchange domain name is exchange.cookie.com.  So if you wanted to email me you could email me at heathy@exchange.cookie.com.  The organization give a user the ability to forward their email to anywhere they want.  So I can give people heathy@cookie.com and it will automatically forward to heathy@exchange.cookie.com.  Now some people have multiple email addresses setup in their forwards such as a yahoo or gmail account.

Here comes the tricky part.  I've figured out how to have Exchange 2007 change the email address to be from heathy@cookie.com vs heathy@exchange.cookie.com.  The problem is if someone else that uses the exchange server replies to that person, exchange routes it internally so it never hits the orgs forwarder that will allow the email to be forwarded to someone's gmail account.

How do I get Exchange to send email sent to heathy@cookie.com to go to the SMTP smart host versus internal routing?
0
heathyob
Asked:
heathyob
  • 3
  • 3
1 Solution
 
2388Commented:
Are you actually using a smart host?  Check in the properties of your smtp virtual server, under delivery, advanced.  That is where you specify a server for all outgoing email connections, and bypass the exchange dns.

If you have the smart host already in that area, then we will need to look at something else.
0
 
heathyobAuthor Commented:
I have it set.

It was created in Exchange 2003 since I have to have them co-exist until I can move everyone off.

Mail from 2007 works just fine internal and external but it's not forcing the usage of the smart host for internal mail.


0
 
2388Commented:
If what I understand is correct, your forwards are on the outside server?  If that is the case, then they might have to be duplicated on the internal server as well.  However, that might be a problem if people have multiple forwards.  I will check to see, but I don't think that you can bypass the delivery options unless you take out the x400 connectors for the users and make them smtp only (which defeats the purpose of an exchange collaboration server)...  but if email is the onyl thing you do on it...
0
Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

 
heathyobAuthor Commented:
Yeah we use the other stuff in exchange otherwise it would just be easier to setup a *nix box.

I know it's possible, someone else has a pure 2007 environment.  It could be that it's going through the 2003 server and it's messing stuff up.  I might just have to hold off until I can get rid of the 2003.
0
 
heathyobAuthor Commented:
I ended up setting up a linux box to rewrite the headers.  Seems to work out fine.
0
 
2388Commented:
Gotta love linux!
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now