Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Flags RST / ACK on interface inside

Posted on 2008-10-01
6
Medium Priority
?
7,526 Views
Last Modified: 2012-06-21
I am getting a lot of "Flags RST's and ACK's on interface inside."

: Saved
:
ASA Version 7.0(7)
!
hostname
domain-name
enable password encrypted
names
dns-guard
!
interface Ethernet0/0
 nameif Outside
 security-level 0
 ip address  
!
interface Ethernet0/1
 nameif Inside
 security-level 100
 ip address 10.0.0.253 255.255.255.0
!
interface Ethernet0/2
 speed 100
 duplex full
 nameif DMZ
 security-level 50
 ip address 172.20.0.1 255.255.255.0
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
 management-only
!
passwd encrypted
banner exec  **************************************************************************
no ftp mode passive
dns name-server 10.0.0.6
dns name-server 64.80.223.226
same-security-traffic permit inter-interface
object-group service SMB tcp
 description SMB TCP
 port-object eq 445
 port-object eq netbios-ssn
object-group service SMBUDP udp
 description SMB UDP
 port-object eq netbios-dgm
 port-object eq netbios-ns
 port-object eq 445
access-list DMZ_access_in extended permit tcp any any
access-list Outside_access_in extended permit tcp any any
access-list Outside_access_in remark NTP UDP
access-list Outside_access_in remark NTP TCP
access-list Outside_access_in remark Ping
access-list Outside_access_in remark SMB TCP
access-list Outside_access_in extended permit tcp any object-group SMB any object-group SMB
access-list Outside_access_in remark SMB UDP
access-list Outside_access_in extended permit udp any object-group SMBUDP any object-group SMBUDP
access-list Outside_access_in remark SMTP
access-list Outside_access_in extended permit tcp any eq smtp host  eq smtp
access-list Outside_access_in remark Terminal Services
access-list Outside_access_in extended permit tcp any eq 3389 host  eq 3389
access-list Outside_access_in extended permit ip any any
access-list Inside_access_in extended permit tcp any any
access-list Inside_access_in extended permit ip any any
pager lines 24
mtu Outside 1500
mtu DMZ 1500
mtu management 1500
mtu Inside 1500
asdm image disk0:/asdm-507.bin
no asdm history enable
arp timeout 14400
nat (management) 0 0.0.0.0 0.0.0.0
nat (Inside) 0 0.0.0.0 0.0.0.0
static (Outside,Inside) tcp 10.0.0.6 www  www netmask 255.255.255.255
static (Outside,Inside) tcp 10.0.0.6 domain  domain netmask 255.255.255.255
static (Outside,Inside) udp 10.0.0.6 domain  domain netmask 255.255.255.255
static (Outside,Inside) tcp 10.0.0.6 2703  2703 netmask 255.255.255.255
static (Outside,Inside) tcp 10.0.0.6 6277  6277 netmask 255.255.255.255
static (Outside,Inside) udp 10.0.0.6 ntp  ntp netmask 255.255.255.255
static (Outside,Inside) tcp 10.0.0.4 ftp  ftp netmask 255.255.255.255
static (Outside,Inside) tcp 10.0.0.6 smtp  smtp netmask 255.255.255.255
static (Outside,Inside) tcp 10.0.0.201 ftp  ftp netmask 255.255.255.255
static (Outside,Inside) tcp 10.0.0.252 3389  3389 netmask 255.255.255.255
static (Outside,DMZ) 172.20.0.2  netmask 255.255.255.255
access-group Outside_access_in in interface Outside
access-group DMZ_access_in in interface DMZ
access-group Inside_access_in in interface Inside
route Outside 0.0.0.0 0.0.0.0  1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00
timeout mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
username root password  encrypted privilege 15
http server enable
http 0.0.0.0 0.0.0.0 Outside
http 192.168.1.0 255.255.255.0 management
http 0.0.0.0 0.0.0.0 Inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 Outside
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd lease 3600
dhcpd ping_timeout 50
dhcpd enable management
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map global_policy
 class inspection_default
  inspect dns maximum-length 512
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
ntp server 192.5.41.41 source Outside prefer
smtp-server 10.0.0.4
Cryptochecksum:2440ce0e2b3a950f479d2bbddf296f6b
: end
Log.jpg
0
Comment
Question by:EODJack
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
6 Comments
 
LVL 32

Expert Comment

by:harbor235
ID: 22616915

Are .43 and .201 on different networks?

Remember teh ASA is a stateful inspection firewall, if it receives a packet out of sequence it will deny that packet.

i.e if an inside host tries to sent A RST without first establishing a flow the firewall will not like it. Could be an attack from the inside, could be some old connections not being flushed. Can you sniff say .43 and look at what its doing, flows, traffic , etc ...

harbor235 ;}
0
 
LVL 1

Author Comment

by:EODJack
ID: 22617370
The two hosts are on the same segment.

The 201 address is archiving files from an AS/400 and the 43 address is our AS/400 Admin.
0
 
LVL 32

Expert Comment

by:harbor235
ID: 22617440

If so i do not understand why the .201 host's traffic is even hitting the inside interface of the firewall.
Are your hosts connected to a switch or to a hub?

harbor235 ;}
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 
LVL 1

Author Comment

by:EODJack
ID: 22620045
All the hosts are connected to a 3Comm switch stack.  They are all configured with the ASA as the gateway.
0
 
LVL 32

Accepted Solution

by:
harbor235 earned 2000 total points
ID: 22634532
Right, but in a switched network traffic from .43 to .201 should never hit the interface of the firewall unless it was broadcast traffic, in this case it is TCP, something is going on there.

Is spannning tree disabled? Start at the .43 box put wireshark on it and see what it is doing

harbor235 ;}
0
 
LVL 32

Expert Comment

by:harbor235
ID: 22681192

What was the problem?

harbor235 ;}
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Use of TCL script on Cisco devices:  - create file and merge it with running configuration to apply configuration changes
A 2007 NCSA Cyber Security survey revealed that a mere 4% of the population has a full understanding of firewalls. As business owner, you should be part of that 4% that has a full understanding.
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Suggested Courses

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question