Solved

After applying service pack 2 and Moving to WDS natively, PXE boot fails

Posted on 2008-10-01
20
1,057 Views
Last Modified: 2012-05-05
I recently installed SP2 on my 2003 server.  This server is used only for RIS.

After the installation, SP2 also installed WDS.

All of my deployment images appear just fine.  I test pxe boot and it fails.

My DHCP server is on a different Windows 2003 server.

I have tried reconfiguring the service but I cannot not get clients to pxe boot or deploy computers.

Any and all help would be appreciated.
0
Comment
Question by:nappy_d
  • 12
  • 8
20 Comments
 
LVL 4

Expert Comment

by:ThorSG1
ID: 22621180
You need to re-install WDS as Mixed mode.  If the server is in Native mode then it will not allow you to download via PXE.  I had this problem when I first installed WDS.  I would recommend moving the directories the images are in out of the folder.  I don't believe that you will lose the images if you don't but safety is always a good policy.
0
 
LVL 4

Expert Comment

by:ThorSG1
ID: 22621204
Also you will have to run the Legacy setup.
0
 
LVL 32

Author Comment

by:nappy_d
ID: 22678232
Thanks for the responses so far.  Things seem to going in the right direction but now, this message is appears in my server's log and which I believe are preventing me from accepting or decling WDS client connection requests:.........

An error occurred while trying to create the machine account for the following device. Please ensure that the machine naming policy is valid and that the  service has the proper permissions in Active Directory Domain Services to create machine accounts.
 
 Machine Naming Policy: %MACn04
 User: Domain Admins
 OU: OU=Computers,OU=myOU,OU=myOU,OU=myOU,DC=Mydomain,DC=corp,DC=MyDC,DC=com
 MAC Address: 000000000000000000000010C6AA4530
 GUID: 4D69A91FDB3F3F2C810E9562188B99C3
 
 Error Information: 0x5
0
 
LVL 4

Expert Comment

by:ThorSG1
ID: 22680975
1.
First check the Log On As account for the Service: Windows Deployment Services (WDS) Server on the server running WDS.  In case you don't know where to find the services goto Start/Administrative Tools/Computer Management open the Services and Applications/Services.  Then find the service listed above.  My server is set to logon as: Local System account.

2.
Open Windows Deployment Services (Not the Legacy setup) drill down to the server name.  Right click and hit properties.  Open the Directory Services tab.  Check the settings.  Mine are as follows.  Yours may differ from mine.
Format: %61Username%#
Client account location: Same domain as the Windows Deployment Services server.

3.
Open the PXE Response Settings tab.  Mine is set to: Respond only to known client computers.

Respond only to known client computers. - Must have the computer account in active directory with the GUID.

Respone to all (known and unknown) client compters - Will allow any request to be processed if the user login has permission to add a computer to the domain.  You can also check the - For unkown clients, notify administrator and respond after approval.  I have never used this so I don't know how that works.

4.
Now go to the Advanced tab.  I've only ever used these settings.

Allow Windows Deployment Services to dynamically discover valid domain servers (recommended)

Yes, I wat to authorize the Windows Deployment Services server in DHCP

5.
Now check your default domain policy.  Under Computer Configuration/Windows Settings/Security Settings/Local Policies/User Rights Assignment, check to see if the appropriate Accounts/Groups have permission under the policy: Add workstations to domain.

6.
You should also check to make sure that your server has been added to DHCP as an authorized server.
0
 
LVL 4

Expert Comment

by:ThorSG1
ID: 22744840
Did this help you?  What problems are you having?
0
 
LVL 32

Author Comment

by:nappy_d
ID: 22768879
Sorry for the late response..

I had our AD admin delegate control of my WDS server for my specified container.

DHCP is authorized my DHCP and WDS are on separate boxes and was working previously under RIS.
I constantly get this error as shown in the screenshot.

On the other hand, I have some machines that are able to start the pxe client and wait for me to accept their connection in the WDS console.
PXE-errror.jpg
0
 
LVL 4

Expert Comment

by:ThorSG1
ID: 22800955
Try this.  I found it on several posts.  Here is one of them: http://forums.techarena.in/windows-server-help/706227.htm

Change the boot program for x86 to OSChooser\i386\startrom.com
0
 
LVL 4

Expert Comment

by:ThorSG1
ID: 22907602
Any luck on this issue?
0
 
LVL 32

Author Comment

by:nappy_d
ID: 22907627
Sorry none so far...I have started rebuilding the server as it is now in my vmware environment.  Maybe I will start over..can you hold on till Monday?
0
 
LVL 4

Expert Comment

by:ThorSG1
ID: 22907647
Let me know if you have any more problems.
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 
LVL 4

Expert Comment

by:ThorSG1
ID: 23003233
So how did it go?
0
 
LVL 32

Author Comment

by:nappy_d
ID: 23034202
I have reverted back to RIS as it just is not working out for me.  I have also moved my machine to vmware and wil apply a snapshot before attempting another WDS move.

Any tips or steps you have would be appreciated...
0
 
LVL 4

Expert Comment

by:ThorSG1
ID: 23073430
Sorry I was on vacation.
I would recommend reviewing this Guide:
http://technet.microsoft.com/en-us/library/cc771670.aspx
Having it on a VM will help if you are having problems.  As I stated before make sure to leave WDS in legacy or mixed mode.  If you move to legacy if will definately fail for you.
If you have any questions or concerns shoot me a message.
0
 
LVL 32

Author Comment

by:nappy_d
ID: 23192252
Hello ThorSG1, Gen. Hammond here(LOL).

So I now have my RIS hat back on.  

I have my server up and running on new hardware.

I have installed RIS on Server3

I have riprepped a system and uploaded it to the RIS server

Server 2 is running my DHCP

Server 2 has option 66 configured to point to server 3's ip

I could swer this was all I did about threee years ago.

This time, no IP is being given via DHCP

Any thoughts..
0
 
LVL 4

Expert Comment

by:ThorSG1
ID: 23194300
Open DHCP.  Click on DHCP above the server2's name.  Hit Manage Authorized Servers.
Make sure server3 is in the list.  If it is not add it.
If it is let me know there must be something else.
0
 
LVL 32

Author Comment

by:nappy_d
ID: 23194348
yes I have both servers authorized for DHCP Server 3(RIS BOX) has NO options configured for DHCP yet the service is running.

Server 2 has DHCP running, with option 66 configured for Server 3 and appears to be providing leases(160 so far)
0
 
LVL 4

Expert Comment

by:ThorSG1
ID: 23199728
DHCP does not have to be running on Server3.  I would uninstall DHCP from that server.
I also do not use option 66 in any of my Scope Options or Server Options.
In DHCP all you have to do is Authorize the server running RIS.
Try removing option 66 and remove DHCP from Server3.
If I remember correctly.  The RIS/WDS server receives a request and forwards or requests an ip address from the DHCP server to the client pc trying to attach.
Is there possibly a network issue.  For instance we have a Cisco switch that we must put a ip helper on the vlan setup that points to both the DHCP server and the WDS server.  We used to not need that setting until we upgraded to a new switch.
I only ask because you are not getting an IP address and you say that Server3 is Authorized in DHCP on Server2.  Depending on your hardware you may need to do something like this.  In our case RIS/WDS does not work and I do not get an IP address.
An example of what I'm talking about would be:
interface Vlan2
ip address 192.168.221.254 255.255.255.0
ip helper-address 192.168.221.10
ip helper-address 192.168.221.21
 
192.168.221.10 - Server2 Running DHCP
192.168.221.21 - Server3 Running RIS
On our switch both must be listed or RIS/WDS will not work.  I will not get an IP address during PXE.
Hope this helps.  Let me know.
0
 
LVL 32

Author Comment

by:nappy_d
ID: 23199795
OK so if I understand you;

Server 3 which has RIS does not need to have DHCP running but needs to be authorized for DHCP? SO I should just stop the DHCP service?

Server 2 which is provides DHCP leases should not need option 66 to point to Server 3?

I had this all running and then something horribly when wrong after an sp update.

If this is correct, I will give it a shot in the morning..
0
 
LVL 4

Accepted Solution

by:
ThorSG1 earned 500 total points
ID: 23200394
Stoping the service would be a start.  I would just uninstall it altogether.  It is not needed on the RIS server.
You do not need option 66 in DHCP to point to Server3.
I still question weather there is a broader network issue at play as well.  But start with those to items.  If you still don't get and IP address then look at your switch config.  See if you something that sends DHCP requests to Server2.  If there is then you will probably need to find a way to send DHCP to both Server2 and Server3.
0
 
LVL 32

Author Closing Comment

by:nappy_d
ID: 31502083
DOH!!! I did not disable the dhcp service as you rightfully suggested.  I kept thinking that the BINL service and DHCP were one in the same.

Looking good so far.  Now I have just troubleshoot why my riprepped image is not booting......

thanks again
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

This may not be a text book method to resolve VSS backup issues but it seemed to have worked on few of the Windows 2003 servers we had issues while performing a Volume Shadow Copy backup. If you have issues while performing a shadow copy backup usin…
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now