Solved

DMZ to Inside connection

Posted on 2008-10-01
13
846 Views
Last Modified: 2008-10-13
I have a new ASA 5505 firewall with Security Plus license that is configured with 3 interfaces--outside, inside and dmz. I can configure it to allow outside connections to the DMZ, inside and DMZ connections to the outside and inside connections to the DMZ.  I still need to allow connections from the DMZ to the inside so that a client or web server located in the DMZ can contact another web server on the inside network.  I have looked at all the documentation, knowledge base articles, etc, and am still coming up dry.  

Here is a summary of the interface IP assignments:
outside: single public address
inside network: 192.168.1.0 255.255.255.0; inside server: 192.168.1.25
dmz network: 192.168.2.0 255.255.255.0; dmz-web-server: 192.168.2.10

Although the outside is set to obtain an IP address from a DHCP server, this is a lab environment and any changes are monitored and incorporated.  Also, the inside and dmz web servers are set statically.

Can someone please help? I have read similar problems on this forum, but have been unsuccessful in getting them to work.
Thank you.
ASA Version 7.2(4)
!
hostname asaEast
domain-name mydomain.com
enable password oNRzEHTKYcYWDvTv encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
name 192.168.2.10 dmz-web-server
name 192.168.1.25 inside-server
name xxx.xxx.xxx.131 outside
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp setroute
!
interface Vlan3
 nameif dmz
 security-level 50
 ip address 192.168.2.1 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
 switchport access vlan 3
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
 domain-name mydomain.com
same-security-traffic permit inter-interface
access-list outside_access_in extended permit tcp any host outside eq www
access-list dmz_access_in extended permit tcp host dmz-web-server host 192.168.2.25 eq www
access-list dmz_access_in extended permit icmp host dmz-web-server host 192.168.2.25
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
global (inside) 1 192.168.1.75-192.168.1.100 netmask 255.255.255.0
global (dmz) 1 192.168.2.50-192.168.2.75 netmask 255.255.255.0
nat (inside) 1 192.168.1.0 255.255.255.0
nat (dmz) 1 192.168.2.0 255.255.255.0
static (dmz,outside) tcp interface www dmz-web-server www netmask 255.255.255.255
static (inside,dmz) 192.168.2.25 inside-server netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 129.130.27.240 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet 192.168.2.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address inside-server-192.168.1.50 inside
dhcpd dns 129.130.254.2 129.130.254.3 interface inside
dhcpd enable inside
!
dhcpd address dmz-web-server-192.168.2.20 dmz
dhcpd dns 129.130.254.2 129.130.254.3 interface dmz
dhcpd enable dmz
!
 
!
!
prompt hostname context
Cryptochecksum:513f12e2d588cd9f4391b3979b759ef0
: end

Open in new window

0
Comment
Question by:InOz
  • 5
  • 5
  • 3
13 Comments
 
LVL 13

Expert Comment

by:Quori
ID: 22618785
You would need to add an ACL (Inside_access_in) and permit specific traffic there.
0
 
LVL 33

Expert Comment

by:MikeKane
ID: 22618786
You haven't applied the access group for the dmz interface

access-group dmz_access_in in interface dmz

0
 

Author Comment

by:InOz
ID: 22619072
To MikeKane-- you're right, I did forget to bind the access-list to the interface, but after I did that, still no joy.

To Quori-- I wonder why the access-list (dmz_access_in) is not accomplishing this. If I need to add another access list entry (inside_access_in), what would it look like?  Currently it allows access from the dmz web server to the inside server by translating its dmz address (192.168.2.10 to  192.168.2.25).  I did change the translated address to 192.168.1.20, but no joy here either.
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 
LVL 13

Expert Comment

by:Quori
ID: 22619090
dmz_access_in is for traffic going into the interface. With the way ASA security levels work, DMZ traffic is implicitly being denied access to a higher security level (50 to 100).

So, you use inside_access_in to allow INBOUND traffic from the DMZ into internal.
0
 
LVL 13

Expert Comment

by:Quori
ID: 22619112
At least, thats how I got my ASA to play ball. It is entirely possible I boned something and don't realise it ;)
0
 
LVL 33

Expert Comment

by:MikeKane
ID: 22619207
That's not correct.   Inside access in in int inside would be used for connections originating from the inside and the ACL would allow or deny them to the interface.  


I have a feeling one of your nat's or statics might be to blame.  

run a SHOW XLATE and see what addresses are being handed out.  

0
 

Author Comment

by:InOz
ID: 22619320
Show xlate returns:

3 in use, 73 most used
Global 192.168.2.25 Local inside-server
PAT Global outside(80) Local dmz-web-server(80)
Global 192.168.2.51 Local inside-server
 
0
 
LVL 33

Expert Comment

by:MikeKane
ID: 22664043
Global 192.168.2.25 Local inside-server
Global 192.168.2.51 Local inside-server

Your inside server is grabbing the static and a NAT'd address to the DMZ.  

You also have not assigned your Inside VLAN to an interface....  

You need to Add that access-group to the DMZ in interface command.  

POst the new code after these are complete.  

In your ASA's syslog, you can see packets being dropped and if it is because of an ACL, this will tell you which is to blame.    

0
 

Author Comment

by:InOz
ID: 22664706
Attached is the new configuration file.  The inside vlan is assigned to all interfaces by default when you use the Startup Wizard in the ASDM.  Just to be sure, I ran a switchport access command to assign interface Ethernet0/0 to the inside.  Afterwards, the conf file remained as it was, so I think that part is okay.  Anyway--now I have access from the inside to the dmz, from the dmz to the inside, but no access from the outside to the dmz nor from the dmz to the outside.  The syslog tells me that the dmz_access_in access-list is the culprit.  
ASA Version 7.2(4) 
!
hostname asaEast
domain-name netlab.ksu.edu
enable password oNRzEHTKYcYWDvTv encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
name 192.168.2.10 dmz-web-server
name 192.168.1.25 inside-server
name xxx.xxx.xx.131 outside
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp setroute 
!
interface Vlan3
 nameif dmz
 security-level 50
 ip address 192.168.2.1 255.255.255.0 
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
 switchport access vlan 3
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
 domain-name netlab.ksu.edu
same-security-traffic permit inter-interface
access-list outside_access_in extended permit tcp any host outside eq www 
access-list dmz_access_in extended permit tcp host dmz-web-server host 192.168.2.25 eq www 
access-list dmz_access_in extended permit icmp host dmz-web-server host 192.168.2.25 
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu dmz 1500
no failover
monitor-interface outside
monitor-interface inside
monitor-interface dmz
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
global (inside) 1 192.168.1.75-192.168.1.100 netmask 255.255.255.0
global (dmz) 1 192.168.2.50-192.168.2.75 netmask 255.255.255.0
nat (inside) 1 192.168.1.0 255.255.255.0
nat (dmz) 1 192.168.2.0 255.255.255.0
static (dmz,outside) tcp interface www dmz-web-server www netmask 255.255.255.255 
static (inside,dmz) 192.168.2.25 inside-server netmask 255.255.255.255 
access-group outside_access_in in interface outside
access-group dmz_access_in in interface dmz
route outside 0.0.0.0 0.0.0.0 129.130.27.240 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 60
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address inside-server-192.168.1.50 inside
dhcpd dns xxx.xxx.xxx.2 xxx.xxx.xxx.3 interface inside
dhcpd enable inside
!
dhcpd address dmz-web-server-192.168.2.20 dmz
dhcpd dns xxx.xxx.xxx.2 xxx.xxx.xxx.3 interface dmz
dhcpd enable dmz
!
 
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny 
  inspect sunrpc 
  inspect xdmcp 
  inspect sip 
  inspect netbios 
  inspect tftp 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:548ad1dda89517ad98628f7136eac217
: end
asdm image disk0:/asdm-524.bin
asdm location dmz-web-server 255.255.255.255 inside
no asdm history enable

Open in new window

0
 
LVL 33

Assisted Solution

by:MikeKane
MikeKane earned 250 total points
ID: 22664723
I don't think you can use
global (outside) 1 interface
and
static (dmz,outside) tcp interface www dmz-web-server www netmask 255.255.255.255
At the same time.....   I'll have to read up on that to be sure, unless another expert wants to jump in there.  

If I'm right, you'll just have to use a port forward command instead of the 1 to 1 static.  

Standby......
0
 

Author Comment

by:InOz
ID: 22664771
Tell me how to set up a port forward command
0
 
LVL 33

Assisted Solution

by:MikeKane
MikeKane earned 250 total points
ID: 22668612
Port forwarding for your scenario is as follows:

static (dmz,outside) tcp interface www dmz-web-server www


On the other issue I was looking at, I know for certain that you can't create 2 statics to the same internal address, I'm still looking for the documentation or proof on using the global interface with a static of the same ip.....
0
 

Accepted Solution

by:
InOz earned 0 total points
ID: 22669851
See below for the new set of access rules and statics.  It now works.

access-list outside_access_in extended permit tcp any host outside eq www
! the next line uses a new public IP address for the dmz server
access-list outside_access_in extended permit tcp any host xxx.xxx.xxx.43 eq www 
access-list acl_dmz extended permit ip 192.168.2.0 255.255.255.0 any
access-list dmz_access_in extended permit tcp host dmz-web-server host 192.168.2.25 eq www
access-list dmz_access_in extended permit icmp host dmz-web-server host 192.168.2.25
global (outside) 1 interface
global (inside) 1 192.168.1.75-192.168.1.100 netmask 255.255.255.0
! set up PAT for dmz on outside interface
global (dmz) 3 interface
nat (inside) 1 192.168.1.0 255.255.255.0
nat (dmz) 1 192.168.2.0 255.255.255.0
static (dmz,outside) tcp xxx.xxx.xxx.43 www dmz-web-server www netmask 255.255.255.255
static (inside,dmz) 192.168.2.25 inside-server netmask 255.255.255.255
access-group outside_access_in in interface outside
access-group acl_dmz in interface dmz

Open in new window

0

Featured Post

Gigs: Get Your Project Delivered by an Expert

Select from freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Optimal Xbox 360 connectivity requires "OPEN NAT". If you use Juniper Netscreen or SSG firewall products in a home setting, the following steps will allow you get rid of the dreaded warning screen below and achieve the best online gaming environment…
Network traffic routing plays key role in your network, if you have single site with heavy browsing or multiple sites, replicating important application data from your Primary Default Gateway ,you have to route your other network traffic from your p…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…

813 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now