[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3031
  • Last Modified:

error while trying to run project: Unable to start debugging on the web server. Your do not have permissions to debug the server.

I am getting this error when i try to debug a project.
I am running on windows 2003 server. I have admin rights and am the member of debugger role.
Framework on IIS is 1.1 and the project is 1.1 framework.

When i try to debug a project i get this error.

error while trying to run project: Unable to start debugging on the web server. Your do not have permissions to debug the server.
Verify that you are a member of the 'Debugger Users' group on the server.


0
nirisan
Asked:
nirisan
  • 6
  • 3
  • 2
1 Solution
 
SameerJagdaleCommented:
check if the virtual directory is available in IIS, further check if application name exists if not , click the remove button and then create .. this will create application name.
try hitting f5 then.
0
 
nirisanAuthor Commented:
I attached process to wp3.exe process and put breakpoints and thwn was able to debug
0
 
nirisanAuthor Commented:
I found the solution as suggested above.
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
SameerJagdaleCommented:
It worked?
0
 
nirisanAuthor Commented:
yes.
0
 
nirisanAuthor Commented:
i mean my solution worked..not yours..thanks anyway
0
 
SameerJagdaleCommented:
ok.
0
 
nirisanAuthor Commented:
found answer as suggested by my own comment
0
 
ebusinessCommented:
Hi,
Im not able to attach process.  Clicking Debug -> Processes from VS.Net 2003, it throws below message.
---------------------------
Microsoft Development Environment
---------------------------
Processes cannot be displayed. Access is denied. Verify that you are an administrator or a member of the 'Debugger Users' group on the machine you are trying to debug. After being added to the 'Debugger Users' group, you must log off and log back on for the setting to apply.
---------------------------
OK  
---------------------------

Please give me the solution.  I couldn't able to debug my project in VS.Net 2003.
Thanks
0
 
nirisanAuthor Commented:
call your project on the your computer in IE. like http://locahost....

in VS2003
place breakpoints in project like in page_load
 select debu> processes
Win the window that opens scroll down to w3wp.exe ..something similar for XP users...
then click attach.

now refresh the page in IE and you should hit the breakpoint.
0
 
ebusinessCommented:
I can able to run the project from IE like http://localhost/projectname, but Clicking Debug > Process throws the below error.  I couldn't able to attache the wp3.exe process to it.

---------------------------
Microsoft Development Environment
---------------------------
Processes cannot be displayed. Access is denied. Verify that you are an administrator or a member of the 'Debugger Users' group on the machine you are trying to debug. After being added to the 'Debugger Users' group, you must log off and log back on for the setting to apply.
---------------------------
OK  
---------------------------

0

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

  • 6
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now