Need helping restoring my Cisco ASA 5505

Posted on 2008-10-01
Last Modified: 2012-06-27
I had a working Cisco ASA 5505 that I was trying to enable users over the Internet  to access  a device on ports 8000-8010, when I completely messed up the whole unit.  Before I began my adventure I did a backup of the Configuration.  I have since reset to factory settings using the CLI.  I can not open it using the GUI.  It keeps prompting me for a username and password, which I don't have.  I tried to leave it blank.  It won't let me back in.....  The ASA is set to  I need to be able to restore the saved config file!!!!  Please assist.
Question by:trinle
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
LVL 12

Expert Comment

ID: 22621444
Can you please send me the backup config you had?
The default password and username are Cisco and Cisco
LVL 12

Assisted Solution

Pugglewuggle earned 100 total points
ID: 22621449
Sorry - that's on routers. The default password on ASAs is blank. Not the word blank, but just nothing.
Also, you won't be able to access it except by the console port with a serial cable unless you put your PC on the inside interface and then try to connect to the PC's default gateway - that's the ASA's IP address because the factory default has DHCP enabled by default.
LVL 12

Expert Comment

ID: 22621453
If you can't get in by IP connect with the console cable and a terminal emulator like PUTTY. 
Portable, direct connect server access

The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.


Author Comment

ID: 22621467
I will be back onsite in the AM tomorrow......
I have a server connected via Console cable to the ASA.  The server's IP is  The ASA has the default IP of
I used Hyper Terminal to console in to the ASA.
How do I restore the backup file that I saved?

Expert Comment

ID: 22621521

Here is procedure for password recovery.
After that you can login again and restore the backup file via GUI or CLI.
LVL 12

Expert Comment

ID: 22621527
You need to first establish IP communication to the device. This just means get the ASA and the server so they're able to ping each other.
Then, run a TFTP program on the server. I recommend Pumkin - good and free. Put the config file in the TFTP root (change it to something like C:\TFTP if you're using Pumpkin).
Then run the following command on the ASA:
copy tftp run
Just fill in the blanks and that should do it! Pumpkin will ask you to accept if it's working.
If you don't get an accept prompt on Pumpkin then something's wrong.
Tell me if that works!
LVL 12

Expert Comment

ID: 22621532
I will recommend against the password recover feature unless either blank, Cisco, or cisco don't work. It's case sensitive - one Cisco is capitalized the other isn't.
If it doesn't work it would be easier to just factory reset than to go through the whole recover process. It doesn't matter since it doesn't have a valid config anyways.
LVL 79

Accepted Solution

lrmoore earned 200 total points
ID: 22623599
Fortunately, the password recovery procedure is quick and painless.
You can also just use cut/paste in hyperterm. You can open the old config in notepad, edit/select all / copy then with the firewall in config mode, just choose paste to host and watch it.
LVL 12

Expert Comment

ID: 22626924
This is true, but I'm lazy. Prepping a script, executing it and all that just takes longer than pressing a button. But then again, it is just 10 minutes! :-P lol

Author Comment

ID: 22639324
I was able to Hyper-Terminal in and go into Config mode and copy and paste the Configs from the backup I made, thanks Irmoore.  A tech named Travis assisted in setting up the Forwarding for our GPS device.  A thanks Pugglewuggle for your input too!      

Author Closing Comment

ID: 31502261
I tried the Pumpkin without TFTP tool though.  I didn't need to reset the password.  I figured out that it kept the old password even after I set it to defaults????  Thanks guys for your prompt responses.

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Port status messages not appearing in console 11 59
Cisco Anyconnect on MS Surface 12 51
Objects in Cisco ASA 2 58
Netgear Router 5 G 11 52
The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
After creating this article (, I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question