Solved

SQL Management Studio can't browse all my files when trying to attach a DB...

Posted on 2008-10-01
6
616 Views
Last Modified: 2012-05-05
Background:
I have created a database within Visual Studio.  The project is stored within MyDocuments\VisualStudio2008\Projects

Problem:
When I open up SQL Management Studio (connect via Windows Auth)...  I right click on databases and then select "attach"...  I then click add and try to navigate to my project folder.  At this point it will not let me browse beyond c\docs&settings\myUser

Question
How do I make it so that I can browse to thos edatabase files so I can attach them...

One thing I can think to do BUT I am not sure if ts safe to so is to give the SQLServerMSSQLUser$"myUserName"$SQLExpress full control or at least read control to my entire user account folder?  Is there any problems with doing that?

0
Comment
Question by:jasonwsaz
  • 2
  • 2
6 Comments
 
LVL 29

Expert Comment

by:QPR
ID: 22621566
When you say you can't browse beyond do you mean the folders aren't visible or you get access denied when you try to open them?
Does the windows account you use to log on to sql with have the necessary permissions to access that folder because that is the account being used when you are traversing the file system.
0
 
LVL 8

Expert Comment

by:Julianva
ID: 22621786
Add the account that starts sql server to the administrators group on the server that have the files.

not this account - SQLServerMSSQLUser$

the account that starts the SQL service.
0
 
LVL 29

Expert Comment

by:QPR
ID: 22621809
Just to be able to open/see a folder? isn't that overkill?
If the original poster is doing this manually and logging on via windows authentication then surely it is their credentials that are being used to navigate to the bak/mdf file?
0
 

Accepted Solution

by:
jasonwsaz earned 0 total points
ID: 22623837
hmm...  actually before you guys responded I added full control to my documents to SQLServerMSSQLUser$

seemed to solve the problem...

Julianva - how do I figure out which user starts the SQL service?

QPR - When I would click on the little "+" sign next to the folder it would imply disapear as if nothing was in the folder.  By adding the user above the the respective folder it works now and I can browse the content of the folder.
0
 
LVL 8

Expert Comment

by:Julianva
ID: 22623901
no user starts the sql service, you either have a domain account to start SQL service or you have the local account that starts the service.

go to control panel

choose administrator tools - then services - look for SQL server
then double click - choose the logon tab you will see what account starts SQL service
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

JSON is being used more and more, besides XML, and you surely wanted to parse the data out into SQL instead of doing it in some Javascript. The below function in SQL Server can do the job for you, returning a quick table with the parsed data.
International Data Corporation (IDC) prognosticates that before the current the year gets over disbursing on IT framework products to be sent in cloud environs will be $37.1B.
Familiarize people with the process of retrieving data from SQL Server using an Access pass-thru query. Microsoft Access is a very powerful client/server development tool. One of the ways that you can retrieve data from a SQL Server is by using a pa…
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now