RDP-TCP Config Environment Initial Program Greyed out

Hi
I was playing around with Group Policy the other day to auto start a program when logging into Terminal Services on Server Ent 2003 SP1.
RDP now starts a program when any user logs into the server.  I don't want the program to start for every user who RDPs to server (esp Adminstrator). In Terminial Services Configuration > Connections > Properties.  the Environment tab is greyed out and I cannot remove the program and path file name.
I thought I'd removed all policies relating to Terminal Services.
Can anybody help.
Thanks
Sara
geekgAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
geekgConnect With a Mentor Author Commented:
Thanks.
I went through RSOP and couldn't find any entry's relating to terminal services.
But have managed to fix the problem.  
Went into Local Policy of Domain Controller (gpedit.msc).  Everything was set to not configured as is should be.  I disabled in both computer and user - Administrative Templates > Terminal Services > 'Start a program on connection'.
Checked the environment tab in rdp-tcp.  Not grey anymore.
Then went back into gpedit and set to Not Configured again.
Rebooted the server just to make sure.
All working now.
Thanks for your help
0
 
dfkeConnect With a Mentor Commented:
Greyed out settings on the Remote Control tab in the rdp-tcp properties  mean that there still is a Group Policy which prohibits remote Control.
Check all GPOs which affect your Terminal Server.

Run rsop.msc (Resultant Set of Policies) to see which GPOs still apply.
0
 
geekgAuthor Commented:
Problem solved
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.