Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

No sound when playing videos in any player - various codec packages installed/uninstalled

Posted on 2008-10-02
16
Medium Priority
?
934 Views
Last Modified: 2013-12-07
It all started when I went to play a .avi video which I downloaded from my camera - by default it opens in Windows Media Player, it plays the video but there is no sound, an error (red cross) appears to the left of the file name on the right side of the player which, when clicked upon, takes me to a support site telling me I am missing an audio codec.

I then tested other video formats and players and found the following -

.avi and MPEG -
No sound in Ulead Video Studio
No sound in Windows Media Center
No sound in Divx Player

.Divx
Sound worked in DivX player

I had already downloaded and installed the Vista Codec Package (by shark) so I tried another package which probably just overwrote the same codecs and I tried installing the AAC Directshow Filter Codec separately.

None of this worked, so I uninstalled them all and installed the latest driver for my Creative Labs XFi Fatl1ty card - this didn't work either.

I then tried system restore and went back a few days where some Windows updates had been installed, but this didn't restore the sound either.

So I started again, going onto Google and acquiring information and trying this and that and eventually found myself going round in circles.  It seems that I definitely have an audio codec problem but cannot seem to fix it.

I used Gspot and loaded in a few of my video files and it simply told me that there was an error acquring information on the audio codec.

All system sounds and music work fine.

Do I have a damaged codec?  Any ideas on restoring all my default Vista codecs so that I can start again?

Any help would be greatly appreciated as this is driving me nuts.
0
Comment
Question by:fuzzyfreak
  • 9
  • 4
  • 2
  • +1
16 Comments
 
LVL 10

Expert Comment

by:TCB1
ID: 22624162
You could try Quicktime Alternative. It's worked well for me. Also you might find other codec related stuff on the site.
http://codecguide.com/about_qt.htm
0
 
LVL 22

Expert Comment

by:fredshovel
ID: 22628692
Sounds like this is a divx avi file. Is this only happening on the one avi file?
If so here may be a solution: Get yourself a copy of Super (it's invaluable anyway).
http://www.afterdawn.com/software/video_software/video_encoders/super.cfm

Drop the file into Super and convert it to another format -- including the audio -- if it won't convert then there is a problem with the file -- not your PC.
You can (in minutes) convert a file in Super to just about anything, but I would suggest for the first test to convert to MPEG-1 for the video and MPEG-2 for the audio --
In the display box tick "no change" (to the display resolution) The reason I would suggest MPEG-1 is that you may not have the MPEG-2 video codec in your WMP (as it doesn't come standard).


0
 
LVL 10

Expert Comment

by:TCB1
ID: 22629917
Yes, Super is a great utility.
0
[Webinar] Cloud Security

In this webinar you will learn:

-Why existing firewall and DMZ architectures are not suited for securing cloud applications
-How to make your enterprise “Cloud Ready”, and fix your aging DMZ architecture
-How to transform your enterprise and become a Cloud Enabler

 
LVL 4

Author Comment

by:fuzzyfreak
ID: 22632262
No, the problem is with all video files, regardless of format.  avi and .mpeg have been tested.  I haven't tested my divx files for a while but last time I tried (when the problem first occurred) they worked fine.
0
 
LVL 4

Author Comment

by:fuzzyfreak
ID: 22632265
Oh, and the .avi files I am having problems with - they are not divx
0
 
LVL 4

Author Comment

by:fuzzyfreak
ID: 22636694
I installed Quicktime and it does play the avi files with sound but will not play my MPEG files at all.  This doesn't solve my issue, does anybody actually know what the problem is?
0
 
LVL 22

Expert Comment

by:fredshovel
ID: 22638144
Not sure how to do this in Vista -- but you need to check which soundcard Vista has selected as the default and to check the Windows mixer to see that nothing's muted or turned down too far.
In XP you go to Start Menu /Control Panel / Sounds and Audio Devices -- clik on Audio Tab and make sure you soundcard is correctly selected in the "Sound Playback" box.
0
 
LVL 4

Author Comment

by:fuzzyfreak
ID: 22638196
This isn't a volume issue, it is a codec issue - thanks anyway.

I am currently working on it and am going round in circles.  I just installed the AC3filter for the third time because Windows Media Player gave me the error code C00D10D1.

Incidentally GSpot says there are no problems with audio and no codec is needed for PCM audio.

I just went back into Ulead to try again and discovered that it will not play sound on the clip preview but will when playing the entire project - presumably because it renders it in it's own codec and doesn't rely on PCM.

Anyway, sticking to the original problem, I can not hear audio when playing avi or mpeg in Ulead, WMP, WMC or DivX player.
0
 
LVL 4

Author Comment

by:fuzzyfreak
ID: 22658305
A further clue.  I tried playing these files on another user profile on this machine and it plays them fine, with sound, no problem.  This is now a profile specific issue.

Incidentally, I also tried playing the vids in Winamp - again they play fine.
0
 
LVL 10

Expert Comment

by:TCB1
ID: 22659594
Have you tried using System Restore to go back to a time when the sound worked properly within your profile?
0
 
LVL 4

Author Comment

by:fuzzyfreak
ID: 22660243
Yes, tried that - see original post.  Trouble is, Vista doesn't go back any further than about 5 days.
0
 
LVL 27

Expert Comment

by:Asta Cu
ID: 22723788
Is your OS 32 or 64 bit?  Could be an issue if you're running 64 and codecs are 32, other possibilities may be helpful here:
Codecs: frequently asked questions - Vista
http://windowshelp.microsoft.com/Windows/en-US/Help/3d0c5a49-8f61-45cc-8a7d-38c4695ba9291033.mspx#EEE
http://www.microsoft.com/windows/windowsmedia/player/faq/codec.mspx
http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=821790&SiteID=1

The fact that the computer provides sound to other users and you're blocked says you're loading a startup that includes an incompatible interface/driver that others without the problem aren't loading.  Might help to see startup apps/interfaces.

Asta
0
 
LVL 4

Author Comment

by:fuzzyfreak
ID: 22811238
I am almost convinced this relates to a corrupt driver or codec but am confused about the issue only being on my profile.  I have spent so long trying to fix this issue that I have decided one one last thing, a repair.  Can I simply put the Vista DVD in the drive while Windows is running, or do I have to boot from it and select repair?  what will it repair?

If this fails, I will be going back to Windows XP - I run this on all machines in the office with no problems.  I figure the only big loss will be the backup facility and the ability to click once on a file name to rename it and it doesn't highlight the extension - I like this feature but if that is all I'll miss then why spend any more time trying to fix this problem?
0
 
LVL 4

Author Comment

by:fuzzyfreak
ID: 22920087
Well, seeing as I have had no further help on this, I can only update my findings.  I created a new profile and tried playing the videos in this - no problem.  I noted that the FFDShow codec appeared in the system tray as I played them with Windows Media Player.  So I went back to my profile and downloaded the latest FFDShow program and installed it but this did not help - I could not get into the FFDShow console due to a dll error - as if it hadn't installed properly.

I am now very close to going back to Windows XP - never had these codec issues in that.
0
 
LVL 10

Expert Comment

by:TCB1
ID: 22922802
Maybe you could try re-registering  that dll or find a copy if it's missing?
0
 
LVL 4

Accepted Solution

by:
fuzzyfreak earned 0 total points
ID: 22974340
I am going to request that this question be archived.  I very much appreciate all the help I have had from all who have contributed, however I still haven't resolved this issue.  I know it was caused by the installation of some software which has corrupted something in my profile but haven't a clue what it could be so I will be reverting to XP at the earliest opportunity.
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The main issue when installing Vista and XP in dual boot is when you have to reinstall any of the two when something fails, let's say a hard disk failure, a lost partition, virus, etc. What commonly happens is that you lose all your hard work config…
There are many reasons a PC runs slower than when it was new, ranging from malicious software intended to mess things up to simple general Windows use.  Your PC performance may slowly degrade over time without you noticing but when you buy a PC from…
Viewers will learn how to use Macros for greater control over Rack parameters in Ableton Live. Group devices into a Rack by selecting them and pressing Command-G (Ctrl-G on PC): Control-click (Right Click on PC) a parameter to access pop-up menu, …
Viewers will learn key ranges in Sampler to make their sampled instruments sound more realistic Gather samples of various notes and drag them to Key Range panel: Set proper root key for each sample: Select all the samples with Command-A (or Ctrl…
Suggested Courses

916 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question