Ubuntu sudo Ifup eth1 problem

The OS is Ubuntu 2.6.24-19-386. I was wondering why every single time I boot up the machine then I need to do as below in order to get wireless internet connection.

$sudo ifdown eth1
$sudo ifup eth1

Here is the thing! The interface of eth1 is already up after I boot up the machine. Why do I need to bring it down and bring it up again to get the ip address? Maybe I should use another command to obtain the ip that I don't know. Besides, windows XP does not have this kind of problem. As long as the machine is up, the wireless connection is connected and ready to use. I don't need to do ipconfig release/all and renew blah blah blah to obtain ip address. Please let me know what is the proper way to deal with my situation. I am new to Linux. Thanks!
alfredng1Asked:
Who is Participating?
 
wesly_chenCommented:
Based on your kernel version, I assume you have Ubuntu 8.04 (hardy).

My wireless is connected when I boot up my Dell D600 laptop.
What I did is
1. Go to  System--> Administration--> Network
And unlock it.
2. Double click on "Wireless connection" under "Connections" tag.
uncheck the "Enable roaming mode" and set the ESSID, "password type" and "Network password".
Then change the "Configuration to "Automatice configuration (DHCP)".
3. Save the change.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.