Upgrading to 3.5 framework on Windows Server 2003

I downloaded VWD2008 and created a web site that uses LINQ heavily.
It was only then that I realized we don't have the 3.5 framework on our Intranet server (where the project is to be used).
This is our first ASP.Net application on this server so I don't need to worry about breaking any 1.1 / 2.0 progams.
I installed the dotnetfx35.exe on this Windows Server 2003 machine, but I still cannot select version 3.5 on my website properties.

Question: What am I missing?
LVL 13
jmundsackAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Snarf0001Commented:
Select version 2.
As long as 3.5 is on the machine, the extra parts will be used, but it uses the same asp reg as 2.0.
0
jmundsackAuthor Commented:
Oh...

Then I think I have asked the wrong question.  You see I used the "Copy Website" function in VWD2008 to install the application on the server, and now when I run the application I am getting an error which I *assumed* meant that somehow my 3.5 installation wasn't being recognized.  Could I impose on you to theorize about the cause of this error, or should I enter a new question?

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load file or assembly 'System.Web.DynamicData, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

Source Error:

Line 50:         <add assembly="System.Data.DataSetExtensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
Line 51:         <add assembly="System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
Line 52:         <add assembly="System.Web.DynamicData, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
Line 53:         <add assembly="System.Web.Routing, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
Line 54:         <add assembly="System.Web.Abstractions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />

Source File: C:\Inetpub\wwwroot\hal\web.config    Line: 52

Assembly Load Trace: The following information can be helpful to determine why the assembly 'System.Web.DynamicData, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' could not be loaded.

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433
0
Snarf0001Commented:
Strange, should have been taken care of when you installed 3.5.
Let me hunt for a moment and see if i can come up with anything.
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

Snarf0001Commented:
Aha, i believe some of those (DynamicData, etc) were not part of 3.5 originally, but part of sp1 or sp2.  Did you install the service packs as well?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jmundsackAuthor Commented:
Aha!  No... I did not.  Let me see if that fixes the error.
0
jmundsackAuthor Commented:
Whoops...  apparently I *did* install sp1.  This was the download page I used:

http://www.microsoft.com/downloads/details.aspx?FamilyId=AB99342F-5D1A-413D-8319-81DA479AB0D7&displaylang=en

I selected the "Full Package" link at the bottom because system policies beyond my control prevent Internet access from the server.

I wonder if that has something to do with it.
0
Snarf0001Commented:
Hmm, strange.
Not quite sure what it would be then...  you did have 2.0 installed first, yes?
0
jmundsackAuthor Commented:
Yes.

Do you think maybe I should uninstall *all* frameworks, then re-install 3.5 (which reportedly *contains* all the previous versions)?
0
Snarf0001Commented:
Check out this link, seems to be the same problem you're having, with some possible solutions:

http://forums.asp.net/p/1173067/2133738.aspx
0
jmundsackAuthor Commented:
Actually....  Now I think it IS the service pack issue!

When I went to microsoft.com to download sp1 after you suggested it, the link for the full download was purple (meaning I'd already visited that link before), so I assumed this was the file I downloaded and didn't proceed.

But just now I went to the page for 3.5 original release (not sp1) and that link was purple too.  So I think that's the one I downloaded.  (Do you have this file so I could compare the "Version" information?  Mine says, "File version: 3.5.21022.8".  I'm curious to know if the sp1 full package download has a different version number.)

I must have tried to download the sp1 file yesterday at some point and the download failed or was interrupted.  The problem is I access the Internet through my work PC and they have a virus scan running on some distant proxy server for every file that gets downloaded -- and it keeps crapping out whenever it tries to scan this particular file!

I think somehow I ended up on the framework 3.5 (non-sp1) page this morning (when I was able to finally download the file), and didn't realize that there were in fact two separate download pages and I was on the wrong one.

So unless I can get this sp1 download to work, I'm going to have to download it from home, and bring it in on a flash drive, so I won't know until tomorrow if that was the issue.
0
jmundsackAuthor Commented:
Thank you for all your help!  It's working perfectly now with framework 3.5 sp1 installed.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
.NET Programming

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.