Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

WEB server access

Posted on 2008-10-02
1
Medium Priority
?
309 Views
Last Modified: 2010-05-18
have a Cisco 5521, trying to set up a Exchange server on the inside, and forward port 443 to it.  the Exchange server inside IP is the 172.20.245.2 the out side IP that we want to use is the 97.xxx.xxx.2 address.

we have confirmed that it works on the inside, we have even temporally turned off the firewall on the exchange box.  The Exchange server can get to the Internet, so the default gateway is correct and we have confirmed that is the firewall.

on the outside it just times out, when we look at the log in ASDM it does not show any rejected activity.  Set up wireshark to capture packets, did not see any coming for the outside test address.

:
ASA Version 8.0(3)
!
hostname fw-asa1
domain-name xxxxxxx.local
enable password xxxxxxxxxxxxxxxxxx encrypted
names
dns-guard
!
interface Ethernet0/0
 nameif outside
 security-level 0
 ip address 97.xxx.xxx.253 255.255.255.0
!
interface Ethernet0/1
 nameif DMZ
 security-level 50
 ip address 192.168.80.254 255.255.255.0
!
interface Ethernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/3
 nameif inside
 security-level 100
 ip address 172.20.255.253 255.255.0.0
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
 management-only
!
passwd aQJifQUNaDM1h.m4 encrypted
boot system disk0:/asa803-k8.bin
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
dns server-group DefaultDNS
 domain-name xxxxxx.local
access-list outside_acl remark Domain Name server; 4 lines
access-list outside_acl extended permit tcp any host 97.xxx.xxx.100 eq domain
access-list outside_acl extended permit tcp any host 97.xxx.xxx.101 eq domain
access-list outside_acl extended permit udp any host 97.xxx.xxx.100 eq domain
access-list outside_acl extended permit udp any host 97.xxx.xxx.101 eq domain
access-list outside_acl extended permit tcp any host 97.xxx.xxx.19 eq www
access-list outside_acl remark OWA
access-list outside_acl extended permit tcp any host 97.xxx.xxx.2 eq https
access-list dmz_acl extended permit icmp 192.168.80.0 255.255.255.0 192.168.80.0 255.255.255.0
access-list dmz_acl extended permit tcp any 192.168.80.0 255.255.255.0 eq www
access-list dmz_acl extended permit udp host 172.20.245.4 host 192.168.80.252 eq domain
access-list dmz_acl extended permit tcp host 172.20.245.4 host 192.168.80.252 eq domain
access-list dmz_acl extended permit udp host 172.20.245.4 host 192.168.80.252 eq ntp
access-list dmz_acl extended permit tcp 192.168.80.0 255.255.255.0 172.20.0.0 255.255.0.0 eq 3389
access-list dmz_acl extended permit icmp 192.168.80.0 255.255.255.0 172.20.0.0 255.255.0.0
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu management 1500
mtu DMZ 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-602.bin
no asdm history enable
arp timeout 14400
global (outside) 1 97.xxx.xxx.150-97.xxx.xxx.250
nat (inside) 1 172.20.0.0 255.255.0.0
nat (DMZ) 1 192.168.80.0 255.255.255.0
static (outside,inside) tcp 172.20.245.2 https 97.xxx.xxx.2 https netmask 255.255.255.255
static (DMZ,outside) 97.xxx.xxx.19 192.168.80.19 netmask 255.255.255.255
static (DMZ,outside) 97.xxx.xxx.252 192.168.80.252 netmask 255.255.255.255
static (inside,DMZ) 192.168.80.0 172.20.0.0 netmask 255.255.255.0
access-group outside_acl in interface outside
access-group dmz_acl in interface DMZ
route outside 0.0.0.0 0.0.0.0 97.xxx.xxx.254 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
aaa-server RADIUS protocol radius
aaa-server RADIUS host 172.20.245.3
 key msdck3y
aaa authentication ssh console RADIUS
http server enable
http 192.168.1.0 255.255.255.0 management
http 172.20.13.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto isakmp enable outside
crypto isakmp policy 5
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 10
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 11
 authentication pre-share
 encryption 3des
 hash md5
 group 1
 lifetime 86400
crypto isakmp ipsec-over-tcp port 10000
telnet timeout 5
ssh 206.xxx.xxx.14 255.255.255.255 outside
ssh 66.xxx.xxx.5 255.255.255.255 outside
ssh 172.20.13.0 255.255.255.0 inside
ssh timeout 15
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
ntp server 172.20.245.3 source inside
webvpn
 enable outside
tunnel-group GEI-office type ipsec-l2l
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns migrated_dns_map_1
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns migrated_dns_map_1
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:
: end

0
Comment
Question by:ggibat
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
1 Comment
 
LVL 10

Accepted Solution

by:
stsonline earned 2000 total points
ID: 22625618
Your NAT is backwards:

static (outside,inside) tcp 172.20.245.2 https 97.xxx.xxx.2 https netmask 255.255.255.255

should be:

static (inside,outside) tcp 97.xxx.xxx.2 https 172.20.245.2 https netmask 255.255.255.255

0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For months I had no idea how to 'discover' the IP address of the other end of a link (without asking someone who knows), and it drove me batty. Think about it. You can't use Cisco Discovery Protocol (CDP) because it's not implemented on the ASAs.…
Many of the companies I’ve worked with have embraced cloud solutions due to their desire to “get out of the datacenter business.” The ability to achieve better security and availability, and the speed with which they are able to deploy, is far grea…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question