Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1232
  • Last Modified:

Deleting Citrix Published Application fails

I have a Citrix published application that I cannot delete. When I try to delete it I get the following eoor,


Delete Failed

Error deleteing application

Unknown error occured

I have ran DSCHECK /FULL SERVERS /CLEAN and DSCHECK /FULL APPS /CLEAN and it still won't let me delete this one application. I am able to delete other applications fine.

I have tried from a different server also and i get exactly the same problem.

Any ideas?
0
mad_oatcake
Asked:
mad_oatcake
1 Solution
 
KrAzYCommented:
Are you running the latest AMC or checked if the a new AMC or newer components address this issue?

http://support.citrix.com/product/xa/v4.5/

http://support.citrix.com/article/CTX107800

I believe you can specify the "Application Name" and use something like this:

dscheck /full Apps <AppName> /DeleteMF

There's another option as well, but I'm not positive on what the descriptions mean:
o /DeleteMF  Delete the MetaFrame application entry from the data store.
o /DeleteComApp  Delete the common application entry from the data store.

Have have not verified the syntax and you should always be careful when running DSCHECK (i.e. make sure you have a backup of your DS).
0
 
mad_oatcakeAuthor Commented:
Hi

Thnaks for that. In the end I had to change the display name, application name and description to someting else and then it let me delete it.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now