Solved

purpose of channel-group in T1 controller configuration

Posted on 2008-10-02
21
1,803 Views
Last Modified: 2008-10-02
I have 2 aging Cisco MC3810 concentrators. I am trying to reconfigure T1 connectivity on them and running into problem with channel-group statement.

I have a private T1 with both 3810 routers configured in the bridge mode. Here is the part of config file that shows configuration of T1 controller:

controller T1 0
 framing esf
 clock source internal
 linecode b8zs
 channel-group 3 timeslots 7-24 speed 64
 tdm-group 0 timeslots 1-6

When I change channel-group statement to:  "channel-group 3 timeslots 1-24 speed 64" and remove
"tdm-group 0 timeslots 1-6" statement, I loose communication via T1.

I ultimately need to reconfigure the router so I have full T1 for IP traffic. I used to have digital PBX on it and that's why I think there is this separation of timeslots.

Thanks in advance,
Lev
0
Comment
Question by:Lev Kaytsner
  • 11
  • 10
21 Comments
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22624832
Have you worked with your telco on reconfiguring the T1?  There are changes on their side that need to be made in coordination with yours...
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22624893
I'm assuming the voice side of the T1 is being handed off to the PSTN by your provider...is that the case?
0
 

Author Comment

by:Lev Kaytsner
ID: 22624970
I wasn't aware of the fact that I need to work with my telco on reconfiguring T1. We used to have NEC digital PBX on both sides and now we have Nortel BCM and all PBX communication is done over IP trunks. So, I am replacing these 3810's with new 2811 routers. But before I do that I need to make sure communication is up without tdm-group statements.

Let me know if it makes sense.
Thanks,
0
 

Author Comment

by:Lev Kaytsner
ID: 22624983
We have gone back and forth between T1 providers, so I am not sure they even aware of what runs on it.
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22625098
Ahh, okay.  You made the change on both ends of the T1, correct?  Did you first do a "no channel-group 3 timeslots 7-24 speed 64"?  When you added "channel-group 3 timeslots 1-24 speed 64", did you make sure the serial interface for the T1 was still configured properly?  I suspect if you remove the channel-group assignment, the corresponding serial interface is also removed so when you add the new channel-group, the serial interface is back to defaults...
0
 

Author Comment

by:Lev Kaytsner
ID: 22625159
I just called AT&T which is my T1 provider. They don't have any special configs on my T1. All it is a plain Private T1 connection. They won't help me because the routers are not managed by them.

Thanks,
0
 

Author Comment

by:Lev Kaytsner
ID: 22625195
Yes, I followed the process by removing both statements first. It did remove the serial0:3 interface form the config file. So when I added this statement  "channel-group 3 timeslots 1-24 speed 64", I went into the newly created Serial0:3 and added IP address to it.

Luckily I have a modem hanging on the remote router, otherwise I wouldn't be able to connect to it at all.
But, at this point there still was no connection. Only when I added both statements back, communication established again.

Thanks,
0
 

Author Comment

by:Lev Kaytsner
ID: 22625271
One statement I don't have on the serial0:3 interface is "encapsulation HDLC". I found a doc on cisco site that shows it as a part of interface config. Maybe that's what is missing.
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22625274
Hmm, sounds like you are doing it properly.  I might try removing the channel-group again and using channel 0 for the group so you get serial0:0.  Have you looked through the rest of the configuration to make sure there isn't anything else related to the tdm-group.  Can you post the full configuration?
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22625284
HDLC encapsulation is the default which is why you don't see it in the configuration.
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:Lev Kaytsner
ID: 22625354
Here is the full config file:

version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3810_1
!
enable secret 5
!
username  password 0
!
!
!
!
network-clock base-rate 56k
network-clock-select 1 T1 0
ip subnet-zero
no ip routing
no ip domain-lookup
!
!
!
controller T1 0
 framing esf
 clock source internal
 linecode b8zs
 channel-group 3 timeslots 7-24 speed 64
 tdm-group 0 timeslots 1-6
 description T1 circuit ID HCGS806414
!
controller T1 1
 framing esf
 linecode b8zs
 tdm-group 1 timeslots 1-6
!
!
process-max-time 200
!
interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 no ip directed-broadcast
!
interface Ethernet0
 ip address 12.47.2.2 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 bridge-group 1
!
interface Serial0
 no ip address
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface Serial0:3
 ip address 12.47.2.221 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 bridge-group 1
!
interface Switch0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 no ip route-cache
 no ip mroute-cache
 shutdown
 no fair-queue
!
no ip http server
ip classless
!
x25 host OK
x25 host ERROR
bridge 1 protocol ieee
!
line con 0
 transport input none
line aux 0
 exec-timeout 10 10
 login local
 modem InOut
 modem autoconfigure type usr_sportster
 transport input all
 stopbits 1
 speed 38400
 flowcontrol hardware
line 2 3
line vty 0 4
 password
 login
!
!
!
cross-connect 1 T1 0 0 T1 1 1
end

I am also not sure about the last statement about the cross-connect.

Thanks,
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22625396
I would try removing the cross-connect statement when removing the tdm-group.  I would also remove the tdm-group from controller t1 1

controller t1 0
no tdm-group 0 timeslots 1-6

controller t1 1
no tdm-group 1 timeslots 1-6

no cross-connect 1 T1 0 0 T1 1 1
0
 

Author Comment

by:Lev Kaytsner
ID: 22625518
I actually removed tdm-group statement from another controller and it's working fine without it. I will remove the "cross-connect" statement also and hope for the best.
Thanks,
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22625548
Your config looks fine otherwise so I'm not sure what else it would be.  Like I said, it may be worth while using channel-group 0 just in case you stepped on a bug....
0
 

Author Comment

by:Lev Kaytsner
ID: 22625568
this is a config file for the 2811 router I am planning to birng in instead of 3810. If you don't mind, take a look and let me know if you think it's configured properly for T1 connection.
***************************************************************************************************************************
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec

!
hostname cisco2811_1
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5
enable password
!
no aaa new-model
!
resource policy
!
ip subnet-zero
no ip routing
!
!
no ip cef
!
!
ip domain name ift.org
!
username privilege 15 secret 5
!
bridge irb
!
!
interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 no ip route-cache
!
interface FastEthernet0/0
 description $ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$$ETH-LAN$
 no ip address
 ip nbar protocol-discovery
 ip flow ingress
 ip flow egress
 no ip route-cache
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description $ES_LAN$$ETH-LAN$
 ip address 12.47.X.X 255.255.255.0
 ip flow ingress
 ip flow egress
 no ip route-cache
 duplex auto
 speed auto
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface Serial0/0/0
 ip address 12.47.X.X 255.255.255.0
 no ip route-cache
 service-module t1 clock source internal
 service-module t1 timeslots 1-24
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface BVI1
 ip address 12.47.X.X 255.255.255.0
!
ip classless
ip flow-top-talkers
 top 10
 sort-by bytes
!
ip http server
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
!
snmp-server community public RO
!
control-plane
!
!
line con 0
 login local
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet
 line vty 5 15
 privilege level 15
 login local
 transport input telnet
!
scheduler allocate 20000 1000
!
end
*********************************************************************************************************************
Thanks,
0
 

Author Comment

by:Lev Kaytsner
ID: 22625576
I am going to try it with channel-group 0 to see if it makes any difference,
Thanks for your help.
Lev
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22625597
The config looks fine except since you are using a BVI interface, the serial doesn't need an IP address.  One end of the T1 should be "internal" clocking and the other "line" clocking.  Line is the default as well as channel-group 1-24 so you shouldn't see those in the running-configuration just in case you don't think they applied.
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22625630
You may also need the following bridge commands.

bridge 1 protocol ieee
bridge 1 route ip
0
 

Author Comment

by:Lev Kaytsner
ID: 22625776
Thank you very much. I will make the change. The reason I have IP address on the serial interface is so I can telnet it since the router is going to be in the remote office. Otherwise I would have to connect via modem. Unless I am missing something.

Thanks again,
Lev
0
 
LVL 43

Accepted Solution

by:
JFrederick29 earned 500 total points
ID: 22625811
You should be able to telnet to the BVI interface....
0
 

Author Comment

by:Lev Kaytsner
ID: 22625993
Thank you very much. I think I got better understanding of this whole setup.
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Problem Description:   Couple of months ago we upgraded the ADSL line at our branch office from Home to Business line. The purpose of transforming the service to have static public IP’s. We were in need for public IP’s to publish our web resour…
Hello to you all, I hear of many people congratulate AWS (Amazon Web Services) on how easy it is to spin up and create new EC2 (Elastic Compute Cloud) instances, but then fail and struggle to connect to them using simple tools such as SSH (Secure…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now