[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1317
  • Last Modified:

SP3 causing issues with Remote Desktop connection

i had a user at home install sp3 on their home pc, 100% legal version and now they cant connect to their home pc via RDC. however, another pc at the same home, has sp2 and we can connect to that one, from our office right now, with no problems.

i helped them configure both PCs and their router and both PCs were working before sp3 install.

i already had them check to make sure the firewall is off and it is, and i statically assigned both computers for them, so it isn't a problem with a wrong IP address or the router with the wrong ports being forwarded.

i changed the registry values on the computer that works so that it is using 3390 as the listening port. again, that computer, with sp2 is fine.

the computer with sp3 was left to 3389, the default value and we are having trouble connecting to it.

questions/comments/answers

thanks.
0
tomdlgns
Asked:
tomdlgns
1 Solution
 
SysExpertCommented:
1) Is it pigable ?
2) Can the user connect from machine 1 ( SP2 ) to machine 2 running SP3  AT home ( not remotely )

If not, then this has to be resolved first.

If it works, then I would check the router port forwarding.

I hope this helps !
0
 
JoWickermanCommented:
Hi,

The issue arises due to security changes in XP SP3 - namely, that the Terminal Services ActiveX control in Internet Explorer is disabled by default.

If you are experiencing this issue, Microsoft Forums user ColinWH has published a workaround:

    Click on Tools -> Manage Add-Ons -> Enable or Disable Add-Ons in IE to enable the Terminal Services ActiveX control. If you are unable to see/enable the Terminal Services ActiveX control in IE7 on XPSP3 as a workaround can you try deleting the following registry keys:

    HKCU\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{7390f3d8-0439-4c05-91e3-cf5cb290c3d0}

    HKCU\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{4eb89ff4-7f78-4a0f-8b8d-2bf02e94e4b2) Once you delete these keys, the activeX control should be enabled in IE7.

Note, of course, that Microsoft have disabled the Terminal Services ActiveX control in Internet Explorer for security reasons, so run these changes with care.

Hope this helps!

Cheers.
0
 
tomdlgnsAuthor Commented:
sys expert- what is pigable?

i will try your suggestion of connecting internally.  however, the only thing that has changed in the setup is SP3.  i will have to rule the router and port forwarding out.

jowickerman- will the active x control help/matter if we are using the actual program?  from what i understand, from reading the articles, you are able to use IE to connect remotely.

thanks guys
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
tomdlgnsAuthor Commented:
sysexpert- we can get the sp3 computer to connect to the sp2 computer, internally, but the sp2 cant connect to the sp3 computer.

0
 
NetSurfyrCommented:
Hey everyone,

I'm having the similar/same problem between an SP2 laptop and an SP3 laptop.

Before I upgraded the one to SP3, both SP2's were able to establish a remote share on their local accounts through a switch to each other (Users working offsite at a customers')  Same folders, same local login accounts.  No problems with SP2...been working for at least a year (before I started)

After I upgraded one to SP3.  Only SP3 can map to SP2.  Can ping each way but only SP3 maps.  SP2 can ping to SP3 but cannot map share(s), cannot see the SP3 laptop.

I upgraded a different laptop to SP3... discovered that an SP3 laptop cannot map to another SP3 either...only downwards to an SP2.

Rolling back to SP2 is the only solution I've found so far.

Netsurfyr
0
 
SysExpertCommented:
If you are not mappng the drives can you connect - Try turning off the drive and printer mapping in the options.

 

I hope this helps !
 
0
 
tomdlgnsAuthor Commented:
i tried changing the settings as mentioned above, and nothing.  still wont connect.

how does MS NOT have a fix for this yet?
0
 
SysExpertCommented:
Are you using the latest RDP client ( 6.1 ) I think ?

0
 
tomdlgnsAuthor Commented:
@ sysexpert

i dont think i know what you are asking me?

all he did was upgrade to sp3.  whatever version of remote desktop is installed on that PC is what he is using.

thanks.
0
 
SysExpertCommented:
Well, there are newer versions available.

Remote Desktop Connection (Terminal Services Client 6.1) for Windows XP (KB952155)
http://www.microsoft.com/downloads/details.aspx?FamilyId=6E1EC93D-BDBD-4983-92F7-479E088570AD&displaylang=en
---------------------------



0
 
tomdlgnsAuthor Commented:
what if i were to tell you that an SP3 computer cant connect to an SP3 computer in the LAN?
0
 
SysExpertCommented:
Did you install the latest client on both ?

0
 
tomdlgnsAuthor Commented:
i assumed that the sp3 would give both PCs the same client.

0
 
SysExpertCommented:
Yes, but  not necessarily the correct one.

Try installing the newest client on both and see if this helps.

I am using this on all my SP3 machines and have no issues accessing them via RDP locally.

0
 
tomdlgnsAuthor Commented:
ok, just wanted to make sure.  i will suggest this and we will take it from there.

thanks.

0
 
tomdlgnsAuthor Commented:
this is the error he gets when trying to upgrade

'Setup has detected that the Service Pack version of this system is newer than the update you are applying.

 

There is no need to install this update.'
0
 
tomdlgnsAuthor Commented:
issue is FIXED!!!!

ok, ready for this one?

it was related to the firewall (i know this was already mentioned, as well as my first fix for the user i was helping, but they assured me that remote desktop was checked to bypass the firewall, read below for the explanation...) BUT....here is the tricky part.

and yes, it is tricky.

from day one, i guessed firewall, however, he had the remote desktop box checked, to allow it through the firewall. we changed the listening port on that PC back when it had sp2. we changed it from 3389 to 3390 and 3391 (2 computers).

well, after the sp3 install, it still kept the remote box checked under the firewall setting, but the only port it was opening was 3389, on that computer we were not using 3389 we changed it in the registry to 3391.

either way, i probably should have just had him turn off the firewall all the way, just to test that.

lesson learned here- even if you allow a port/program, always turn the firewall off to double check.

note- i was helping via email, had i been at the computer, i would have just disabled the firewall, since i never use it anyway.
0
 
tomdlgnsAuthor Commented:
i tried to submit my last response as the solution, but it said it has to be verified by a moderator.

0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now