Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

MySql remote connection error 2003

Posted on 2008-10-02
11
Medium Priority
?
569 Views
Last Modified: 2013-12-05
Hi
i have a client system installed with
MS Windows xp and the ip address of it (i made static also ) as 192.168.1.29

and my server has
MS Windwos 2000 and its ip address is 192.168.1.10
I have installed MySql5.0 latest version on the server and was trying to connect from the client and i was getting this error
" cant connect to mysql server on 192.168.1.10 "

so i have referred to lots of material and many of the similar questions in this forums and in one the solutions ,it was advised to use the below
GRANT ALL
    ON *.*
    TO root@'%' identified by 'password';

and i have tried this and no use.
so i went ahead and also created a user with
user - root
Hostname - 192.168.1.29
password - password

and when i try to connect from the remote client,still the same issue.
please suggest how to go about as this is very important
0
Comment
Question by:darien_software
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 4
11 Comments
 
LVL 12

Accepted Solution

by:
rionroc earned 2000 total points
ID: 22625044
Hello

Grant again with no password for testing.

GRANT ALL ON *.* TO root@'%'


OR

simply apply:
FLUSH PRIVILEGES;
after granting to any user.


Great is our GOD.
:)
0
 

Author Comment

by:darien_software
ID: 22631257
hi rion
thanks for the reply
i have done what u have told but still no respite..

anyother way around??
0
 
LVL 12

Expert Comment

by:rionroc
ID: 22631730
OK

Just be sure where you set the GRANT and FLUSH PRIVILEGES, either to your localhost(1.10) computer or to your server(1.29)



Great is our GOD.
:)
0
Learn Veeam advantages over legacy backup

Every day, more and more legacy backup customers switch to Veeam. Technologies designed for the client-server era cannot restore any IT service running in the hybrid cloud within seconds. Learn top Veeam advantages over legacy backup and get Veeam for the price of your renewal

 

Author Comment

by:darien_software
ID: 22632293
hi rion
well the server is (1,10) and local host is (1,29)
well i have given Grant and Flush privileges on the Server(1,10) and i am trying to access this MySql database from a client which is the local host(1,29)..
so even after entering these details,i am having the same problem
please guide

0
 

Author Comment

by:darien_software
ID: 22632313

hi rion
well the server is (1,10) and local host is (1,29)
well i have given Grant and Flush privileges on the Server(1,10) and i am trying to access this MySql database from a client which is the local host(1,29)..
so even after entering these details,i am having the same problem
please guide
0
 

Author Comment

by:darien_software
ID: 22632580
should i also do the same thing on the client machine also?
0
 

Author Comment

by:darien_software
ID: 22632676
well i have run the instructions on the client machine also.But whatever i did with the resources.still getting the same error.
connecting from client to server and also tried from server to client
no respite.
0
 
LVL 12

Expert Comment

by:rionroc
ID: 22633370
>>should i also do the same thing on the client machine also?
No

Just want to ask this:
Are you trying to develop a database program?
Or just connecting via MySql query browser?




0
 

Author Comment

by:darien_software
ID: 22634301
hi rion
thanks for ur feedback
well i have used the grant command which was ending "with grant option " and it worked
well i have also diabled all my firewalls(default and installed) and it worked
well now i configured my firewall so i am able to connect on 2 way basis
and also
i guess i need MySql on the client machine to be installed for it to conenct to the server ..

well my suggestions to ones have this problem
1.As the above replies says
         use grant command with root@% or ip address to grant privileges
2.check your firewalls,thats important.What we dont guess will stop,will be blocking the connectivity.
3.Have MySQL also installed on client machine even though we are accessing the database on the server

with these options i guess this error will be solved

thanks rion for your help
0
 

Author Comment

by:darien_software
ID: 22634357
will be helpful for everyone
0
 
LVL 12

Expert Comment

by:rionroc
ID: 22635824
Hmp!

I though windows firewall excluded mysql already and I though you already did.

Anyway thanks.


Great is our GOD.
:)
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This post contains step-by-step instructions for setting up alerting in Percona Monitoring and Management (PMM) using Grafana.
In this blog post, we’ll look at how ClickHouse performs in a general analytical workload using the star schema benchmark test.
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…
In this video, Percona Solutions Engineer Barrett Chambers discusses some of the basic syntax differences between MySQL and MongoDB. To learn more check out our webinar on MongoDB administration for MySQL DBA: https://www.percona.com/resources/we…
Suggested Courses

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question