Solved

FTP server behind Cisco ASA 5505 NAT public address

Posted on 2008-10-02
5
1,102 Views
Last Modified: 2011-09-20
Hi,
I would like to use a public address for an  FTP server on my LAN. I've added what I thought were the right commands to do this but it is still not working. Here's my config:

Result of the command: "show running-config"

: Saved
:
ASA Version 7.2(4)
!
hostname RI5505
domain-name seaboardbox.com
enable password Dr0KI7S5C7dIwyPV encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.50 255.255.0.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 69.26.xxx.179 255.255.255.248
!
interface Vlan3
 shutdown
 no forward interface Vlan1
 nameif dmz
 security-level 50
 no ip address
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
 domain-name domain.com
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list access_outside_in extended permit tcp any host 69.26.xxx.180 eq ftp
access-list outside_access_in extended permit tcp any any eq ftp
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp 69.26.xxx.180 ftp 192.168.1.80 ftp netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 69.26.xxx.177 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
http 0.0.0.0 0.0.0.0 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto isakmp identity address
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp nat-traversal  20
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:afb962d4d65c569ac417f9367e4e1728
: end

Thanks
0
Comment
Question by:VNI-Joe
  • 3
  • 2
5 Comments
 
LVL 26

Expert Comment

by:Soulja
Comment Utility
I think your nat statement is backwards:

static (real_interface,mapped_interface) mapped_ip real_ip netmask mask

Try

static (outside,inside) tcp 192.168.1.80 ftp 69.26.xxx.180 ftp netmask 255.255.255.255

0
 

Author Comment

by:VNI-Joe
Comment Utility
What would my access list command be?
0
 
LVL 26

Expert Comment

by:Soulja
Comment Utility
Your access list command looks fine.
0
 

Author Comment

by:VNI-Joe
Comment Utility
Which one because it looks like I have two different commands for the same thing. And I still can't connect to the FTP server at the 69.26.xxx.180 address.

access-list access_outside_in extended permit tcp any host 69.26.xxx.180 eq ftp
access-list outside_access_in extended permit tcp any any eq ftp
0
 
LVL 26

Accepted Solution

by:
Soulja earned 250 total points
Comment Utility
Both are correct on is just more restrictive.

Add

static (outside,inside) tcp 192.168.1.80 ftp-data 69.26.xxx.180 ftp-data netmask 255.255.255.255


access-list access_outside_in extended permit tcp any host 69.26.xxx.180 eq ftp -data

See if that works.
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
ASA in Multi-Context 1 38
redistribute default route to EIGRP? 2 26
The purpose of Root Bridge 7 27
Cisco ASA 5505 ios upgrade 6 29
Cisco Pix/ASA hairpinning The term, hairpinning, comes from the fact that the traffic comes from one source into a router or similar device, makes a U-turn, and goes back the same way it came. Visualize this and you will see something that looks …
This article will cover setting up redundant ISPs for outbound connectivity on an ASA 5510 (although the same should work on the 5520s and up as well).  It’s important to note that this covers outbound connectivity only.  The ASA does not have built…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now