Solved

Publishing More Than One Infopath Form to a Single Sharepoint Document Library

Posted on 2008-10-02
16
1,188 Views
Last Modified: 2012-05-05
Is this possible? When I publish a second form to the same library it wipes out the first one. I have multiple forms and do not wish to have multiple document libraries. If it's possible, how?

Thanks,

Dave
0
Comment
Question by:drlewicki
  • 9
  • 6
16 Comments
 
LVL 11

Expert Comment

by:Vivek Thangaswamy
Comment Utility
This can be achived using Content Types in SharePoint. Please read this article to get solution for your problem
http://www.codeproject.com/KB/sharepoint/publishingtemplates.aspx
 
0
 
LVL 1

Expert Comment

by:hstaples53
Comment Utility
vivekthangaswamy is correct. For one form, inside of InfoPath you can File | Publish ... directly to the Document Library. When you move to multiple forms, however, you will need to allow multiple Content Types for the Document Library, then upload the Infopath form as the Content Type's template.

The nice thing about having only one content type and using File | Publish ... is that it takes care of promoting the properties for you during the publish process.

To save some typing and to get all my fields promoted, I do the following:
* Take one of the forms and File | Publish ... it to create the document library.
* Goto Doc Library's Site Settings and turn on multiple Content Types
* Delete the Form content type
* Now, add all the content types.

You'll have your various content types in the New menu dropdown, and also all the fields.
0
 

Author Comment

by:drlewicki
Comment Utility
hstaples53 - thanks for the reply. I went to the Doc Library's Site Settings but where do I find the place to turn on multiple content types? What's the exact navigation path?

Thanks,

Dave
0
 
LVL 1

Expert Comment

by:hstaples53
Comment Utility
Multiple content types (Yes/No) are at the Document Library level.

To turn on multiple content types for a Document Library
* Go to your document library
* Click Settings | Form Library Settings
  The Settings page will appear.
* In the 1st column, under General Settings, click Advanced Settings
* Under the heading, Content Types, "Allow management of content types", click the Yes radio button.
* Click OK.

Now, you need to setup the content types
* Goto Site Settings.
* Under the column, labeled "Galleries", click Site content types
* Click Create
* For the name field, enter a name as it will appear under the New menu for users:
    e.g.  "Expense Report Employee"
* For the Select parent content type from: choose "Document Content Types"
* For the Parent Content Type: choose "Document"
* Click OK.

  You're now in the settings for the Content Type you just created.
* Click Advanced Settings.
* Click the radio button beside "Upload a new document template", then click Browse and find the Infopath form on your local system, then click Open.
* Click OK to close the settings for your new Content Type.

To add the newly created content type to your blank Document Library,
* Goto your Document Library
* Click Settings | Form Library Settings
* Under the Content Types heading, click "Add from existing site content types"
* In the Add Content Type page, in the left-hand column, choose your newly created content type, then click the "Add" button to move it to the right-hand column, then click OK.
* Return to viewing your Document Libary's documents (by clicking its name in the breadcrumb at top)
* Click the New menu and confirm your new content type is listed in the dropdown.


0
 

Author Comment

by:drlewicki
Comment Utility
I got the answer to my previous comment. Now when creating a new content type, I go to the parent content type list box and I do not find Microsoft Office InfoPath in the list as the article above mentioned. I see document content types. Is that the one to select?
0
 

Author Comment

by:drlewicki
Comment Utility
P.S. I forgot to thank you for your great inputs.
0
 
LVL 1

Expert Comment

by:hstaples53
Comment Utility
Yes, Document Content Type is the one to select.
0
 

Author Comment

by:drlewicki
Comment Utility
Now I seem to be having another problem.... I click the View as Webpage and the InfoPath Form is configured to be viewed in a browser, but if a user has InfoPath on his system, the form doesn't come up in the browser but in InfoPath when a new instance of the form is created in the Shared Documents library.
0
6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

 

Author Comment

by:drlewicki
Comment Utility
Correction on my last comment. If the user does not have InfoPath on his machine, the message is displayed that IE 6.0 or later is required AND a Windows Sharepoint Services Compatible XML Editor.
The user has the right version of IE. So it fails to bring up the form.

Thanks,

Dave
0
 

Author Comment

by:drlewicki
Comment Utility
AND a Windows Sharepoint Services Compatible XML Editor (such as InfoPath)
0
 
LVL 1

Expert Comment

by:hstaples53
Comment Utility
If they have a good version of IE, then it means Sharepoint was trying to open the form in Infopath and it didn't find Infopath. I assume the situation is that you want the user to edit the form in the browser instead of through Infopath because they don't have Infopath installed on their computer. Note, this requires having the Infopath Forms Services activated for your SP site (http://technet.microsoft.com/en-us/library/cc262885.aspx). I activated ours by going to the Site Actions | Site SEttings | Site Features, and clicking the button beside Office SharePoint Serve Enterprise Site features. But I don't know what SP install you have, so I included the link above. Okay, so once Infopath Forms Services is activated, then you'll need to do the following for the form.

Make the form usable in a browser
* Open the form in Design mode in Infopath
* Click Tools | Form Options
   The Form Options dialog box opens.
* Click Compatibility on the left
* On the right, click the checkbox beside "Design a form template ... browser ..."
* Click OK

Check that the form has no errors.
* Click Tools | Design Checker and make sure there isn't anything in the form that needs fixing.

Update your content type with the new form
* Goto the SP site, then click Site Actions | Site Settings
* Under the Galleries column, click Site Content Types
* Scroll down and click on the Content Type that needs to have the template updated.
* Click Advanced settings
* Click Upload a new document template radio button
* Click Browse, find your updated Infopath form, click Open.
* Click OK.

At this point, you can try again creating a new document from the dropdown menu and confirm it opens inside the browser.

That's about all I can say on your 2nd topic here of publishing a form for browser compatibility; if it doesn't work, not sure I can help sleuth why it didn't.
0
 

Author Comment

by:drlewicki
Comment Utility
I have Office SharePoint Server Enterprise Site features activated. But I'm not sure if I'm running InfoPath Forms Server. How do I find this out?
0
 

Author Comment

by:drlewicki
Comment Utility
I mean InfoPath Forms Services
0
 
LVL 1

Expert Comment

by:hstaples53
Comment Utility
Okay, one other thing to check:

#1 - Doc library is setup for browser-enable docs
* In browser, goto Document Library and click Settings | Document Library Settings.
* Click Advanced Settings
* Under Browser-enabled Documents, click the radio button "Display as a Web page"
* Click OK.

At this point, you're getting into the configuration of Infopath Forms Services, and I would think there's other questions that have already answered that.
0
 

Author Comment

by:drlewicki
Comment Utility
Thanks so much for your inputs again. So how do I find out whether or not I am running InfoPath Forms Services? Couldn't that be a problem?
0
 
LVL 1

Accepted Solution

by:
hstaples53 earned 500 total points
Comment Utility
Oh, sorry. I didn't answer that question. Forms Services is included in SP Enterprise Services, and since you have that activated, then you have Forms Services running. I, unfortunately, don't have enough experience with the back-end Central Administration of Forms Services to help you determine what needs to be tweaked to resolve your problem as I'm not having the problem.
0

Featured Post

Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

Join & Write a Comment

Before you can digitally sign infopath forms, you must have a digital certificate. Microsoft Certificate Services will need to be enabled on a Windows Server 2008 to facilitate the creation and verification of the digital certifciates on the web ser…
In this article, you will read about the trends across the human resources departments for the upcoming year. Some of them include improving employee experience, adopting new technologies, using HR software to its full extent, and integrating artifi…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now