[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Unable to map network drives on Vista

Posted on 2008-10-02
12
Medium Priority
?
956 Views
Last Modified: 2012-05-05
I have a Server 2003 domain with all XP workstations.  Network drives are mapped via login scripts (.bat files).  I have a compination of direct server based shares and replicated DFS network shares that.
My scripts work fine with the XP machines but not any of the new Vista machines, unless the user is part of the domain administrator group.  I have disabled UAC on the Vista machine.
When the login script runs, the direct server network shares get mapped but the DFS shares do not.  Here is an example of my script:
=================================================================================
@echo off

net use f: /d
net use i: /d
net use s: /d
net use t: /d
net use w: /d
net use p: /d
net use u: /d
net use f: \\houfs01\data
net use i: \\investlinc\dfs\InvestlincData\Corporate
net use s: \\investlinc\dfs\InvestlincData\ILS
net use t: \\investlinc\dfs\InvestlincData\IEG
net use w: "\\investlinc\dfs\InvestlincData\Wealth Services"
net use p: "\\investlinc\dfs\InvestlincData\Private Capital"
net use U: \\investlinc\dfs\InvestlincData\ICM
=================================================================================
In the example above, if a user logs in (not a member of the administrator group), this script runs.  He will get the f: \\houfs01\data drive, but none of the DFS drives.  It has something to do with rights in Vista since when I log into a vista machine, all of my drives map properly, but I am a domain admin.  Normal users DFS drives do not map.
Any suggestions would be appreciated
0
Comment
Question by:markcondiff
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 3
12 Comments
 
LVL 56

Expert Comment

by:McKnife
ID: 22627153
Log on as standard user and execute net use i: \\investlinc\dfs\InvestlincData\Corporate visible at the command prompt and return with the error message.
0
 
LVL 12

Expert Comment

by:Serge Fournier
ID: 22627205
use a vbs logon script

there is a lot of thoses here on this forum

search for my name, i already posted a full logon script, long and short versions for vista
0
 
LVL 12

Expert Comment

by:Serge Fournier
ID: 22627231
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:markcondiff
ID: 22627738
Wildboy85, I may take a look at the VBS scripts but for now they are too complicated (if they are the only solution, then I will go that route).  

Per McKnife's request, I entered the "net use" command from the command prompt and got the following error: "System error 67 has occurred.  The network name cannot be found."
0
 
LVL 12

Expert Comment

by:Serge Fournier
ID: 22628193
try a little harder

in my post i extract the main parts, and explain a lot ;)

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_23486974.html

i do not think net use support DFS drive mapping
(some windows application does not even support it!!!)
0
 
LVL 56

Accepted Solution

by:
McKnife earned 1500 total points
ID: 22628269
Of course mapping DFS shares (using net use for example) is supported and we are doing it without problems. Server: 2003 R2, Clients: Vista SP1. Mark, there are several ways to map a drive. What happens if you use the windows explorer menu to map it? You could also map drives using a GPO (with group policy preferences CSE installedon the clients), see
Group Policy Preferences FAQ
http://technet2.microsoft.com/windowsserver/en/technologies/featured/gp/preferencesfaq.mspx 
An Overview of Group Policy Preferences
http://www.microsoft.com/downloads/details.aspx?FamilyID=42e30e3f-6f01-4610-9d6e-f6e0fb7a0790&DisplayLang=en 

But before reading just test manual mapping. By the way, are you on SP1? Is the server on SP2? Maybe just a bug long solved by an SP.
0
 

Author Comment

by:markcondiff
ID: 22633374
The servers are Server 2003 R2 SP2.  The Vista desktop is Vista Business SP1.  
Ok, this is getting hard to troubleshoot because it is not consistent.  I had logged in as a regular domain user and everything mapped the first time.  Then I restart and it does not map with the logon script the second time.  I then removed the user profile (from users in system properties and deleted the user folder under the Users folder on C:.  The next time I logged in as that user, it said it could not load the profile (I figured it would recreate it as it does in XP).  I continued to get this error.  I then had to go in and delete the user SID from the registry and the next time I logged in as that user, it recreated the profile.
The first time I logged in again with the new profile, it mapped the network drive fine.  The second time, it didn't, only the non-DFS drives.
I can map the DFS drives manually.  As a matter of fact, I can go to \\Server\Netlogon and double click the exact logon script and it runs fine and maps all drives, including the DFS drives.
One more thing, when I login (when the script does NOT map the drives), the User Home folder/drive specified in the domain user profile does not map either (it is also a DFS share).
0
 

Author Comment

by:markcondiff
ID: 22633596
I tried the same thing with a new profile.  The first 3 times I logged in, everything mapped fine.  The 4th - 5th times, it didn't.  Very inconsistent.  I log in, then restart the computer each time.
By the way, all windows updates are current on the vista machine.
The 6th time, I tried just logging off and then logging back on rather than restarting and this time it mapped the drives.
I then restarted and it did not map the drives.  Manually running the logon script mapped the drives.
0
 
LVL 56

Expert Comment

by:McKnife
ID: 22637225
Well, sorry for you. Try mapping via gpp.
0
 

Author Comment

by:markcondiff
ID: 22638003
I will keep working and post anything I find out. Thanks for your help.
0
 
LVL 12

Expert Comment

by:Serge Fournier
ID: 22828474
do you have the policy that tell windows to wait for the network to start before loggin in?
0
 

Author Comment

by:markcondiff
ID: 22830617
Yes, I actually used a sleep command in the script which seemed to work.  
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I'm a big fan of Windows' offline folder caching and have used it on my laptops for over a decade.  One thing I don't like about it, however, is how difficult Microsoft has made it for the cache to be moved out of the Windows folder.  Here's how to …
Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
Visualize your data even better in Access queries. Given a date and a value, this lesson shows how to compare that value with the previous value, calculate the difference, and display a circle if the value is the same, an up triangle if it increased…

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question