Solved

QoS between Sites

Posted on 2008-10-02
4
951 Views
Last Modified: 2013-12-27
I'm having a problem with dropped phone calls over a WAN between two buildings.  The calls will connect and then drop after any given amount of time.  I would like to rule out the router configuration, could someone let me know if the QoS is configured correctly?

Router 1


class-map match-all Voice
 match access-group 20
!
!
policy-map Voice-Policy-Percent
description QoS policy for 75% avail bandwidth
 class Voice
  priority percent 75
 class class-default
  fair-queue
policy-map Voice-Policy-2
description QoS policy for full T1
 class Voice
  priority 1000
 class class-default
  fair-queue
!
!
!
interface Multilink1
 description T1 bundle to New Jersey
 ip address 172.16.1.1 255.255.255.252
 service-policy output Voice-Policy-Percent
 ppp multilink
 ppp multilink fragment disable
 ppp multilink group 1
!
interface GigabitEthernet0/0
 description NewJersey LAN
 ip address 192.168.160.5 255.255.240.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description PBX VLAN
 ip address 192.168.150.5 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 description WAN Link to MDL-WWMP
 ip address 172.16.1.9 255.255.255.252
 service-policy output Voice-Policy-Percent
 service-module t1 clock source internal
 service-module t1 timeslots 1-24
!
interface Serial0/1/0
 description to Texas Broadwing#
 no ip address
 encapsulation frame-relay IETF
 shutdown
 service-module t1 timeslots 1-24
 frame-relay lmi-type ansi
!
interface Serial0/2/0:0
 description T1 to Houston, circuit
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
interface Serial0/2/1:0
 description T1 to Houston, circuit
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.160.1
ip route 10.0.0.0 255.255.255.0 192.168.160.8
ip route 172.16.1.4 255.255.255.252 172.16.1.2
ip route 192.168.180.0 255.255.255.0 172.16.1.2
ip route 192.168.181.0 255.255.255.0 172.16.1.10
ip route 192.168.190.0 255.255.255.0 192.168.160.8
ip route 192.168.201.0 255.255.255.0 192.168.160.21
ip route 192.168.202.0 255.255.255.0 192.168.160.21
ip route 192.168.203.0 255.255.255.0 192.168.160.21
ip http server
ip http authentication local
ip http timeout-policy idle 600 life 86400 requests 10000
!
!
access-list 20 remark ip address of voip device
access-list 20 permit 192.168.160.150
access-list 20 permit 192.168.150.150


Router 2



User Access Verification

Password:
MDL-WWMP#sh running-config
Building configuration...

Current configuration : 1507 bytes
!
version 12.4

!
hostname MDL-WWMP
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable password
!
no aaa new-model
ip cef
!

class-map match-all Voice
 match access-group 20
!
!
policy-map Voice-Policy-Percent
  description QoS policy for 75% avail bandwidth
 class Voice
  priority percent 75
 class class-default
  fair-queue
!
!
!
interface FastEthernet0/0
 description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$
 ip address 192.168.181.5 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface Serial0/1/0
 description WAN link to
 ip address 172.16.1.10 255.255.255.252
 service-module t1 timeslots 1-24
 service-policy output Voice-Policy-Percent
!
ip route 0.0.0.0 0.0.0.0 172.16.1.9
!
ip http server
ip http authentication local
ip http timeout-policy idle 600 life 86400 requests 10000
!
access-list 20 remark ip address of voip device
access-list 20 permit 192.168.181.150
snmp-server community MDLAB RO
snmp-server enable traps tty

Thank you
0
Comment
Question by:mdltech
  • 2
  • 2
4 Comments
 
LVL 8

Accepted Solution

by:
MrJemson earned 250 total points
ID: 22630434
Looks ok for straight IP QoS.

When I setup QoS I usually do it via protocol not via the IP. There may be a bunch of other services running on the VoIP device, that are sending data that is being prioritized over the link that don't need to be.

Heres what I would have for my class-map:

class-map match-all Voice
  match protocol rtp audio
  match protocol sip
  match protocol rtcp

Maybe give that a go, and see if there is any improvement.
0
 

Author Comment

by:mdltech
ID: 22633361
Thank you, I'll give that a try
0
 
LVL 8

Assisted Solution

by:MrJemson
MrJemson earned 250 total points
ID: 22656648
How did you go with this?

Any update?
0
 

Author Closing Comment

by:mdltech
ID: 31502525
So far it is working.  I'll give it a few more days
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Cost effective dual wan w/ qos 5 49
EIGRP STUB 19 85
Cisco 800 router unable to connect through TPG network 12 23
Cisco ASA 5512-X Active/Standby HA 4 25
I recently purchased a Bluetooth headset called the Music Jogger (model BSH10). The control buttons on it look like this: One of my goals is to use it as the microphone and speakers for Skype calls. In that respect, it works well. However, I …
Implementing Avaya's One-X portal is pretty painless, until you want to deploy this to the Android and iPhone clients when these clients are outside of your network. The clients will also work within your local network. Here is our experience and so…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question