Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Sanity check needed on basic router config.  Is likely  a gateway config. error.

Posted on 2008-10-02
16
Medium Priority
?
317 Views
Last Modified: 2012-05-05
I'm having trouble configuring a router from scratch.

The DHCP server appears to be working but I can't get out.  I'm guessing I have the gateway syntax wrong, but am unsure.  The tutorials have got me close, I'm sure I'm missing something basic.

I've attached the config file.  It's accurate, save the replacement of the first series of digits with an x for security purposes.

When I replace the router with a chepie netgear everything works fine.
!
hostname UnionPlaza-gw
!
enable password xxxxxx
!
!
!
!
!
clock timezone CST -6
clock summer-time CDT recurring
ip subnet-zero
no ip source-route
ip domain-name x.com
ip name-server x.130.255.3
ip name-server x.122.32.71
ip name-server x.42.42.42
ip dhcp excluded-address 192.168.2.254
ip dhcp excluded-address 192.168.2.253
!
ip dhcp pool FranceOffice
   network 192.168.2.0 255.255.255.0
   default-router 192.168.2.254 
   dns-server x.130.255.3 x.122.32.71
   domain-name x.com
!
!
!
!
!
interface Ethernet0
 description LAN
 ip address 192.168.2.254 255.255.255.0 secondary
 ip address x.139.18.98 255.255.255.252
!
interface Serial0
 ip address 192.168.2.253 255.255.255.252
!
!
ip classless
ip route 0.0.0.0 0.0.0.0 x.139.18.97
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
 transport input all
line vty 0 4
 access-class 99 in
 exec-timeout 0 0
 password x
 login
!

Open in new window

0
Comment
Question by:orac666
  • 5
  • 5
  • 4
  • +1
16 Comments
 
LVL 13

Expert Comment

by:kdearing
ID: 22629740
Are you trying to use the E0 port for both outside and inside?
What is the S0 used for?
Need more info on what you are trying to do.

The first thing I noticed is that you have 2 interfaces configured in the same subnet.

interface Serial0
 ip address 192.168.2.253 255.255.255.252
             and
interface Ethernet0
 ip address 192.168.2.254 255.255.255.0 secondary

Unless the interfaces are bridged, it won't work.
0
 

Author Comment

by:orac666
ID: 22629884
Yes, I am using Eth) for both outside and inside.  There is only one NIC on this router.  It used to have 8 IP's bound to that single Interface and worked just fine.

The serial port is using the same subnet, I'm just using it to configure.  Does that matter?
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 1000 total points
ID: 22629908
Your cheapie Netgear has at least two interfaces, I'm guessing.
How do you expect to have a WAN and a LAN interface with just one router port?
The whole purpose of a router is to route traffic from one network (aka interface) to another, most often with a different connection type, i.e Ethernet to ADSL, Ethernet to T1, Ethernet to other..
You need to NAT from the private ip to the public IP. Hard do to with only one interface.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:orac666
ID: 22630086
I may not be a pro on these Cisco's but they can assign multiple IP's to one port.

That's one of their big advantages.

It was working that way before.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 22630669
0
 
LVL 13

Expert Comment

by:kdearing
ID: 22630798
The only way that it MAY work is to trunk E0 with 2 VLANs, outside and inside.
Of course, that would involve using a VLAN-capable switch.
Configuring NAT may be tricky.
0
 
LVL 12

Assisted Solution

by:Pugglewuggle
Pugglewuggle earned 1000 total points
ID: 22631387
Hi,
Yes, you can assign multiple IPs to one port using subinterfaces... but that's not the solution here.
My guess is that you're using an old 2500 series router or something like that that only has 1 ethernet port?
If that is the case, you're not going to be able to correctly set this up unless you've got a seral interface to the internet (like a T1 line). Even then, if I'm thinking right, this is a different type of serial alltogether... your serial port is like a big black rectagle with about 50 little holes, isn't it?
I'm very sorry but you're not going to get this working. :(
0
 

Author Comment

by:orac666
ID: 22633376
TO clarify matters, this is a 3640 series router
0
 
LVL 12

Expert Comment

by:Pugglewuggle
ID: 22635172
In that case, if you only have one ethernet port, this isn't going to work for your setup. You need at least 2. One for inside, one for outside.
Please check to see if you have more than one. If you don't you won't be getting it working without buying another module and WIC.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 22635262
Check the nat-on-a-stick in the link I referenced above. I've never seen it work and it is not TAC supported, but the document is there.
0
 
LVL 12

Expert Comment

by:Pugglewuggle
ID: 22635502
Lol the next thing I'm gonna invent will be ACLs on a stick! :-P
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 22635599
packets come in, but they can't get out!
the packet motel.....
0
 
LVL 12

Expert Comment

by:Pugglewuggle
ID: 22635767
Lol!
0
 

Author Comment

by:orac666
ID: 22638534
Had the Eureka moment while reading these replies.

The router was prior configured with loads of IP's on the single NIC, but it did not do NAT.

It makes sense that NAT requires two NICs.

Thanks for all the help.
0
 

Author Closing Comment

by:orac666
ID: 31502592
Thanks guys.  The multiple IP's on one NIC thing was what was throwing me, I forgot to consider the need for two NICs on NAT.

0
 
LVL 12

Expert Comment

by:Pugglewuggle
ID: 22638569
No problem! NAT does indeed require two network interfaces - one to act as outside and at lease one to act as inside.
:) Let me know if you have any other questions!
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

927 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question