I need assistance on how to change the default owner when the policy is not exposed.

AIF inbound requires that we change the default owner of inbound files.  As explained in Microsoft KB article 947721 this setting is not available in security policy settings list.  It refers to article 214752 which gives an example How to add custom registry settings to Security Configuration Editor.  But this example is not clear to me and it is about XP anyway.  I need assistance on how to change the default owner in Windows 2008 when the policy is not exposed.  Thank you.
harkenincAsked:
Who is Participating?
 
Henrik JohanssonConnect With a Mentor Systems engineerCommented:
In %WINDIR%\inf\sceregvl.inf, add following lines.

in section [register registry values]
MACHINE\System\CurrentControlSet\Control\Lsa\NoDefaultAdminOwner,4,%NoDefaultAdminOwner%,3,0|%DefaultOwner0%,1|%DefaultOwner1%


in section [strings]
NoDefaultAdminOwner = "System objects: Default owner for objects created by members of the Administrators group"
DefaultOwner0 = "Administrators group"
DefaultOwner1 = "Object creator"

0
 
harkenincAuthor Commented:
The following abc instructions are provided:  
a. Click Start > All Programs > Administrative Tools > Local Security Policy.
b. On the Local Security Settings menu, navigate to Security Settings > Local Policies > Security Options.
c. Change the Security Settings for the System Objects: Default owner for objects created by members of the administrator's group from Administrators group to Object creator.
The following AIF application error is being displayed:
File ... cannot be read because the submitting user could not be determined. The default owner for objects created by members of the Administrators group must be set to the object creator.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.