Solved

iphone connection to the server failed - sbs 2003

Posted on 2008-10-03
8
17,137 Views
Last Modified: 2011-06-01
Hi

We have a sbs 2003 server with OMA enabled. OMA is working. The use can login into OMA from any domain computer and see his email. Port 25, 80 and 443 is enabled on the (Cisco 800) router firewall. (ISA is not enabled on the server). When we try connect with the iPhone it gives the error  "connection to the server failed".

We have deleted and re-created the iPhone account settings.

To access OMA from any Internet connection. We use: https://www.companydomainname.com/oma

My iPhone settings are configured as follows:

Correct email address:
domain: companydoman (not companydomain.local)
Username: username onyl (not email address)
pass: password
server name: www.mycompanydomain.com/oma

Please advise why we are unable to conenct with the "connection to server failed" error
SSL is selected under I-phone account settings.

Thanks
Regards
Quintin
0
Comment
Question by:QGSmith
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 13

Expert Comment

by:ach_patil
ID: 22632608
Have you configured ActiveSync on your Server.  iPhone uses ActiveSync to connect to Exchange 2003

Also you need to make sure RPC/HTTPS is enabled for ActiveSync to work.
http://www.microsoft.com/windowsmobile/en-us/help/synchronize/activesync45.mspx
http://www.msexchange.org/tutorials/Exchange-2003-Mobile-Messaging-Part1-Microsoft-DirectPush-technology.html
0
 
LVL 7

Accepted Solution

by:
Mikealcl earned 250 total points
ID: 22635154
Active Sync doesn't need rpc/https.  It just needs Active Sync turned on.  It can even work without ssl(but I wouldn't suggest it)

In Exchange system manage on the top part expand the first area, go properties on the mobile section and enable active sync.  You also must enable devices that do not meet full security requirements for the iPhone if you have any security polices enabled.

If you do want to use SSL I would suggest using a real, not self signed, certificate as active sync devices sometimes have issues with self signed non trusted certificates.


0
 
LVL 1

Expert Comment

by:wolfbird
ID: 22645743
Make sure you have exchange sp2 installed
0
Raise the IQ of Your IT Alerts

From IT major incidents to manufacturing line slowdowns, every business process generates insights that need to reach the people required to take action. You need a platform that integrates with your business tools to create fully enabled DevOps toolchains.

You need xMatters.

 

Author Closing Comment

by:QGSmith
ID: 31502700
Resovled! We configured Iphone to choose (other) as mail account setup instead of Exchange account setup. We also choose mail.companydomain.com as the mail server address with SSL enabled. This seem to have worked for us. Thanks for all your help.
0
 
LVL 7

Expert Comment

by:Mikealcl
ID: 22649586
Just revisiting this

server name: www.mycompanydomain.com/oma

That should be the DNS of your exchange server.  The /oma part is probably what makes that fail.
0
 

Author Comment

by:QGSmith
ID: 22649651
No. I just used mail.mycompanydomain.com for the server name.
Important to have ports: 443,193 and 993 open.
Make sure to setup an OTHER mail accoint on the iphone not and not EXCHANGE account.
I couldn't get the exchange account to work with my server for some reason with ot without SSL.
 
0
 

Expert Comment

by:Computer Superheroes
ID: 34601477
This is not a solution to an ActiveSync issue.  Because the author has 993 open to his server, the iPhone is making an IMAP connection when selecting the "other" type account.  iPhones will try this type of connection first when using the "other" account type.
0
 
LVL 18

Expert Comment

by:ZENandEmailguy
ID: 35052514
I realize this is closed but I fixed my ActiveSync problem tonight by confirming that the Security on my AD user had the check box for Inherited Permissions checked (found after clicking the Advanced button on the Security tab).  Before it was checked, I received the "failure to connect to server" each time I attempted to retrieve mail.  Each of our users who have reported ActiveSync problems have been found to not have this box checked.  As soon as we checked that box and waited for AD to sync the change (about 5 minutes), their problems with getting mail were solved.

Scott
0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
CodeTwo Sync for iCloud (http://www.codetwo.com/sync-for-icloud?sts=6554) automatically synchronizes your Outlook 2016, 2013, 2010 or 2007 folders with iCloud folders available via iCloud Control Panel. This lets you automatically sync them with…

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question