Solved

Pix ACL and VPN

Posted on 2008-10-03
4
405 Views
Last Modified: 2010-04-12
Hi,

I have a VPN that i want to filter traffic

Here's the config.  I removed the sysopt connection permit-ipsec so i can filter what i want
So i want the only access to 192.168.123.0 to be on the 192.168.1.2 host with rdp

My concern is that this ACL is on the ougoing interface and is mixed with the other ACL group of the outside interface so even if somebody is not coming from the VPN, he might spoof the 192.168.123.0 network and gain access.

And later on i want to add a couple of other VPN so i will have to create an access-list for every VPN

Is there another way to do this ?

Thanks,

PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
access-list fromnet permit icmp any any echo-reply
access-list fromnet permit tcp 192.168.123.0 255.255.255.0 192.168.1.2 255.255.255.255 eq 3389
access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 192.168.123.0 255.255.255.0
access-list outside_cryptomap_20 permit ip 192.168.1.0 255.255.255.0 192.168.123.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 172.16.4.201 255.255.255.0
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group fromnet in interface outside
route outside 0.0.0.0 0.0.0.0 172.16.4.1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
ntp server 132.246.168.164 source outside prefer
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer 172.16.4.200
crypto map outside_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address 172.16.4.200 netmask 255.255.255.255 no-xauth no-config-mode
isakmp identity address
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 inside
dhcpd dns 205.151.222.250
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd enable inside
terminal width 80


0
Comment
Question by:fox54
  • 2
4 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 125 total points
Comment Utility
Probably not with what you have.
In my opinion, you're worrying about nothing.
Nobody can spoof the 192.168.x.x network because it always encrypted and gets decrypted first. It would have to be awfully sophisticated of an attack.
Keep the sysopt enabled because this only affect the outside interface, not the inside and keeps your outside acl clean and easy to manage
What you can do is create a restrictive acl on the inside interface going out
Example:
 access-list inside_going_out permit tcp host 192.168.1.2 eq rdp 192.168.123.0 255.255.255.0
 access-list inside_going_out deny ip 192.168.1.0 255.255.255.0 192.168.123.0 255.255.255.0
 access-list inside_going_out permit ip any any
access-group inside_going_out in interface inside

 
0
 
LVL 12

Expert Comment

by:Pugglewuggle
Comment Utility
lrmoore is right - that would be a crazy attack.
What you need to do if you want to filter traffic is create a traffic filter - this will restrict traffic on the VPN tunnel-group to the networks/addresses you specify:
As far as I know this command is not available in PIX software 6.x. You will need to upgrade to 7.x if you're running a PIX 501 or 506, or 8.x if you're running a PIX 515 or above.
Cheers!
0
 

Author Comment

by:fox54
Comment Utility
Hi,

I check that out and i tought it was working but in fact it seems that it does not work

Strange enough it blocks ICMP traffic but i can still web-browse the server at 192.168.1.2 from the 192.168.123.0 network

Can the version of the pix have an effect on this ?
0
 
LVL 79

Expert Comment

by:lrmoore
Comment Utility
it could be.
Latest is 6.3(5)
Unless you have 515 or bigger, then you can upgrade all the way to 8.0(4) which implements a lot of ways to create restrictive acls for VPN's.
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

This article will cover setting up redundant ISPs for outbound connectivity on an ASA 5510 (although the same should work on the 5520s and up as well).  It’s important to note that this covers outbound connectivity only.  The ASA does not have built…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now