Solved

External FTP Requests Stopped Working!

Posted on 2008-10-03
12
1,036 Views
Last Modified: 2013-12-09
I installed our FTP server via IIS6 on our public web server about 6 months ago and bound it to a separate network card, public IP address and public DNS name, which up until recently it has been working without fail.

Recently, external clients complained intermittently that they couldnt connect.  Initially I couldn't replicate from from home, but I am now finding that it appears to have totally stopped working as I now I cant connect from home and no one else has reported success with it.

If I test this internally, it works every time!

The known results from vairous external methods of connections to both the DNS name (ftp://www.ftpsite.co.uk) and IP (ftp://xxx.xxx.xxx.xxx), are as follows:

Windows Explorer:  "A connection to the server could not be established."
Internet Explorer 7: "Internet Explorer could not display the page"
DOS:  "Connection timed out"
Ping:  
Pinging www.ftpsite.co.uk [xxx.xxx.xxx.xxx] with 32 bytes of data
Request timed out.
Request timed out.
Request timed out.
Request timed out

The strange thing is that our http: website works fine, which is on the same server and also hosted via IIS6.  So I changed the internel IP of the FTP site to share the one that our website is using, and tried to access the same FTP site using the dns name of our website, but it still doesnt work.

Can anyone shed any light on this issue, as I'm running out of ideas?

Thanks

FTPDiagram.jpg
0
Comment
Question by:FSIFM
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 3
  • 2
12 Comments
 
LVL 6

Expert Comment

by:DewFreak
ID: 22633515
This sounds like a firewall issue.  What type of firewall are you using and have you rebooted it latley?
0
 
LVL 4

Author Comment

by:FSIFM
ID: 22633580
I have rebooted the firewall recently, but no other traffic appears to be affected and the FTP rule is still there.

We are using a SonicWall 2040 Pro.

Would you suggest another firewall reboot?
I rebooted the web server last night to see if that helped, but alas it didnt!
0
 
LVL 5

Expert Comment

by:NutrientMS
ID: 22633589
Yeah, sounds like a firewall rule.  Watch the logs for your FTP requests to see what is happening.
0
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

 
LVL 6

Expert Comment

by:DewFreak
ID: 22633670
I would check the rule and see what internal IP the FTP is pointing to.
0
 
LVL 4

Author Comment

by:FSIFM
ID: 22633702
Just tested again from an external source and this time I was able to login successfully via IE and was able to open an FTP Explorer window via 'Page\Open FTP Site in Windows Explorer'

I guess the intermittent issue is back!
0
 
LVL 4

Author Comment

by:FSIFM
ID: 22633719
I would say that the rule is fine as it used to work and as per my last post, it still does, but now its only occasionally.
The rulle allow FTP WAN traffic into the internal IP assigned to the FTP site.  However this does explain why it didnt work when I changed the internal IP of the FTP site to that of our Web site!
0
 
LVL 5

Expert Comment

by:NutrientMS
ID: 22633744
Again, watch your logs.  When people call up with the issue you can get their IP address (www.wimi.com) and search your logs for the information on there.  It will go a long to figuring out the root cause.
0
 
LVL 6

Expert Comment

by:DewFreak
ID: 22633795
ok, so now to troubleshoot the "occasional" problem.  Using IIS6 your users willl need to disbale passive FTP.
0
 
LVL 4

Author Comment

by:FSIFM
ID: 22634642
I'm so confused as to why a PC that didnt work, now works!

On the test PC, I disabled Passive FTP and its still working, but as it was working prior I cant confirm that this made any difference.

I will try again from home tonight, as I can definitely say that it wasnt working from there last night.
0
 
LVL 4

Author Comment

by:FSIFM
ID: 22635234
Thanks for your help so far guys, have a nice weekend.
0
 
LVL 4

Author Comment

by:FSIFM
ID: 22648409
I've looked at my firewall logs and found notthing has been blocked.

But I  may have found a solution, which uses part of DewFreaks last suggestion and may be related to just IE7.

#: In IE, Tools - Internet Options - Advanced
#: Tick:    Enable FTP Folder view (outside of Internet Explorer)
#: Untick:    Use Passive FTP (for firewall and DSL modem compatibility)
#: Click OK
#: Then enter: ftp://<username>:<password>@ftpsite.com in the address bar
#: Click Page Menu and select "Open FTP site in Windows Explorer".

I'm still awaiting feedback from others on this, but its been working for me since trying this method.
0
 
LVL 4

Accepted Solution

by:
FSIFM earned 0 total points
ID: 22669232
Thanks for all your help, but I've concluded that all you need to do is ensure the Enable FTP Folder view (outside of Internet Explorer)
 is set withing IE and that you need to use the ftp://<username>:<password>@ftpsite.com format to upload and download files.

The Passive FTP  setting in IE doesnt appear to make any difference, but I have read elsewhere that this is recommended, so I am awarding the points to DewFreak.
0

Featured Post

U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

First of all, clustering IIS is something you should rarely consider doing. In almost all cases, Microsoft Network Load Balancing (NLB) (http://technet.microsoft.com/en-us/library/cc758834(WS.10).aspx) is a much better solution when you need to p…
A phishing scam that claims a recipient’s credit card details have been “suspended” is the latest trend in spoof emails.
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…

740 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question