Solved

clamAV setup for redhat enterprise linux and yum

Posted on 2008-10-03
5
1,076 Views
Last Modified: 2013-12-16
Dear Sir/Madam:
I have redhat enterprise linux ver5 working as samba domaincontroller , name server ,ftp server now the requirement is to configure the mail server using postfix as an MTA , install clamav and mailscanner but bydefault yum is not getting the package of clamav hence  , added the RPMForge to the YUM after this iam able to do clamd installation with the command yum install clamd fine it worked but as regular process i did # yum update ( this do to update all the packeges ) after adding the RPMForge iam getting the following error message with the # yum update command:
Transaction Summary
=============================================================================
Install      6 Package(s)
Update      25 Package(s)
Remove       0 Package(s)
Total download size: 18 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Check Error:
  file /usr/share/emacs/site-lisp/psvn.el from install of subversion-1.5.2-0.1.el5.rf conflicts with file from package subversion-1.4.2-2.el5
  file /usr/share/man/man1/svn.1.gz from install of subversion-1.5.2-0.1.el5.rf conflicts with file from package subversion-1.4.2-2.el5
  file /usr/share/man/man1/svnadmin.1.gz from install of subversion-1.5.2-0.1.el5.rf conflicts with file from package subversion-1.4.2-2.el5
  file /usr/share/man/man1/svnlook.1.gz from install of subversion-1.5.2-0.1.el5.rf conflicts with file from package subversion-1.4.2-2.el5
  file /usr/share/man/man5/svnserve.conf.5.gz from install of subversion-1.5.2-0.1.el5.rf conflicts with file from package subversion-1.4.2-2.el5
  file /usr/share/man/man8/svnserve.8.gz from install of subversion-1.5.2-0.1.el5.rf conflicts with file from package subversion-1.4.2-2.el5
  file /usr/share/xemacs/site-packages/lisp/psvn.el from install of subversion-1.5.2-0.1.el5.rf conflicts with file from package subversion-1.4.2-2.el5
Error Summary

i think before adding the RPMForge to yum , yum database was only checking the
Repository of "rhel1-x86_64-servers-5" but after adding RPMForge Repository also checks the "rpmforge"

finally iam ending up with the error when i run the command # yum update
Transaction Check Error:
  file /usr/share/emacs/site-lisp/psvn.el from install of subversion-1.5.2-0.1.el5.rf conflicts with file from package subversion-1.4.2-2.el5
  file /usr/share/man/man1/svn.1.gz from install of subversion-1.5.2-0.1.el5.rf conflicts with file from package subversion-1.4.2-2.el5
  file /usr/share/man/man1/svnadmin.1.gz from install of subversion-1.5.2-0.1.el5.rf conflicts with file from package subversion-1.4.2-2.el5
  file /usr/share/man/man1/svnlook.1.gz from install of subversion-1.5.2-0.1.el5.rf conflicts with file from package subversion-1.4.2-2.el5
  file /usr/share/man/man5/svnserve.conf.5.gz from install of subversion-1.5.2-0.1.el5.rf conflicts with file from package subversion-1.4.2-2.el5
  file /usr/share/man/man8/svnserve.8.gz from install of subversion-1.5.2-0.1.el5.rf conflicts with file from package subversion-1.4.2-2.el5
  file /usr/share/xemacs/site-packages/lisp/psvn.el from install of subversion-1.5.2-0.1.el5.rf conflicts with file from package subversion-1.4.2-2.el5
Error Summary

please help me to solve this problem , how make the yum updates normally with the errors .



0
Comment
Question by:D_wathi
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 28

Expert Comment

by:Jan Springer
ID: 22637665
I would recommend going to www.mailscanner.info and picking up the SA/ClamAV package from there.
0
 
LVL 19

Accepted Solution

by:
bevhost earned 500 total points
ID: 22646530
Can you remove the offending subversion package first?
eg

rpm -e subversion

or maybe

yum update subversion
0

Featured Post

Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Linux Mailserver setup & redundancy 2 77
How to use question mark (?) in filename with html 25 98
AWS EC2 HTTP & HTTPS 2 74
Recover Lacie Edmini data. 11 64
1. Introduction As many people are interested in Linux but not as many are interested or knowledgeable (enough) to install Linux on their system, here is a safe way to try out Linux on your existing (Windows) system. The idea is that you insta…
The purpose of this article is to demonstrate how we can upgrade Python from version 2.7.6 to Python 2.7.10 on the Linux Mint operating system. I am using an Oracle Virtual Box where I have installed Linux Mint operating system version 17.2. Once yo…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question