• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4568
  • Last Modified:

LDAP register on imagerunner network printer

We recently got a Canon imagerunner C5185i network printer, I have everything else set up except LDAP registration so that it can pull address book off the Exchange server. I am using Exchange 2003 running on Win Server 2003.

It wants to know server name, server address, location to start search, and whether or not to use login. I have tried putting public name, simple name, FQDN, public IP, internal IP, and various things into the location to start search box from stuff I have found on Canon site and Google, but none work. I already know you have to restart the printer to make the settings take.

Anyone have any experience with this and know what it wants exactly?
LDAP-reg.png
0
Bob Stone
Asked:
Bob Stone
  • 4
  • 3
1 Solution
 
MikeKaneCommented:
We use the same Canon's here:  

Server name is hostname
Server address is the IP
Location to start search will depend on your version of LDAP, basically your version of windows server, but should look like:
"ou=system accounts,dc=domainname,dc=com"
This is basically the location you want the ldap searches to start in.


Use the logon info if you need to specify an account with LDAP lookup permissions?  
0
 
Bob StoneIT GuruAuthor Commented:
I tried that, but I must have gotten something wrong still, maybe the syntax or something, I dunno.
0
 
MikeKaneCommented:
Is it working now for you?  
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
Bob StoneIT GuruAuthor Commented:
No, not sure why either.
0
 
MikeKaneCommented:
I double checked my settings.....  

Make your start point the entire domain for now.... you can restrict it later if you like....  

dc=domain,dc=local  


Also, you probably need to specify an account for LDAP lookups.  

You should try adding a domain account with a non-expiring password in the logon fields as well.    

0
 
MikeKaneCommented:
Oh, and make sure that your copier can communicate with the LDAP server on port 389 as well....  
0
 
Bob StoneIT GuruAuthor Commented:
I am setting up a new Exchange server now with DNS and all that sorted out better. Maybe that will help.
0
 
NeilNuttallCommented:
Was having problems, until I tried this in the ImageRunner's LDAP settings
(NB: We are using W2K3)
Login information: Use (not Use (Secure Authentication))
User: domain\username
Password: password
Domain: <leave blank>
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now