Solved

DAO.Database error 3492 when attempting to sync replica to design master

Posted on 2008-10-03
9
724 Views
Last Modified: 2012-05-05
We currently use DAO 3.6 with Access 2003.

To update cleint databases, we create templates from the design master and distribute those templates.

For some clients, we get this error:

3492 - The synchronization failed because a design change could not be applied to one of the replicas.

the line that causes this error is: db.Synchronize sTemplate, dbRepImportChanges

I check the MSysSchemaProb table and found this information
Column = Value
--------------------------
Command = Set
Error = 3011
ErrorText = The Microsoft Jet database engine could not find the object 'qryCityByCityStateCode'.  Make sure the object exists and that you spell its name and the path name correctly.
SchemaVersion = 10833
Text1 = Tables
Text2 = qryCBCSC
-----------------------------

I checked the upgrade template and the query is there, i have tried rebuild the database into a blank version of the same db with no luck, i ran code to see if there are any conflicts listed and there are not. please help. Thank you.
0
Comment
Question by:DevLSS
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
9 Comments
 
LVL 38

Expert Comment

by:puppydogbuddy
ID: 22636320
Often Access error messages are cryptic.  Even though the query exists, there may have been a design change within the query itself that is causing the error with the upgrade template.   Try comparing the query in design view or in sql view between the upgrade template  and Design master.  

Hope this helps.
0
 

Author Comment

by:DevLSS
ID: 22636970
i did compare them and they are identical, the same exact SQL and design view
0
 
LVL 38

Expert Comment

by:puppydogbuddy
ID: 22637384
hmmm....just thinking....I know you said the query was exactly the same in sql and in design view....but would you have noticed if the order of the columns in the query grid or query sql was slightly different?  It seems to me that if the select statement was changed from >>>>>Select A, B, C  to >>> Select A,C, B  this might a subtle change between the design master and the upgrade template that you might have overlooked.  And it could also explain why the error goes away when you rebuild the db..
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 

Author Comment

by:DevLSS
ID: 22637690
i could see that as a problem, but why would it work for one DB and not another?
0
 
LVL 38

Expert Comment

by:puppydogbuddy
ID: 22639358
I  assume that the replicas were created at different times, and all but one created after the design change to the query was made in the master...... the one replica that was created before the design change is the one that caused the conflict........which went away when you created a new replica.  Is that possible??
0
 

Author Comment

by:DevLSS
ID: 22643092
Yes, the replicas were created at different times, but i don't see how that would be the problem because aren't all the replicas tied to the deisgn change history of the design master?
0
 
LVL 38

Expert Comment

by:puppydogbuddy
ID: 22643222
Yes, that is what the synchronization process is all about. .....if a design change is made to the master, it won't present itself as a conflict until the next attempt to synchronize....at which time the conflict will be resolved and disappear (as in your case). Timing does matter.

Your last question was related to how it was possible that only the one replica was showing  a conflict....and the answer is that the one replica was created from the master as it existed before the design change to the query was made.  The other replicas did not have the conflict because they were probably created after the design change was made, and therefore, those replicas had already included the  design change before the synchronization that is the subject of this post was performed.
0
 

Accepted Solution

by:
DevLSS earned 0 total points
ID: 22644173
none of these replicas could have had the query, because it was added to the design master this time. so when the template is applied to the replicas, the query is being created.

I also checked the upgrade template against the design master and the query is identical in every way.

I can try rebuilding the database into a newer version of the database(which i prefer to find a solution and not use this workaround). That will usually do the trick.
0
 
LVL 38

Expert Comment

by:puppydogbuddy
ID: 22644219
Ok,then I have no other ideas as to why only one of your replicas had the conflict.  If it doesn't happen very often, your workaround should suffice.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

AutoNumbers should increment automatically, without duplicates.  But sometimes something goes wrong, and the next AutoNumber value is a duplicate.  This article shows how to recover from this problem.
You need to know the location of the Office templates folder, so that when you create new templates, they are saved to that location, and thus are available for selection when creating new documents.  The steps to find the Templates folder path are …
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…
Visualize your data even better in Access queries. Given a date and a value, this lesson shows how to compare that value with the previous value, calculate the difference, and display a circle if the value is the same, an up triangle if it increased…
Suggested Courses
Course of the Month9 days, 4 hours left to enroll

615 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question