Solved

ASA translation group question

Posted on 2008-10-03
10
1,187 Views
Last Modified: 2008-10-20
I have an ASA 5520 that I am eventually going to implement. It has 3 active interfaces. The interfaces are outside, inside (going to our production network), and TestNet. I just set up TestNet to make myself a small network to test firewall rules on. I want TestNet to be able to communicate with devices on the inside network, as well as send external traffic out the outside interface. Inside and TestNet are both set to 100 for the security level. When I connect a device to TestNet(192.168.251.0/24) and it tries to access the inside network (10.0.0.0/16) I get the error No translation group found for udp src TestNet:192.168.251.10/2705 dst inside:10.0.0.252/53. I know it is a NAT error, but I am unsure of which kind of exemption/rule to add to make this work. Any help would be appreciated! My running config is below.
ASA Version 8.0(4) 

!

names

!

interface GigabitEthernet0/0

 nameif outside

 security-level 0

 ip address 204.XX.XX.XX 255.255.255.0 

!

interface GigabitEthernet0/1

 nameif inside

 security-level 100

 ip address 10.0.1.109 255.255.0.0 

!

interface Management0/0

 nameif management

 security-level 100

 ip address 192.168.1.1 255.255.255.0 

 management-only

!

interface GigabitEthernet1/0

 nameif TestNet

 security-level 100

 ip address 192.168.251.1 255.255.255.0 

!

!

ftp mode passive

clock timezone PST -8

clock summer-time PDT recurring

dns server-group DefaultDNS

 

same-security-traffic permit inter-interface

same-security-traffic permit intra-interface

access-list inside_outbound extended permit ip 10.0.0.0 255.255.0.0 any 

access-list InsomVPN_splitTunnelAcl standard permit 10.0.0.0 255.255.0.0 

access-list inside_nat0_outbound extended permit ip any 192.168.250.0 255.255.255.0 

access-list vpn_inbound extended permit ip 192.168.250.0 255.255.255.0 10.0.0.0 255.255.0.0 

access-list outside_access_in extended permit ip 192.168.250.0 255.255.255.0 10.0.0.0 255.255.0.0 

access-list inside_access_in extended permit ip 192.168.250.0 255.255.255.0 10.0.0.0 255.255.0.0 

access-list inside_access_in extended permit ip 10.0.0.0 255.255.0.0 192.168.250.0 255.255.255.0 

access-list inside_access_in extended permit ip 10.0.0.0 255.255.0.0 any 

access-list outside_access_out extended permit ip 10.0.0.0 255.255.0.0 192.168.250.0 255.255.255.0 

access-list outside_access_out extended permit ip 10.0.0.0 255.255.0.0 any 

access-list vpn_outbound extended permit ip 192.168.250.0 255.255.255.0 204.2.209.0 255.255.255.0 

access-list vpn_outbound extended permit ip 192.168.250.0 255.255.255.0 192.168.250.0 255.255.255.0 

pager lines 24

logging enable

logging asdm informational

mtu management 1500

mtu inside 1500

mtu outside 1500

mtu TestNet 1500

ip local pool VPNpool 192.168.250.1-192.168.250.254 mask 255.255.255.0

ip verify reverse-path interface outside

no failover

icmp unreachable rate-limit 1 burst-size 1

asdm image disk0:/asdm-613.bin

asdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list inside_nat0_outbound

nat (inside) 0 0.0.0.0 0.0.0.0

nat (outside) 1 192.168.250.0 255.255.255.0

access-group inside_access_in in interface inside

access-group outside_access_in in interface outside

access-group outside_access_out out interface outside

route outside 0.0.0.0 0.0.0.0 204.2.209.1 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

dynamic-access-policy-record DfltAccessPolicy

 network-acl inside_outbound

 network-acl vpn_inbound

 network-acl inside_access_in

 network-acl vpn_outbound

 network-acl outside_access_out

http server enable

http 10.0.0.0 255.255.0.0 inside

http 192.168.1.0 255.255.255.0 management

no snmp-server location

no snmp-server contact

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 

crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 

crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 

crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 

crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 

crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 

crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 

crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 

crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 

crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs 

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association lifetime seconds 28800

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association lifetime kilobytes 4608000

crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP

crypto map outside_map interface outside

crypto map inside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP

crypto map inside_map interface inside

crypto isakmp enable inside

crypto isakmp enable outside

crypto isakmp policy 10

 authentication pre-share

 encryption 3des

 hash sha

 group 2

 lifetime 86400

crypto isakmp ipsec-over-tcp port 10000 

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd address 192.168.1.2-192.168.1.254 management

dhcpd enable management

!

dhcpd address 192.168.251.2-192.168.251.254 TestNet

dhcpd dns 10.0.0.252 10.0.0.253 interface TestNet

dhcpd wins 10.0.0.252 10.0.0.253 interface TestNet

dhcpd domain insomniacgames.com interface TestNet

!

threat-detection basic-threat

threat-detection scanning-threat shun except ip-address 10.0.0.0 255.255.0.0

threat-detection statistics host

threat-detection statistics port

threat-detection statistics protocol

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

class-map inspection_default

 match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

 parameters

  message-length maximum 512

policy-map global_policy

 class inspection_default

  inspect dns preset_dns_map 

  inspect ftp 

  inspect h323 h225 

  inspect h323 ras 

  inspect rsh 

  inspect rtsp 

  inspect esmtp 

  inspect sqlnet 

  inspect skinny  

  inspect sunrpc 

  inspect xdmcp 

  inspect sip  

  inspect netbios 

  inspect tftp 

!

service-policy global_policy global

prompt hostname context 

Cryptochecksum:add875d80c87fd95442f297ee50e09e3

: end

asdm image disk0:/asdm-613.bin

asdm history enable

Open in new window

0
Comment
Question by:downscm
  • 6
  • 4
10 Comments
 
LVL 28

Accepted Solution

by:
Jan Springer earned 500 total points
Comment Utility

access-list NONATINSIDE extended permit ip 10.0.0.0 255.255.0.0 192.168.251.0 255.255.255.0
access-list NONATTESTNET extended permit ip 192.168.251.0 255.255.255.0 10.0.0.0 255.255.0.0

nat (inside) 0 access-list NONATINSIDE
nat (TestNet) 0 access-list NONATTESTNET
nat (TestNet) 1 192.168.251.0 255.255.255.0

0
 

Author Comment

by:downscm
Comment Utility
Awesome, that fixed that issue. Now, for some reason the ACL outside_access_out is blocking TestNet traffic destined for the outside world. I have the device set to allow traffic to less secure interfaces, as well as an explicit rule allowing the traffic from testnet out.

Deny tcp src TestNet:192.168.251.10/3242 dst outside:64.233.187.99/80 by access-group "outside_access_out" [0x0, 0x0]

Any ideas? Config should be the same as above with the addition of what you had me add.
0
 
LVL 28

Expert Comment

by:Jan Springer
Comment Utility
Add:

access-list outside_access_out extended permit ip 192.168.251.0 255.255.255.0 any
0
 

Author Comment

by:downscm
Comment Utility
It says found duplicate element, because I already have that rule.
0
 

Author Comment

by:downscm
Comment Utility
If it helps, this is the sequence:
Built dynamic TCP translation from TestNet:192.168.251.10/3624 to outside:204.2.209.57/34241
Deny tcp src TestNet:192.168.251.10/3624 dst outside:207.46.19.190/80 by access-group "outside_access_out" [0x0, 0x0]

Maybe has something to do with the translation?
0
6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

 
LVL 28

Expert Comment

by:Jan Springer
Comment Utility
These are the only lines that I see for that access list:

access-list outside_access_out extended permit ip 10.0.0.0 255.255.0.0 192.168.250.0 255.255.255.0
access-list outside_access_out extended permit ip 10.0.0.0 255.255.0.0 any

I do not see where you are permitting 192.168.251.0/24 and that is why it is being denied.
0
 

Author Comment

by:downscm
Comment Utility
It is in there, i must have added it after the last code post. Here is the new stuff. What is the difference between access lists and access groups? The error i am getting is that the access-group is disallowing the traffic, not the list.
same-security-traffic permit inter-interface

same-security-traffic permit intra-interface

access-list inside_outbound extended permit ip 10.0.0.0 255.255.0.0 any 

access-list InsomVPN_splitTunnelAcl standard permit 10.0.0.0 255.255.0.0 

access-list inside_nat0_outbound extended permit ip any 192.168.250.0 255.255.255.0 

access-list vpn_inbound extended permit ip 192.168.250.0 255.255.255.0 10.0.0.0 255.255.0.0 

access-list outside_access_in extended permit ip 192.168.250.0 255.255.255.0 10.0.0.0 255.255.0.0 

access-list inside_access_in extended permit ip 192.168.250.0 255.255.255.0 10.0.0.0 255.255.0.0 

access-list inside_access_in extended permit ip 10.0.0.0 255.255.0.0 192.168.250.0 255.255.255.0 

access-list inside_access_in extended permit ip 10.0.0.0 255.255.0.0 any 

access-list outside_access_out extended permit ip 10.0.0.0 255.255.0.0 192.168.250.0 255.255.255.0 

access-list outside_access_out extended permit ip 10.0.0.0 255.255.0.0 any 

access-list outside_access_out extended permit ip 192.168.251.0 255.255.255.0 any 

access-list TestNet_nat0_outbound extended permit ip 192.168.251.0 255.255.255.0 any 

access-list vpn_outbound extended permit ip 192.168.250.0 255.255.255.0 204.2.209.0 255.255.255.0 

access-list vpn_outbound extended permit ip 192.168.250.0 255.255.255.0 192.168.250.0 255.255.255.0 

access-list NONATINSIDE extended permit ip 10.0.0.0 255.255.0.0 192.168.251.0 255.255.255.0 

access-list NONATINSIDE extended permit ip 10.0.0.0 255.255.0.0 192.168.250.0 255.255.255.0 

access-list NONATTESTNET extended permit ip 192.168.251.0 255.255.255.0 10.0.0.0 255.255.0.0 

access-list TestNet_access_out extended permit ip 192.168.251.0 255.255.255.0 any 

access-list TestNet_access_in extended permit ip 192.168.251.0 255.255.255.0 any 
 

global (outside) 1 interface

nat (inside) 0 access-list NONATINSIDE

nat (inside) 0 0.0.0.0 0.0.0.0

nat (outside) 1 192.168.250.0 255.255.255.0

nat (TestNet) 0 access-list NONATTESTNET

nat (TestNet) 1 192.168.251.0 255.255.255.0

access-group inside_access_in in interface inside

access-group outside_access_in in interface outside

access-group outside_access_out out interface outside

access-group TestNet_access_in in interface TestNet

access-group TestNet_access_out out interface TestNet

route outside 0.0.0.0 0.0.0.0 204.2.209.1 1

Open in new window

0
 

Author Comment

by:downscm
Comment Utility
There is also 0 hits on that list rule, so it seems like it isn't even getting there
0
 
LVL 28

Expert Comment

by:Jan Springer
Comment Utility
I don't even know why you have that access list.  If none of the lines are in use, can you:

no access-group outside_access_out out interface outside

And try again.
0
 

Author Comment

by:downscm
Comment Utility
That worked. That was so stupid of me. Thanks a lot.
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

Imagine you have a shopping list of items you need to get at the grocery store. You have two options: A. Take one trip to the grocery store and get everything you need for the week, or B. Take multiple trips, buying an item at a time, to achieve t…
Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now