[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

How do I setup ISP failover and load balancing on a Cisco 1841 router?

Posted on 2008-10-03
12
Medium Priority
?
1,945 Views
Last Modified: 2013-12-14
I've been following the instructions on this site, http://www.inacom-sby.net/Shawn/post/2007/11/Getting-Dual-ISPs-running-on-Cisco-1811-and-above-routers(Part-1).aspx, for setting this router for ISP load balancing and failover.  I run into a problem at one of the steps.  track 1 rtr 1 reachability  It's not working.  I get this error.  % Invalid input detected at '^' marker  Can someone fill me in on why?  

Also, I want to make sure this configuration will work?  I know that the T-1 interface is not setup correctly.  I'm waiting on the information from my ISP for me to complete it.
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PROXY
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.2.1 192.168.2.99
!
ip dhcp pool STSCS
   network 192.168.2.0 255.255.255.0
   default-router 192.168.2.5
   dns-server 4.2.2.2
   domain-name sts-cs.com
   lease 3
!
!
no ip domain lookup
ip sla 1
 icmp-echo 4.2.2.2
 timeout 500
ip sla schedule 1 life forever start-time now
!
!
track 1 stub-object
!
class-map match-all VOIP
 match protocol rtp audio
class-map match-all VOIP_Control
 match protocol sip
!
!
policy-map VOIP_PM
 class VOIP
  priority percent 50
 class VOIP_Control
  priority percent 20
!
!
!
!
interface Loopback0
 ip address 10.108.1.1 255.255.255.0
 ip nat outside
!
interface FastEthernet0/0
 description ATTDSL
 bandwidth 512
 bandwidth receive 6144
 ip address 65.5.44.25 255.255.255.0
 ip nbar protocol-discovery
 ip nat outside
 duplex auto
 speed auto
 service-policy output VOIP_PM
!
interface FastEthernet0/1
 description Internal
 ip address 192.168.2.5 255.255.255.0
 ip nbar protocol-discovery
 ip nat inside
 duplex auto
 speed auto
!
interface Serial0/0/0
 description ATTT-1
 bandwidth 1544
 no ip address
 ip nbar protocol-discovery
 ip nat outside
 service-policy output VOIP_PM
!
!
no ip http server
ip nat inside source route-map ATTDSL interface FastEthernet0/0 overload
ip nat inside source route-map ATTT-1 interface Serial0/0/0 overload
!
access-list 100 permit ip any any log
route-map ATTT-1 permit 10
 match ip address 1
 match interface Serial0/0/0
!
route-map ATTDSL permit 10
 match interface FastEthernet0/0
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
end

Open in new window

0
Comment
Question by:dsvxaey
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 3
  • 2
12 Comments
 
LVL 12

Expert Comment

by:Pugglewuggle
ID: 22638017
So just to confirm - you have a single 1841 that you will be doing loadbalancing/backup interfaces on? You are NOT using multiple routers with HSRP, is this correct?
The way it basically works is that you setup "interface tracking" to track the interfaces and remove the routes from the round robin interface load balancing. One important thing to note is that the load balancing never actually stops - it's just that the route of the interface that's down is taken out of the LB pool while it's down - effectively, everything is then load balanced to the interface (or interfaces) that are still up.
Cheers! Let me know if you have any questions!
0
 
LVL 5

Expert Comment

by:devangshroff
ID: 22639755
hi

 Pugglewuggle: Is it possiplle to do wan failover between to ISP withot BGP on cisco router.
                   
regards,devang
0
 
LVL 12

Expert Comment

by:Pugglewuggle
ID: 22639906
Yes, it is possible to do a WAN failover without BGP - basically just track interfaces and costs if using dynamic routing.
You can in fact do it with pretty much any type of connection - even a dial up line with the right WIC on the router!
Cheers!
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
LVL 5

Expert Comment

by:devangshroff
ID: 22640025
hi
Pugglewuggle: can u just explain how nattin will work if i have two internet connect fron different provider on same router.

regards,
devang
0
 
LVL 12

Expert Comment

by:Pugglewuggle
ID: 22640053
Well you assign each interface as ip nat outside so they can be used in round robin LB for NAT. Then if one goes down the other one takes over. And when it comes back up, everything goes back to normal.
0
 

Author Comment

by:dsvxaey
ID: 22650986
Ok, I understand how it works.  I'm just wondering how to add the tracking ability for failover.  I can't seem to figure that part out.  Thanks.
0
 
LVL 12

Expert Comment

by:Pugglewuggle
ID: 22652854
To "track" interfaces when not using HSRP and two routers, you need to use "floating static routes". Here is a funny article that helps you understand them nice and easily:
http://www.routergod.com/charlesmanson/
Don't know why they picked charles manson for that one though... usually they pick someone better.
Cheers!
0
 
LVL 12

Expert Comment

by:Pugglewuggle
ID: 22652886
And here is a more serious article from Cisco.
http://www.cisco.com/en/US/tech/tk801/tk133/technologies_tech_note09186a008009457d.shtml 
Cheers!
0
 

Author Comment

by:dsvxaey
ID: 22661983
I can't get this working.  Standard pinging won't go out over the T1.  Can somebody point me in the right direction?  The router hands out DHCP leases just fine, but I can't ping externally over the T1 from a client or from the router itself.   Thanks.
0
 
LVL 12

Expert Comment

by:Pugglewuggle
ID: 22663893
Do you have a route setup for the T1? That is often an issue.
0
 

Author Comment

by:dsvxaey
ID: 22664397
Hmm, not sure.  Give me an example of what the route would look like.
0
 
LVL 12

Accepted Solution

by:
Pugglewuggle earned 600 total points
ID: 22664539
ip route 0.0.0.0 0.0.0.0 71.23.43.123 1
or
ip route 0.0.0.0 0.0.0.0 71.23.43.123 1 track
0

Featured Post

Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I found an issue or “bug” in the SonicOS platform (the firmware controlling SonicWALL security appliances) that has to do with renaming Default Service Objects, which then causes a portion of the system to become uncontrollable and unstable. BACK…
Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question