• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 13006
  • Last Modified:

How to change screen resolution in Linux (Command line)?

Hello group,

I'm using command line only on my linux box and also using a wide screen (DELL) the problem is that fonts are big and I want to have bigger resolution.

How can I change it?

Thanks,
ak
0
akohan
Asked:
akohan
1 Solution
 
chingmdCommented:
You need to install and configure the framebuffer.  But the CentOS5 doens't have it turned on by default.  You will need to do some custome kernel complilation to make it available.  

0
 
nedvisCommented:
What you actually need to do is to reconfigure your current XTERM ( terminal emunlator for X ) in Linux.
More precisely you have to tell X server how to utilize your video card and monitor to their fiull potincial and
not to use only safe setting.
This article may help you understanding X server basics and how to configure Xterm.
http://linuxhelp.blogspot.com/2005/10/configuring-xterm-in-linux.html

goog luck
0
 
chingmdCommented:
nedvis, we interpreted the question different.   His statement of command line only, I took as no X.  Your interpretation was inside X on a command line.

akohan, please clarify.

Are you on the console?  (not remote)
Using X at all, or not?


0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
dathhoCommented:
Sorry, only 640x480 unless you run X.
To do that edit your /etc/inittab file

if you have
id:3:initdefault:

change it to
id:5:initdefault:

If this is already set to X11 (read the file) then there is something wrong with your xconf...

After that it depends on which display manager you are using.  If Gnome then
System -> Preferences -> Hardware -> Display Resolution
0
 
Deepak KosarajuDevOps EngineerCommented:
use command
system-config-display.
0
 
akohanAuthor Commented:


Thanks to all for your the response. Chingmd, regarding your question I'm using my server directly there is no any remote thing or ... terminal such putty or ....
I hope this clarifies it.

Regards.
0
 
akohanAuthor Commented:

Dathho,

I guess what you came up with is for X but I'm not using X. It is only command line. I rather use command line to learn it deeper. Of course, the file /etc/inittab is here and I can modify it but will that create a proper resolution after rebooing the system?

Thanks!
0
 
chingmdCommented:
If you not using X, then you will need to utilize framebuffer to get resolutions higher than 640x480.    

Check out the use of framebuffer:

Check for kernel support.  

zcat /proc/config.gz | grep -i frame

If you have frambufffer support in the kernel, then take a look at the following URLs for getting it started.


http://www.faqs.org/docs/Linux-HOWTO/Framebuffer-HOWTO.html

If you are using grub for the bootloader, you can apply the framebuffer information fromthis gentoo configuration cage.
http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1&chap=10

Here's another good resource.
http://www.linux.org/docs/ldp/howto/Framebuffer-HOWTO-5.html



0
 
chingmdCommented:
If you don't have it in the kernel, you'll need to recompile the kernel to enable it.  I think that is a wholly different question from the how to get a  higher resolution console on your linux box.
0
 
Duncan RoeSoftware DeveloperCommented:
You can get some improvement over the default 640x480 layout even without framebuffer.
Using the LILO boot loader, you specify "vga=?" for a list of supported modes (resolutions). Once you know what you want, you change to having  e.g. vga=0x330 in your lilo.config.
I suspect the boot loader has to support this and I don't know if GRUB does, although "info grub" has a few references to adding "vga=ext" to the boot command line.
The extra resolutions you get are nothing special, just a bit better than 640x480. Or maybe the resolution is the same but it squeezes in more  and longer lines of small characters - it's a while since I used it.
Once you have kernel framebuffer support (say using the last HOWTO above), you can set the console resolution using the fbset command, e.g.:

/usr/sbin/fbset -fb /dev/fb0 -a 1600x1200-76
0
 
MysidiaCommented:
Try using the resizecons command:

       resizecons COLSxROWS
       resizecons -lines ROWS

Or man resizecons
0
 
Ricardo ElenaManager, US OperationsCommented:
you can check your file /etc/X11/xorg.conf
look for Section "Screen"

de "DefaultDepth     24"

and arrenge the order of the under the defualt depth  Modes    "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
 
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now