Solved

Can't connect to Internet on VM

Posted on 2008-10-03
18
2,189 Views
Last Modified: 2012-08-13
I just installed VMWare workstation and then installed a copy of Windows XP Pro. I was able to join my home peer-to-peer network and the virtual pc (WinXP) has a separate IP address. The problem is, I cannot connect to the internet using the virtual pc. I have setup the bridged connection using the virtual machine settings and selected Replicate physical network connection state. However, even though I can see all of the other computers on the workgroup, the internet will not connect

Any help?
Thanks,
Charlie
0
Comment
Question by:charlieb01
18 Comments
 
LVL 6

Expert Comment

by:DewFreak
ID: 22638704
Did you assign the VM a static IP or is it grabbing a DHCP lease?  If static, did you put in the gateway address?
0
 
LVL 3

Expert Comment

by:ahmedalnooh
ID: 22638760
maybe you need to configure proxy in the ie or take a look at the default getway it might wrong and also see that if you have an internet security software like kaspersky the vm wale lan is conedered in the program as trusted network the it must work fine
0
 

Author Comment

by:charlieb01
ID: 22638950
I used DHCP. The host is:
192.168.1.104
255.255.255.0
Default Gateway: 192.168.1.1

Using ipconfig in the virtual I get:
192.168.1.106
255.255.255.0
Default gateway: 192.168.1.1

There is no anti-virus or internet security software on the virtual
On the virtual I click on "connect to" select the DSL and then click the Connect button.
I get a dialog: Connecting to Verizon DSL...   Connecting through WAN Miniport (PPPOE)
Then I get Error 678 "The remote computer did not respond.
I can ping the router (192.168.1.1) and get the expected 4 replies.
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 6

Expert Comment

by:DewFreak
ID: 22638962
Why are you trying to authenticate ??  Doesn't your router/modem already do this?
0
 

Author Comment

by:charlieb01
ID: 22638997
I am not sure I understand your question.
I am using a notebook with Host OS as Windows Vista and VMWare is installed and as a virtual I installed Win XP Pro.
Now I want to install software, such as MS Office. I know that when I get it installed under the virtual (XP Pro) it is going to try yo activate over the Internet. Therefore, the Win XP virtual needs to be able to connect to the Internet - That is what I am trying to do. I have no problem using Vista (the host) to connect to my DSL - that is what I am using now. But I should be able to connect to my DSL through te virtual as well
0
 
LVL 6

Expert Comment

by:DewFreak
ID: 22639060
Yes, I understand.  You should not have to do anything for that VM to access the internet if it is pointing to your router and you can ping it.  You should not have to setup any connection settings.  You should not be clicking on CONNECT.
0
 
LVL 3

Expert Comment

by:DraconianSoul
ID: 22639081
It sounds like you have multiple computers in your network.  When any of those computer connect to the internet do you have to connect each one to the "Verison DSL" network?

This is confusing since most home routers will connect to the DSL network so that no other computer has to.  If you have to connect each pc in your network to the DSL network individually I'd say your network is misconfigured and not the VM.
0
 
LVL 6

Expert Comment

by:DewFreak
ID: 22639085
Right on DraconianSoul.  The router or modem should be doing the PPPoE authentication.
0
 

Author Comment

by:charlieb01
ID: 22639134
Well, I do have multiple computers on the network and have always had to click on Connect. Everything works fine that way. In other words, I don't have my networks computers automatically connect to the DSL upon startup. That way I can control what is connected to the DSL.
On this notebook that I am currently using, when I turn it on, it automatically connects to the network (my Linksys router). Then I click on Connect to and select Verizon DSL, then click on the Connect button and everything connects fine and I can then use IE to get to the Internet.
So, I don't think the problem is with the way I have my network setup. All of my other computers connect to my network and the DSL in the same way. The only problem I am having is with the VM.
0
 
LVL 6

Expert Comment

by:DewFreak
ID: 22639200
I will say this..that is not normal.  Not sure when you click connect what is really happening..I can't imagine that you are actually authenticating when you are doing that on multiple PC's but then again maybe that is the problem.  They only allow so many PC's to connect.
0
 

Author Comment

by:charlieb01
ID: 22639232
I don't think the problem is with the number of PC's connected. I have tried disconnecting a couple of the PC's from the DSL and then tried connecting the VM without any luck.
So, I am back to the basic question - If I can connect to my other network devices (ie shared folders) then what is wrong with the DSL connection?
0
 
LVL 6

Expert Comment

by:DewFreak
ID: 22639245
Exactly.  The networking from the VM is working.  That is established.  Nothing needs changed there.  When you create this connection for the Verizon DSL what information do you enter?  a username and password?  Lets step through this process so everyone understands how you connect to your ISP.
0
 

Author Comment

by:charlieb01
ID: 22639354
When I create the DSL connection in the New Connection Wizard, under Network Connection Type  I choose connect to the Internet then click Nect. I then choose Setup my connection manually. and click Next.
I then click on "Connect using a broadband connection that requires a user name and password and click Next.
Next I need to enter a Connection name like "Verizon DSL" (or whatever name I want) and click on the Next button
I then enter a User name, Password, and Confirm password. I leave checked the boxes that say "Use this account name and password when anyone connects to the Internet from this computer" and the box labeled "Make this the default Internet connection" and click on the Next button. Then I click on the Finish button.
Now, when I want to connect to the Internet, I click on Start >, Connect to > Verizon DSL.
The dialog that appears already has my username and in the password field it says "[To change the saved password click here]"  - I don't change anything.
The checkbox is checked for "Save this user name and password for the following users:
and the selection is Anyone who uses this computer.
I then click on the Connect button.
At this point I usually get a message in the taskbar that says Verizon DSL connected.

0
 
LVL 6

Expert Comment

by:DewFreak
ID: 22641402
I would suggest configuring the PPPoE settings in your router/modem instead of logging in each PC as you have described.  It would remedy this problem I am sure.  So continuing with you currect method, is the host PC connected to the DSL when you try the VM?  When you say you have setup the "bridged connection using the VM" does that mean you have selected the VM bridge protocol on the adapter?  If you so do not need this enabled.  You should not have to do anything as far as the network adapters for VMware to work out of the box.
0
 

Author Comment

by:charlieb01
ID: 22654723
DewFreak,
I don't usually turn off my other computers but had the need to do so yesterday. When it restarted I noticed that it automatically connected to my DSL connection. That particular desktop machine is Win Xp-Pro.
I checked my router and noticed that I must have setup the PPPoE some time ago because it has my username and a password.
So, I have a few questions:
1. I uninstalled the VMWare workstation from my Vista notebook and am about to reinstall it and then reinstall WinXP Pro as the guest OS. When asked during WinXP setup what type of Internet connection I have should I select one that is always on?

2. I want to add the guest OS (WinXP Pro) to my home peer to peer network so I can share files and folders. Should I use the bridge network, something else, or nothing at all and simply have the Guest OS join my home workgroup?

3. Finally, On the Vista 64-bit notebook, is there some way to change the configuration so I don't need to select "Connect to" and therefore have it automatically connect to my DSL?

I really appreciate you time and help.

Thanks in advance,

Charlie
0
 
LVL 6

Accepted Solution

by:
DewFreak earned 500 total points
ID: 22692354
1. Yes select always on
2. You should not have to do anything for your XP VM to be able to talk to your other PC's except normal file sharing etc.
3. If you have your router setup for your PPPoE auth then you should not have to click connect on your vista machine.  It should connect just by opening your browser.  Lets start with this issue.  I think it may be the root of all your troubles.
0

Featured Post

Portable, direct connect server access

The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, I will show you HOW TO: Suppress Configuration Issues and Warnings Alert displayed in Summary status for ESXi 6.5 after enabling SSH or ESXi Shell.
An article on effective troubleshooting
Teach the user how to edit .vmx files to add advanced configuration options Open vSphere Web Client: Edit Settings for a VM: Choose VM Options -> Advanced: Add Configuration Parameters:
Teach the user how to join ESXi hosts to Active Directory domains Open vSphere Client: Join ESXi host to AD domain: Verify ESXi computer account in AD: Configure permissions for domain user in ESXi: Test domain user login to ESXi host:

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question