Solved

Remote Desktop Connections not disconnecting all the way...

Posted on 2008-10-03
4
1,043 Views
Last Modified: 2013-11-21
I am having a similar problem as WolfManBN25 in case ID#: 22761624.
I have several people who terminal serve onto a server.  They do this several times a day - and not necessarily from the same computer.  Sometimes it can be a thin client and other times it is a desktop PC.  I was receiving Event ID 1517 all over the place.  Also, sometimes when the person tries to log back in all they receive is a blue screen - no login.  I would have to go into the Terminal Services Manager and reset their account.
So, anyway, I have installed UPHClean.  It got rid of the 1517 errors and now I recieve the UPHClean Info 1401 that look like this:  
The following handles in user profile hive DOMAIN\username (S-1-5-21-153723871-2679035580-3975090593-1611) have been remapped because they Rtvscan.exe (2384)
HKCU\Software\Symantec\Symantec Endpoint Protection\AV\Custom Tasks (0xb8c)

Problem is - I still have users getting locked up w/ the blank screen and no login, so I still have to reset the account.  

Any ideas how to get this to stop?  
Thanks!
0
Comment
Question by:tacomarose
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 38

Accepted Solution

by:
ChiefIT earned 500 total points
ID: 22640129
You can manage TS through group policy to include a timeout of the connection:

http://www.windowsnetworking.com/articles_tutorials/Terminal-Services-Group-Policy.html

I think these are the two policys you might want to look at on that page:

The following is a direct quote from above article:
_________________________________________________________________________________
Remove disconnect option from Shut Down dialog - This policy is found under Computer Configuration\Administrative Templates\Windows Components\Terminal Services and setting it to Enabled can help enhance the performance of your Terminal server. Reason is, it prevents users from using the Shut Down dialog and disconnecting their Terminal Services session instead of terminating their session. If a Terminal Services session is disconnected, the session continues to run on the Terminal server and uses up server resources (processor, memory, disk). If a session is terminated instead, the resources used by the session are released for use for other sessions. So if your Terminal server is working near capacity to support your users, it's important that users not be allowed to disconnect their sessions and leave them running on the server and hogging resources that could be used by other users. The downside of this policy is that it only removes the disconnect option from the Shut Down dialog and doesn't prevent users from disconnecting their session in other ways, for example by disabling their network connection. As a result, you should also configure the next policy as well.
Sets time limit for disconnected sessions - This policy is found under both Computer Configuration\Administrative Templates\Windows Components\Terminal Services\Sessions and User Configuration\Administrative Templates\Windows Components\Terminal Services\Sessions and it can be used in conjunction of the previous policy above to help enhance your Terminal server's performance. By configuring disconnected sessions to time out after a short period of time, you can ensure that resources are released for your server when a Terminal Services user no longer requires them. Note that this setting has no effect on console or Remote Desktop sessions.
_______________________________________________________________________________
0
 

Author Closing Comment

by:tacomarose
ID: 31502955
I have implemented these changes, and since then I have had no phone calls of lockouts.  I realize that it has been only 4 hours, but it is looking very promising.  
Thanks!
0
 

Author Comment

by:tacomarose
ID: 22654920
Hi -
Sorry to bother you again.  
Is there a way where I can setup Terminal Services so the users do not use their roaming profile?  And, even maybe, use a default profile?
Currently, when they use RD to login it automatically runs an app.  I'm wondering if there is a way to set it up where all they get when they login is an icon to run the app rather than it automatically starting.  Is that possible?
Thanks!
0
 
LVL 38

Expert Comment

by:ChiefIT
ID: 22656173
You are not bothering me:

Let me look this up and get back with you. I think you should always have a separate profile for TS instead of using the domain profile.
0

Featured Post

Online Training Solution

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action. Forget about retraining and skyrocket knowledge retention rates.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

I've always wanted to allow a user to have a printer no matter where they login. The steps below will show you how to achieve just that. In this Article I'll show how to deploy printers automatically with group policy and then using security fil…
Issue: One Windows 2008 R2 64bit server on the network unable to connect to a buffalo Device (Linkstation) with firmware version 1.56. There are a total of four servers on the network this being one of them. Troubleshooting Steps: Connect via h…
With Secure Portal Encryption, the recipient is sent a link to their email address directing them to the email laundry delivery page. From there, the recipient will be required to enter a user name and password to enter the page. Once the recipient …
In an interesting question (https://www.experts-exchange.com/questions/29008360/) here at Experts Exchange, a member asked how to split a single image into multiple images. The primary usage for this is to place many photographs on a flatbed scanner…

710 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question