Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 507
  • Last Modified:

NS lookup cannot find domain controller SBS2003

I have a Server SBS 2003.  It was newly installed around January of this year.  Recently, the server stopped showing up in the "My Network Places".  So, I did nslookup, but it says that it cannot find the server name for 192.168.1.100.  I uninstalled and reinstalled DNS.  Made sure that there was a forwarder zone and a Reverse lookup zone.  Made sure that DHCP was working as a service and that it updates DNS.  
Other part of message is **Can't find server name for address 192.168.1.100 : Non-existent domain
Default server: unknown
Address: 192.168.1.100.
0
zotfarms
Asked:
zotfarms
  • 12
  • 6
  • 2
1 Solution
 
Henrik JohanssonSystems engineerCommented:
For nslookup error: Make sure the PTR record for 192.168.1.100 is created in reverse lookup zone.
0
 
zotfarmsAuthor Commented:
It is not There, how do you make it show up?
0
 
zotfarmsAuthor Commented:
Now also, I have workstations that will not logon because they say that the domain is not available.
0
Building an Effective Phishing Protection Program

Join Director of Product Management Todd OBoyle on April 26th as he covers the key elements of a phishing protection program. Whether you’re an old hat at phishing education or considering starting a program -- we'll discuss critical components that should be in any program.

 
Henrik JohanssonSystems engineerCommented:
As I understood the questoin the forward lookup zone for domain.com and reverse lookup zone for 192.168.x.y has already been created. Is this true?
0
 
DraconianSoulCommented:
Just out of morbid curiosity... the SBS server is in fact set with 192.168.1.100?  Make sure your workstation is set to use the SBS server's IP in DNS.  Try 'ping -a 192.168.1.100' and see if that replies with the resolved hostname and 4 pings.  Did anyone install a firewall or new antivirus scanner on the SBS server?
0
 
zotfarmsAuthor Commented:
Yes, it is set for 192.168.1.100.  I do have the workstation DNS setting for 192.168.1.100.  I updated the antivirus on the server, but after this problem occurred, I totally uninstalled the AV.  On the workstation in question, I also put the server's ip address and FQDN with ip address in the host file.
0
 
zotfarmsAuthor Commented:
This server is also running Exchange.  I don't know if that is a factor.
0
 
zotfarmsAuthor Commented:
I have disabled the firewall service on the server as well.
0
 
DraconianSoulCommented:
Is the workstation and server on the same subnet? IE, is there a firewall or router between the two computers?

Also, what about the ping?  The -a switch resolves and displays the hostname.  If we get four good replies we know we can communicate with the server.  I'm assuming you're running nslookup on the workstation with no additional switches?  Does nslookup behave properly on the server itself?
0
 
zotfarmsAuthor Commented:
I can ping.  I added the prt entry on the reverse lookup, so now when I do nslookup on the server, it now says that it is working fine.  I have not tried nslookup on the workstations.  They are all on the same subnet, the server is acting as DHCP and DNS.
0
 
zotfarmsAuthor Commented:
I noticed in the DNS Forwarders on the zone, the 4 folders : dc, domains, gc, and pdc are missing.
0
 
DraconianSoulCommented:
In DNS settings of the server, is "Register this connection's addresses in DNS" checked?
0
 
zotfarmsAuthor Commented:
where do I find that setting?
0
 
DraconianSoulCommented:
In the control panel open Network Connections or on the desktop right clickn on My Network Places and choose properties.  Right click on the network adapter and choose properties.  Select TCP/IP and click properties.  Click advanced.  Select the DNS tab.  In that window at the bottom is a check box labeled Register this connection's addresses in DNS.
0
 
zotfarmsAuthor Commented:
ok selected, register this connection's address in dns
0
 
DraconianSoulCommented:
So it was cleared?  This would cause most of your problems.  A domain controller needs to update the DNS server with its records (such as the ones you noticed were missing) as well as its A and PTR records.  If this is cleared it will prevent the DC from updating any and all DNS records.
0
 
zotfarmsAuthor Commented:
it was cleared.  Also the option below it something about a suffix.
0
 
zotfarmsAuthor Commented:
I've populated the Register this connection's addresses in DNS option now.
0
 
DraconianSoulCommented:
I'm pretty sure you can ignroe the entry about the suffix, i've always seen it unchecked.

OK, now you might have to restart the netlogon service to refresh the DNS records.  Drop to a command line and run these three commands.
net stop netlogon
net start netlogon
ipconfig /registerdns
0
 
zotfarmsAuthor Commented:
The register this connection on dns was exactly right.  Thanks so much!!!!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 12
  • 6
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now