Generating user instances in SQL Server is disabled.

When I try and create a New SQL Database in Visual Studio Solution Explorer, I get

Generating user instances in SQL Server is disabled.

This is using Visual Studio 2005, since I want to build this with VS 2005 and SQL Server 2005.  I have the 2008 versions of each on my machine as well.

How do I test if Visual Studio 2005 is using SQL 2005?  And what shall I do to fix this?

thanks,
newbieweb
newbiewebSr. Software EngineerAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
gemailjConnect With a Mentor Commented:
http://dotnetslackers.com/SQL/re-60482_Generating_user_instances_in_SQL_Server_is_disabled_Use_sp_configure_user_instances_enabled_to_generate_user_instances.aspx

run this system procedure using management studio

exec sp_configure 'user instances enabled', 1

Open in new window

0
 
newbiewebSr. Software EngineerAuthor Commented:
My management studio is 2008.  But when I run it inside a Query I get:

Msg 15123, Level 16, State 1, Procedure sp_configure, Line 51
The configuration option 'user instances enabled' does not exist, or it may be an advanced option.

Additionally,when I open management studio I am asked this question.   Does this have anything to do with my problem?

TITLE: Microsoft SQL Server Management Studio
------------------------------

There are SQL Server 2005 Management Studio registered servers on this system. Do you want to add them into Microsoft SQL Server Management Studio? Adding the server registration information has no effect on the servers themselves.

------------------------------
BUTTONS:

Yes
No
------------------------------
0
 
Mark WillsConnect With a Mentor Topic AdvisorCommented:
If you want to keep using just the 2008 SSMS, then click yes. It means you can see both 2008 and 2005 servers from the one SSMS.

You will have to turn on advanced options first...   EXEC sp_configure 'show advanced option', '1';

0
All Courses

From novice to tech pro — start learning today.