• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 462
  • Last Modified:

Wordpress Install Error

Hi,

I am having a bit of trouble getting my Wordpress Install to work I have created the database and I have modified the config.php file to correspond with the database settings and then I go to the install from the web browser and it gives me this error

Fatal error: Call to undefined function site_url() in /home/bbbenefi/public_html/articles/wp-includes/script-loader.php on line 208.

I do not have a Fastascio Option with my cPanel Hosting account.

Thanks,
0
CompTeck2255
Asked:
CompTeck2255
  • 2
3 Solutions
 
nanharbisonCommented:
Wordpress is very easy to install unless you do something in the wrong order,  or something. Can you try deleting all the tables in the DB that wordpress added to your db when you installed it and try again, with the correct config file?
Also, another possibility is that when you downloaded WP onto your computer to upload to your web server, if you changed the place where you saved it to, or saved it with a different name, it might mess up the installation.  So see if you can delete all the files and start again, (after you delete all of the db tables). I did that once!
0
 
nanharbisonCommented:
I thought of something else that might have happened to cause this error. Check to be sure that there is a file called link-template.php in your wp-includes folder. That is where the function is defined.
Sometimes when you upload a large group of files to a web server all at once, one gets missed.
0
 
mysticamusicCommented:
Hi ..

Please make sure that you have renamed wp-config-sample.php file to wp-config.php and  you have changed its following section of code...

// ** MySQL settings ** //
define('DB_NAME', 'wordpress');    // The name of the database
define('DB_USER', 'root');     // Your MySQL username
define('DB_PASSWORD', 'yourpasswordhere'); // ...and password
define('DB_HOST', 'localhost');    // 99% chance you won't need to change this value
define('DB_CHARSET', 'utf8');
define('DB_COLLATE', '');

and


// You can have multiple installations in one database if you give each a unique prefix
$table_prefix  = 'wp_';   // Only numbers, letters, and underscores please!



and one thing more... make sure your .htaccess file have the right code...

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /wordpressfolder/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /wordpressfolder/index.php [L]
</IfModule>

# END WordPress





note that wordpressfolder is the folder where you have installed your wordpress




Try this....

Thanks
0
 
CompTeck2255Author Commented:
Hey,

Thanks for the help on this one guys great help. Sorry I haven't replied in ages I have been tied up with things.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now