[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 307
  • Last Modified:

OWA website is down after i rebooted server. How to bring back up and running?

I rebooted our exchange server and after it restarted the OWA site is down. In the exhange server are blackberry BES, our owa hosting server (virtually) .   I am not familiar with Exchange Shell (codes), but how do i get the OWA site running again.  Please help me.  
0
dhidalgo
Asked:
dhidalgo
  • 8
  • 7
1 Solution
 
tntmaxCommented:
Is IIS admin running? Web services? OWA will not work without WWW services running. Any errors in the event log?
0
 
dhidalgoAuthor Commented:
how do i determine those if they are running? what are the shell codes?
0
 
tntmaxCommented:
start -> run -> services.msc

Look for IIS Admin and World Wide Web Publishing services. They should be set to automatic and started. IIS Admin is needed to administer the website through the IIS MMC, and WWW is required to actually run the page.

Alternatively, you can look for w3wp.exe in the task manager (processes tab).

If they are not running, try starting them from the services console, otherwise check the event viewer to find out why it is not running.
0
NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

 
dhidalgoAuthor Commented:
Under services, ISS admin and WWWpublishing services are running and on auto.

the w3wp.exe in task manager under processes was not found... would that be the problem?
0
 
tntmaxCommented:
Can you go into IIS Admin and see if the default website is running? You can also start and stop the website within IIS, so even if WWW running, you can still stop the website. Once again, any error codes in the event logs?
0
 
dhidalgoAuthor Commented:
Microsoft Exchange couldn't find a certificate that contains the domain name ls-ex1.lifestream.local in the personal store on the local computer. Therefore, it is unable to support the STARTTLS SMTP verb for the connector Internet Send Connector with a FQDN parameter of ls-ex1.lifestream.local. If the connector's FQDN is not specified, the computer's FQDN is used. Verify the connector configuration and the installed certificates to make sure that there is a certificate with a domain name for that FQDN. If this certificate exists, run Enable-ExchangeCertificate -Services SMTP to make sure that the Microsoft Exchange Transport service has access to the certificate key.

the certificate that was installed yesterday was for mail.lifestream.com
0
 
dhidalgoAuthor Commented:
here is a clip of the error.  
a certificate was issued for mail.lifestream.com website for OWA
error-log.bmp
0
 
tntmaxCommented:
What are the transport warnings? Any errors or warnings in System?

How did you install the cert? What kind of cert? Did you do a single domain cert, or one of the new special multi-domain certs? With Exchange 2007, you need to have a cert that will sign for at least 5 domains, including external and internal names for the server.
0
 
tntmaxCommented:
finally, this site was most helpful to me to understand Exchange 2007 certs:

http://msexchangeteam.com/archive/2007/02/19/435472.aspx
0
 
dhidalgoAuthor Commented:
it was set up yesterday; and everything was running smoothly until I restarted the server today.  Why do you think restartig the server would initiate something or the owa to not run again.
0
 
tntmaxCommented:
Not sure, I don't know your environment, that's why I'm asking questions :-)
0
 
dhidalgoAuthor Commented:
this is the trasport warning:  Microsoft Exchange couldn't find a certificate that contains the domain name ls-ex1.lifestream.local in the personal store on the local computer. Therefore, it is unable to support the STARTTLS SMTP verb for the connector Default LS-EX1 with a FQDN parameter of ls-ex1.lifestream.local. If the connector's FQDN is not specified, the computer's FQDN is used. Verify the connector configuration and the installed certificates to make sure that there is a certificate with a domain name for that FQDN. If this certificate exists, run Enable-ExchangeCertificate -Services SMTP to make sure that the Microsoft Exchange Transport service has access to the certificate key.

An internal transport certificate expired. Thumbprint:664B36....
0
 
dhidalgoAuthor Commented:
so it is still refering to the expired certificate.  

Csr was generated on exchange server (the cert was for a domain 2yrs for mail.lifestream.com).  was then imported and enabled.  installed to root and intermediate...

before i left yesterday; everything worked.
0
 
tntmaxCommented:
Once again, how did you install your cert? How did you generate it? Did you read the links that I gave you, and did you follow those instructions? The msexchangeteam article has the commands that you need to run to get this working, so there's no need to type it again.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 8
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now