Switch to Vista and SMB shares not working well on XBMC

I recently upgraded to Vista, and now my wireless network shares are no longer working as well.

I am sharing media over wireless network (802.11g), using SMB, from my PC to a modified Xbox1 running XBMC.  They appear and will start on the console however within a minute or two in, the playback stops, sometimes altogether, sometimes skips to the next song.

I am able to stream via different protocols (eg. uPnP, ftp) without issue.  However SMB is preferable since it is build in to the PC's OS, meaning I don't have to run an additional media server on the PC.

I have also found that everything works properly over conventional (not wireless) network setup.

Everything is pointing to poorer network performance since I believe is a "less efficient" method.  However my wireless network performs very well other than this - have seen up to 900KB/s downloads from internet, up to 2 MB/s transfers via ftp to Xbox...

Looking for suggestions to get SMB shares working as well as they were on my old XP machine.

THanks
MontyChristoAsked:
Who is Participating?
 
SheddingConnect With a Mentor Commented:
Sounds like a mismatched MTU setting.  Vista has a variable MTU (it used to be hard set to 1492 in windows xp) and the XBOX has the setting to most likely 1492.  Try this:

netsh int tcp set global autotuninglevel=disabled

You can always enable it back if it doesn't work.  But once it is disabled, go to the registry in vista

to this place
HKEY_LOCAL_MACHINE \ SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces

underneath the interface folder.. you will see a lot of {######-###  folders.  each one represents your network interface.  Find the one for your wireless network (you can normally tell by the ip assigned to it).  

Add a DWORD entry called MTU and assign it the value of 1492 (Decimal).  That should take care of this.  Also make sure that you do the same in your wireless router (change the MTU setting to 1492).


0
 
SheddingCommented:
I should've said that the netsh command should be tried in the command prompt.  You do this by going to start- run and type CMD and then enter.  But by the sounds of your post, it sounds like you are technically knowledgeable.
0
 
MontyChristoAuthor Commented:
Thanks so much.  Seems to be working so far with music, but I'm going to give it a little more time and also try some video to be sure it is actually resolved.

I've tried a ton of things to fix this but this is the first time adjusting MTU has come up.  This is the kind of solution I was hoping for - easy.  

Keeping my fingers crossed.
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

 
MontyChristoAuthor Commented:
(By "easy" i just mean "easy to implement").
0
 
SheddingCommented:
well.. hopefully it is a permanent fix.  glad i could help.
0
 
MontyChristoAuthor Commented:
Bad news - as of today the problem has resurfaced.  It's certainly odd in that everything seemed to be fine for a couple of days.  So basically I'm still searching for a solution.  If you have any other suggestions...
0
 
SheddingCommented:
It is a bit strange that it would take this long to resurface.  The only thing I can think of is that the wireless network might not be quick enough to dish out the information needed.. so it is playing catch up.  Have you thought about getting a wireless N gigabit router?
0
 
MontyChristoAuthor Commented:
Well, seeing as there are other protocols such as uPnP, XBMSP and FTP that all appear to be working fine, it's not really practical to spend a bunch of extra money just to be able to use SMB.  It just means I have to run a server, and now that XBMC is cross platform, I can just run it on the PC and uPnP does the rest.

Incidentally, after my last post, I tried reverting some performance settings that I'd backed off on my router a few weeks ago (on the advice of d-link tech support) and re-enabling Super G mode, and things appeared to be working fine again.  Don't know if it was co-incidence or not.

Appreciate your assistance.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.