OWA Public Folders returning Error: HTTP/1.1 503 Service Unavailable

We have a Single Exchange 2003 Server running on a Windows 2003 R2.  Both have latest SP and critical Patches applied.  Exchange sits behind ISA 2004 Server.

Problem:  Users are able to access OWA Mailbox, Calendars etc but for some reason are Unable to access Public Folders via OWA.

Any ideas?
Cheers
Rodd
rjyoung1968Asked:
Who is Participating?
 
Keith AlabasterEnterprise ArchitectCommented:
Then you have something amiss with the setup generally.
Last proof of this can be done by accessing owa normally ans then choosing public folders from within the owa screen - does this work OK?

If it doesn't, you are into the removal of OWA and readding it again (for a clean situation) as I don't believe you can do public folders seperately.
0
 
Keith AlabasterEnterprise ArchitectCommented:
Have you added the /public on the IIS service that is hosting OWA?
So ISA is on SP3?
Do public folders wotrk if you use the OWA internally?
0
 
rjyoung1968Author Commented:
Thanks for the quick response Keith
Are you talking about the Public Virtual Directory under Exchange in IISAdmin on the Exchange Box?
Also, User are not able to access Public Folders via OWA internally or externally
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
Keith AlabasterEnterprise ArchitectCommented:
Yes, gthat was the folder I meant.
If it does not work internally either then it is unlikely to be an ISA issue.
I assume you are using a different URL internally compared to the one you are using for external users?
If you open the isa gui - select monitoring - logging - click start query, what do you see in the logs when normal owa access is attempted compared to when public folder access is attempted?
0
 
rjyoung1968Author Commented:
No URL same inter as for external ie
mail.servername.com.au/Exchange

Looking at the logs in ISA for my logon - It shows: Status 200 OK when connecting to the Inbox and when trying to access the Public Folders displays a 503 Error Service not available.

I was also looking at the local path in IISAdmin for the Exchange Website - The path to Public Folders looks a little strange,  Where in the Exchange Directory Structure does the Public Folder Store sit?

0
 
Keith AlabasterEnterprise ArchitectCommented:
internal - try just http (or https)  //internal_server_name/public as a test
0
 
rjyoung1968Author Commented:
OK Silly question  - Public Folder store sits in the same location as the Mail Store, to be more to the point the Local path the Public Virtual Directory Points to is -
\\.\BackOfficeStorage\servername.com.au\Public Folders
I cant see a share called BackOffice Storage? Is this an IIS default name used when setting OWA up in IIS?

Also after reviewing the Microsoft KB Article 282230
I removed the Mapping to Davex.dll in Application Configuration for the Public Virtual Directory. I also dismounted and re-mounted the Public Folder Store, IISReset,  stoped and start the Information Store.

When clicking on the Public Folder from OWA it now displays a 404 error: File or Directory not Found.
After re-adding the mapping and dismounting an re-mounting the Public Folder store in ESM, OWA still displays a 404 error: File or Directory not Found.
Settings are back to the original  - now have a different error with the original settings?

0
 
Keith AlabasterEnterprise ArchitectCommented:
Thats an alias - your path looks fine and is identical to mine excluding the fqdn part obviously.

Now sounds like you have bu99ered it :(  As you say, a 404 err9or is file/directory not found so something has changed in your config and it is not back to what it was.... never played with the .dll files so I have no idea what those changes you made may have done although a reboot may re-associate the .dll's with the app again.

0
 
rjyoung1968Author Commented:
tried http://Servername/Public
prompted for a username and password,  which I used my credentials.  IE then displayed the 404 Error: File not found
0
 
rjyoung1968Author Commented:
Not what wanted hear....Is it an involved process to remove and re-add OWA ?
Having never done it
0
 
Keith AlabasterEnterprise ArchitectCommented:
No, I don't suppose it is.....

This may help?
http://forums.msexchange.org/m_170140300/mpage_1/key_/tm.htm#170140300

0
 
Keith AlabasterEnterprise ArchitectCommented:
0
 
rjyoung1968Author Commented:
After checkin the KB Article 883380...your right dosn't look simple, but
Also found this on MSEXCHANGE

http://www.msexchange.org/tutorials/Fixing-Damaged-Incorrectly-Configured-OWA-2003-Installation.html.
Thanks Keith, will let you know how it goes.
0
 
Keith AlabasterEnterprise ArchitectCommented:
:) - fingers crossed and holding breath
0
 
rjyoung1968Author Commented:
Kieth, Good new mate.  

Have gone through the process as described in the above link above on MSEXCHANGE and it worked without a hitch.  I now have access to mail via OWA and Public folders are working again.

Thanks for the guidence, I have no problem allocating you the points as you where the only that offered a solution.

Good Job and
Thanks again
0
 
Keith AlabasterEnterprise ArchitectCommented:
Good job - well done and thanks :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.