Solved

Group policy for Wallpaper

Posted on 2008-10-05
10
1,528 Views
Last Modified: 2012-05-05
I have applied the group policy for domain. FOr this I have enabled the Active Desktop wallpaper in User configuration-->Admin Temp-->Desktop-->Active Desktop and enabled Active Desktop Wallpaper, in the wallpaper name I have given the path of the wallpaper. Also enabled "Enable Active Desktop".

Now the problem is I think policy is applied as on users systems It is showing blue screen and in the display properties-->desktop, back ground is not highlighted while on my domain controller, it is showing new wallpaper. I am not able to understand what is causing not to show the wallpaper on the users systems while my DC shows the new wallpaper. I checked the path of the wallpaper. Every thing seems fine.

Please suggest, Thanks
0
Comment
Question by:Shiv3
  • 5
  • 5
10 Comments
 
LVL 58

Expert Comment

by:tigermatt
ID: 22643999
I have had problems using that particular feature unless the wallpaper file itself is in Bitmap (BMP) format. Have you considered saving the wallpaper as BMP and updating the path in the policy as a test?
0
 

Author Comment

by:Shiv3
ID: 22644009
But I go for .bmp file then the size of the file comes out to 1.5 MB ( I have already compressed the .jpg file) so will that be OK if I will use that much size of file in GP, will that not create the congestion in the newtork in the morning when users will login in.
0
 
LVL 58

Expert Comment

by:tigermatt
ID: 22644034
1.5MB is nothing for a BMP file, and considering the other traffic which goes across the network at login that wouldn't affect logon times or network load.

The compression on a JPG is very good and JPG files are compressed, but due to the mechanisms by which JPG files are set as desktop wallpaper, I have found that they are not very reliable or may not work at all. If you use a BMP file and specify this in the policy, you should find the wallpaper is applied first time.

-tigermatt
0
 

Author Comment

by:Shiv3
ID: 22644182
it is still not working, Is there any way to check what is wrong with the GP.How could I find the problem associated with it. any event which I could check in event viewer. any trouble shooting I could do to solve the problem.

0
 
LVL 58

Expert Comment

by:tigermatt
ID: 22644210
If there is an error while applying Group Policy, you will see an Error log in the System / Application Event Viewer at the time when you logon.

You would also want to run rsop.msc at a client workstation, then browse to the location where you set the policy. Rsop.msc shows you all the policies active on a machine, so if you don't see it listed there, it isn't applying to that particular machine for some reason.

Remember to run gpupdate /force after changing a policy for it to update immediately.

Also, you are referencing the BMP on the server using a UNC path, i.e. \\servername\share\background.bmp, aren't you?

-tigermatt
0
 

Author Comment

by:Shiv3
ID: 22644243
I don't know but I think you have indicated me the problem. Actually I am using local path, and to the partition I was using, domain user is not having access. I can say That is very silly mistake I was doing, Let me give the UNC path for the file,
Please correct me if I am wrong

I will let you know if all will go well. Thanks a lot Tigermatt.
0
 
LVL 58

Accepted Solution

by:
tigermatt earned 125 total points
ID: 22644264
If you use a local path, then when that policy is applied to the workstation, the file would have to be present at the local path on the workstation. Since you haven't copied the file to each workstation, this will cause it to fail.

Put the file in a share on the server, give Everyone access, then set it as a UNC in the policy. You should find it will work.

:)

-tigermatt
0
 

Author Closing Comment

by:Shiv3
ID: 31503163
Thanks a lot Tigermatt. You was right, I used UNC path and it worked even for .jpg.Thanks Again for your guidance and steps to check what is wrong with GP.
0
 

Author Comment

by:Shiv3
ID: 22645597
Thanks a lot Tigermatt. You was right, I used UNC path and it worked even for .jpg.Thanks Again for your guidance and steps to check what is wrong with GP.
0
 
LVL 58

Expert Comment

by:tigermatt
ID: 22645608
You're most welcome. Thanks again :)
0

Join & Write a Comment

My last post dealt with using group policy preferences to set file associations, a very handy usage for a GPP. Today I am going to share another cool GPP trick, this may be a specific scenario but I run into these situations frequently in my activit…
Mapping Drives using Group policy preferences Are you still using old scripts to map your network drives if so this article will show you how to get away for old scripts and move toward Group Policy Preference for mapping them. First things f…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles from a Windows Server 2008 domain controller to a Windows Server 2012 domain controlle…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now