sql server 2005 reporting services installation problems

Installing SQL Server 2005 Reporting Services on Vista Ultimate is hell. At least that is my experience after hours and hours at it.

Currently, I am trying to figure out why nothing works/displays in the browser. If I select my reporting manager directory within IIS 7 and click on Basic Settings/Test Settings I get the error listed at the end of this message. The same for the virtual directory for the reportServer.

Within IIS if I right click on each of the directories and edit permission I can see that I have given full control to for the username myComputer/ReportServer2005 for both directories. The Reporting Services Configuration application shows that the windows service identity is Service Account myComputer/ReportServer2005 and the Windows Account option is checked. The web services are running under the DefaultAppPool.

If I enter URL http://myComputer/Reports/ I get a page of stuff but the main message is that 'the request is not available in this context'. Checking the event log shows an event code of Event code: 3005, Event message: An unhandled exception has occurred' and :

Process information:
    Process ID: 8008
    Process name: w3wp.exe
    Account name: NT AUTHORITY\NETWORK SERVICE
 
Exception information:
    Exception type: HttpException
    Exception message: Request is not available in this context
 
Request information:
    Request URL: http://rprice-laptop/Reports/home.aspx 
    Request path: /Reports/home.aspx

If I try URL http://myComputer/Reports/ I get a web application on this server is unavailable, nothing in the event log and no real indication of what is wrong.

The server is configured to use pass-through authentication with a built-in account to access the specified physical path. However, IIS Manager cannot verify whether the built-in account has access. Make sure that the application pool identity has Read access to the physical path. If this server is joined to a domain, and the application pool identity is NetworkService or LocalSystem, verify that <domain>\<computer_name>$ has Read access to the physical path. Then test these settings again.
blindbullAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

QPRCommented:
I remember having this issue when I installed on vista.
Have you enabled II6 compatability?
http://support.microsoft.com/kb/934164


0
rwinklerCommented:
A friend of mine was looking for a solution to this.  It appears as though she found it.  Here it is:
Use an app pool that is in classic mode instead of integrated mode.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
QPRCommented:
I believe enabling II6 compatability enables you to specify this on the app pool.
0
blindbullAuthor Commented:
The book that I am using states that you should not use an App Pool in Classic Mode when developing reporting services in .NET
0
QPRCommented:
Did you check this link?
http://support.microsoft.com/kb/934164
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DB Reporting Tools

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.