Solved

How can I prevent the message "Internet Explorer has restricted this file from showing active content" from popping up?

Posted on 2008-10-05
16
1,186 Views
Last Modified: 2013-12-08
I keep getting the message "Internet Explorer has restricted this file from showing active content" all the time. Usually I would just go to Tools, Internet Options, Advanced, Security, and then just checkmark the box next to the option. But for some reason, that option isn't there anymore. It just disapeared. Has anybody else had this same problem or know how to correct it?

I'm using Windows XP Pro and Internet Explorer 6 by the way...
0
Comment
Question by:Goatmetal
  • 9
  • 3
  • 3
  • +1
16 Comments
 
LVL 97

Expert Comment

by:war1
ID: 22645069
Hello Goatmetal,

The option should be under Security > Customized button.  Select allow to display mixed content.

Also, check under Advanced tab of Internet Options.

Hope this helps!
war1
0
 
LVL 12

Expert Comment

by:TK-77
ID: 22645071
Just to clarify, are you checking the 2nd checkbox that says ""Allow active content to run in files on My Computer"?

http://www.genopro.com/help/report-generator/allow-blocked-content/

TK
0
 

Author Comment

by:Goatmetal
ID: 22645076
That option isn't there either.
0
 

Author Comment

by:Goatmetal
ID: 22645085
I thought it was usually under the Internet Options and then Advanced...Cuz I remember doing this all the time, I can't stand that message...hehe...But I also tried what you said, The Internet Options, then Security, and the customized button...but it's not there either.
0
 

Author Comment

by:Goatmetal
ID: 22645094
The first option under Internet Options, Advanced, Security is "Check for publisher's certificate revocation"....seems like those  first few options just vanished.
0
 
LVL 97

Expert Comment

by:war1
ID: 22645106
Goatmetal,

Do you have a group policy preventing you from acessing certain options in IE. That could be the reason those options are not available.
0
 

Author Comment

by:Goatmetal
ID: 22645147
No. Well, I've never even used that option before. But is there a way I can find out if any Group Policies are running? I just find that strange that just the FIRST 3 options are missing. As far as I remember, every other option is there.

Good suggestion...Let me know if there's a way to check if any policies are running...thanks.
0
 
LVL 97

Expert Comment

by:war1
ID: 22645227
Goatmetal,

Here is how to access the Group Policy Editor
http://support.microsoft.com/kb/307882
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:Goatmetal
ID: 22645286
Hmmmm...Just checked it and doesn't seem to be running anything extra or out of the ordinary....
I just noticed another thing that's wrong. When I click the start button, then Help and Support...The Help and Support window opens like it should.....Every option seems to be working fine except for when I click on Index at the top. All I get is and empty box with an "X" in the upper left corner. Althought I have the description on the right hand side for the index.
    Reason I'm mentioning this is maybe I don't have a Help and Support Index because of the problem (whatever it may be) is.
0
 
LVL 50

Expert Comment

by:jcimarron
ID: 22646437
Goatmetal--The settings you want are in IE Tools|Internet Options|Security tab.  The easy way to set them is to use the slider.  Medium-High or Medium should get rid of the message.  Or you can click Custom Level and then in the ActiveX area change settings as suggested here.
http://www.microsoft.com/technet/prodtechnol/ie/reskit/6/part2/c04ie6rk.mspx?mfr=true
(you have to scroll about 50% of the way down for the ActiveX section)
0
 

Author Comment

by:Goatmetal
ID: 22647184
Hey jcimarron:

This is exactly what I have in Internet Options / Security tab. So, what exactly should I have checked?

.NET Framework-reliant componets
                     Permissions for components with manifests
            Disable
            High Safety
      Run components not signed with Authenticode
            Disable
            Enable
            Prompt
      Run components signed with Authenticode
            Disable
            Enable
            Prompt
Downloads
      Automatic prompting for file downloads
            Disable
            Enable
      File download
            Disable
            Enable
      Font download
            Disable
            Enable
            Prompt
Miscellaneous
      Access data sources across domains
            Disable
            Enable
            Prompt
      Allow META REFRESH
            Disable
            Enable
      Allow scripting of Internet Explorer Webbrowser control
            Disable
            Enable
      Allow script-initiated windows without size or position constraints
            Disable
            Enable
      Allow Web pages to use restricted protocols for active content
            Disable
            Enable
            Prompt
      Display mixed content
            Disable
            Enable
            Prompt
      Don't prompt for client certificate selection when no certificates or only one certificate exists
            Disable
            Enable
      Drag and drop or copy and paste files
            Disable
            Enable
            Prompt
      Installation of desktop items
            Disable
            Enable
            Prompt
      Launching programs and files in an IFRAME
            Disable
            Enable
            Prompt
      Navigate sub-frames across different domains
            Disable
            Enable
            Prompt
      Open files based on content, not file extension
            Disable
            Enable
      Software channel permissions
            High safety
            Low safety
            Medium safety
      Submit nonencrypted form data
            Disable
            Enable
            Prompt
      Use Pop-up Blocker
            Disable
            Enable
      Userdata persistence
            Disable
            Enable
      Web sites in less privileged web content zone can navigate into this zone
            Disable
            Enable
            Prompt
Scripting
      Active scripting
            Disable
            Enable
            Prompt
      Allow paste operations via script
            Disable
            Enable
            Prompt
      Scripting of Java applets
            Disable
            Enable
            Prompt
User Authentication
      Logon
            Anonymous logon
            Automatic logon only in Intranet zone
            Automatic logon with current username and password
            Prompt for user name and password
0
 

Author Comment

by:Goatmetal
ID: 22647197
Plus, I just checked, and in Internet Options/Advanced, the activex options towards the botton are still missing. I know for a fact that's where they are supposed to be. Isn't it a BIG coincidence that the message that keeps appearing all the time is about active content, and the 3 options that are supposed to be in the Advanced tab are missing? Or is ActiveX and active content two totally different things?
0
 

Accepted Solution

by:
Goatmetal earned 0 total points
ID: 22647995
Hey all....
After searching for hours more on Google, I found out the problem. Somehow something in the registry got messed up which turned off all "ActiveX" commands and options. I guess some of the smaller programs I installed messed it up I think...Well, anyway...One of the ways somebody said worked for them was to reinstall Service Pack 2. I did that, and amazingly those 3 first options that had disappeared in the Tools/Internet Options/Advanced/Security were suddenly there again. Funny how one little box to be check marked can REALLY annoy the $@# outta you. lol...

Thanks for everyone's input trying to help me.
0
 
LVL 50

Expert Comment

by:jcimarron
ID: 22651508
Goatmetal--Good for you.  Glad to hear all is well.  Can you tell us what the Registry key was (or give us the Google link) to fix the problem?  
I think you will find you also have a whole bunch of ActiveX settings (in a section called "ActiveX controls and plug-ins") in IE Tools|Internet Options|Security|Custom Level now.
0
 

Author Comment

by:Goatmetal
ID: 22681360
Hey jcimarron,  I'm not really sure what the Registry Key was....I didn't really mess around with any of that. As for the link, I'm not sure about that either. It's just reinstalling Service Pack 2. So, I'm pretty sure all I did was go on google and type in "service pack 2 download". If you want, I can find the exact link and post it back here. It'd be no problem at all....I'll be back in a little bit with the link..Take care.
0
 
LVL 50

Expert Comment

by:jcimarron
ID: 22681919
Goatmetal--Please do not go to a lot of trouble, but if you wander across more info, let us know.  Thanks.
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Join & Write a Comment

Bada platform is becoming more and more famous this days and people talking about same. Some friends included those who have bada OS mobile asked me "what is bada?"and "what its features?". That encouraged me to research and write this article. [st…
Issue: Unstable cursor in Windows XP and Windows runs extremely slow in that any click will bring up the Hour glass (sometimes for several seconds before giving you what you want) . Troubleshooting Process and the FINAL FIX: This issue see…
Google currently has a new report that is in beta and coming soon to Webmaster Tool accounts. This Micro Tutorial will highlight new features for Google Webmaster Tools.
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now