How do I stop session time out for terminal services

I run a terminal services app on windows 2003 server and XP clients which uses a local user account to log on to windows on the computer. Then the app is launched by clicking on an icon which has the needed credentials on the domain to access required resources.
 My problem is after a period of in activity the terminal session locks similarly to locking your windows desktop session and hence the user needs to know the domain account password to unlock the session. This defeats the purpose. How can I stop this time out issue or extend the time it takes. I went over the GP and have made several setting changes but none seem to address the issue. Thanks for any help you can offer
dutyfreecaribbeanAsked:
Who is Participating?
 
McKnifeConnect With a Mentor Commented:
Please check the value of the following regkey:
http://www.microsoft.com/technet/prodtechnol/windows2000serv/reskit/regentry/93258.mspx?mfr=true
Has to be zero.
0
 
McKnifeCommented:
The policy to be modified is the screen saver setting at the TS. "on resume, display logon screen" is activated. You could take out that setting completely or rise the screen saver activation time.
0
 
placebo69aCommented:
McKnife hit it spot on mate. What's causing the timeout is the Screen Saver setting. It's probably set to the default which means after 10 minutes of inactivity the Screen Saver pops up and locks the session out.
If you made changes to the Screen Saver settings using a GPO you will need to adjust the settings in that gpo. If you haven't made any settings you can simply use the Local Security Policy editor in the Administrative Tools on the server. Look under Local Computer Policy\User Configuration\Administrative Templates\Control Panel\Display for the following settings:
Hide screen saver tab - Removes Screen Saver tab from Display in Control Panel. This way users won't be able to change your settings.
No screen saver - Enable to prevent any screen savers from running.You could switch this on and forget about the following setting. If you don't you want to set this next one:
Password protect the screen saver -Disable to prevent passwords from being used on all screen savers. And an end to your worries.

You should consider the following: Without a Screen Saver with password protection enabled any terminal services session is compromised if someone obtains access to the computer running it. If your visitor security is lax or the intended application is sensitive this is a potential security risk.

Let me know if this helps. :)



0
 
dutyfreecaribbeanAuthor Commented:
I tried adjusting the setting on the database server, including out right  disabling the screen saver and still having the same issue where the credentials are being required to unlock the session
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.