How to make AD User member of Administrators Group on Local Machine

Can someone tell me how I make a domain user an administrator on a local machine.
I tried logging onto the local machine as a domain administrator but the machine does not see my domain user account. I would have thought that this could be achieved through AD Users and Computers on the server but I can't find where.
MattWilkinsonAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
MattWilkinsonConnect With a Mentor Author Commented:
I solved this issue - the problem was that the right click manage groups option does not allow you to add a domain user (whether you log onto the domain or as local admin)

I managed to do this by using control panel user account and adding it there. I could add the user when logged onto the local machine with a domain admin account
0
 
KCTSCommented:
if yopu want to do this you can - but be aware making ALL users local admins in no necessary and has serious security consequeces

For a single computer
logon as Local Administrator to the computer (not the domain)
Right click on "My Computer" and select Manage
Expand "Local Users and Groups->Groups->Administrators
Click Add
Enter the full user name eg domain\username
and OK out again

You can add users to Local Administrators with group policy.

First put the users that you want to give local admin rights to into a security group (or you Domain Users if you want it to apply to all users)

Create and OU that contains the computers that you want them to have rights on and put the computers into the OU. Note that this cannot be the Computers Container and should not contain any servers or Domain Controllers for obvious reasons.

Create a group policy that configures the security group as a Restricted Group, and under the "This group is a member of...", option add "Administrators"

Link the GPO to the OU that contains the computers

Run gpupate/force to update the policy

See http://support.microsoft.com/kb/810076
0
 
KCTSCommented:
>> I solved this issue - the problem was that the right click manage groups option does not allow you to add a domain user (whether you log onto the domain or as local admin) <<

Oh yes its does !
0
All Courses

From novice to tech pro — start learning today.