Solved

Creating a backup ACL on Cisco ASA 5505

Posted on 2008-10-06
2
865 Views
Last Modified: 2012-06-27
Hi there

I recently setup a backup DSL connection on my ASA that switches back and forth when the lines come up.

I am trying to setup a backup ACL so I can use terminal server when the primary goes down for an extended period.

I have attached my code, but I think there may be something missing.

If any one can help that would be appreciated.

Thanks

Arm
hostname xxxxxxxxx-ASA

domain-name xxxxxxxxx.local

enable password APS5CehY9m0w5TW8 encrypted

names

!

interface Vlan1

 nameif inside

 security-level 100

 ip address 172.16.0.1 255.255.252.0

!

interface Vlan2

 nameif outside

 security-level 0

 ip address 80.x.x.154 255.255.255.248

!

interface Vlan3

 nameif backup

 security-level 0

 ip address 78.x.x.233 255.255.255.248

!

interface Ethernet0/0

 switchport access vlan 2

 speed 100

 duplex full

!

interface Ethernet0/1

 switchport access vlan 3

 speed 100

 duplex full

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

passwd APS5CehY9m0w5TW8 encrypted

ftp mode passive

dns domain-lookup inside

dns server-group DefaultDNS

 name-server 172.16.0.20

 domain-name xxxxx.local

access-list acl_outside extended permit tcp any host 80.x.x.156 eq 3389

access-list acl_outside extended permit udp any host 80.x.x.156 eq 3389

access-list acl_outside extended permit tcp any host 78.x.x.234 eq 3389

access-list acl_outside extended permit udp any host 78.x.x.234 eq 3389

pager lines 24

logging asdm informational

mtu inside 1500

mtu outside 1500

mtu backup 1500

ip local pool remote-pool 172.16.1.1-172.16.1.254

no failover

icmp unreachable rate-limit 1 burst-size 1

asdm image disk0:/asdm-522.bin

no asdm history enable

arp timeout 14400

global (outside) 1 interface

global (backup) 1 interface

nat (inside) 1 0.0.0.0 0.0.0.0

static (inside,outside) tcp 80.x.x.156 3389 172.16.0.26 3389 netmask 255.255.255.255

static (inside,outside) udp 80.x.x.156 3389 172.16.0.26 3389 netmask 255.255.255.255

static (inside,backup) tcp 78.x.x.234 3389 172.16.0.26 3389 netmask 255.255.255.255

static (inside,backup) udp 78.x.x.234 3389 172.16.0.26 3389 netmask 255.255.255.255

access-group acl_outside in interface outside

route outside 0.0.0.0 0.0.0.0 80.x.x.153 1 track 1

route backup 0.0.0.0 0.0.0.0 78.x.x.234 254

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout uauth 0:05:00 absolute

http server enable

http 192.168.1.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

sla monitor 123

 type echo protocol ipIcmpEcho 80.x.x.153 interface outside

sla monitor schedule 123 life forever start-time now

crypto ipsec transform-set myset esp-des esp-md5-hmac

crypto dynamic-map dynmap 10 set transform-set myset

crypto dynamic-map dynmap 10 set reverse-route

crypto map mymap 10 ipsec-isakmp dynamic dynmap

crypto map mymap interface outside

crypto isakmp enable outside

crypto isakmp policy 10

 authentication pre-share

 encryption 3des

 hash md5

 group 2

 lifetime 86400

!

track 1 rtr 123 reachability

telnet 172.16.0.0 255.255.0.0 inside

telnet timeout 5

ssh 80.169.162.152 255.255.255.248 outside

ssh timeout 5

console timeout 0
 

!

class-map inspection_default

 match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

 parameters

  message-length maximum 512

policy-map global_policy

 class inspection_default

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect netbios

  inspect rsh

  inspect rtsp

  inspect skinny

  inspect sqlnet

  inspect sunrpc

  inspect tftp

  inspect sip

  inspect xdmcp

  inspect dns preset_dns_map

!

prompt hostname context

Cryptochecksum:91667b81fa62306e91a9f13895754f61

: end

[OK]

xxxxxxxxx-ASA(config)# access-group acl_backup in interface backup

ERROR: access-list <acl_backup> does not exist

Open in new window

0
Comment
Question by:ArmstrongInt
2 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 250 total points
ID: 22655803
Try this:
no access-list acl_outside extended permit tcp any host 78.x.x.234 eq 3389
no access-list acl_outside extended permit udp any host 78.x.x.234 eq 3389

access-list acl_backup extended permit tcp any host 78.x.x.234 eq 3389
access-list acl_backup extended permit udp any host 78.x.x.234 eq 3389
access-group acl_backup in interface backup
0
 
LVL 1

Author Comment

by:ArmstrongInt
ID: 22657402
Boom

nice one thanks for that.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

This article assumes you have at least one Cisco ASA or PIX configured with working internet and a non-dynamic, public, address on the outside interface. If you need instructions on how to enable your device for internet, or basic configuration info…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now