Solved

Adobe 9 MSI will not deploy via Group Policy

Posted on 2008-10-06
11
1,725 Views
Last Modified: 2013-11-14
I created a custom MSI via Adobe's Customization Wizard 9 and It will not install via GPM. I had it uninstalling the previous version and installing unattended. It comes up for about 10 seconds and then finishes logging in. Here is what I have done so far with no change.

Created a test OU with new assigned policy. 1 test user
Domain computers, users, and everyone has full access to the new policy
Permissions to the network folder are correct. full access
I used the UNC path to the file
Unchecked the option to remove previous version for the MSI. no change
Used the original MSI on the disk to make sure it was not any of the custom settings
I can manually run the msi and the cd key is not an issue

I checked the event log and here is what it says. (very unspecific)

Event ID: 301
The assignment of application Adobe Acrobat  9 Standard from policy Adobe 9 succeeded.

Event ID: 1013
Product: Adobe Acrobat  9 Standard --  error. (Gotta love that one)

Event ID: 102
The install of application Adobe Acrobat  9 Standard from policy Adobe 9 failed.  The error was : Fatal error during installation.

Event ID: 303
The removal of the assignment of application Adobe Acrobat  9 Standard from policy Adobe 9 succeeded.

Event ID: 108
Failed to apply changes to software installation settings.  Software changes could not be applied.  A previous log entry with details should exist.  The error was : Fatal error during installation.

Event ID: 1085
The Group Policy client-side extension Software Installation failed to execute. Please look for any errors reported earlier by that extension.

I was able to install the office 2007 compatibility msi without a problem. Anyone have any ideas?

Thanks, Scott...

0
Comment
Question by:smuth
  • 6
  • 5
11 Comments
 
LVL 40

Expert Comment

by:Vadim Rapp
Comment Utility
enable detailed msi  logging, the log will show what was the fatal error.

Did you specify "install during logon", or you only assigned it?

> I was able to install the office 2007 compatibility msi without a problem.
with the service pack??
0
 

Author Comment

by:smuth
Comment Utility
Here is the userenv.log file and the MSI*.log

Yes, I specified "install during logon". It starts the install at logon, but stops after 5-10 seconds
USERENV(128.12c) 12:01:30:687 CUserProfile::CleanupUserProfile: Ref Count is not 0

USERENV(128.12c) 12:01:30:687 CUserProfile::CleanupUserProfile: Ref Count is not 0

USERENV(128.12c) 12:01:30:687 CUserProfile::CleanupUserProfile: Ref Count is not 0

USERENV(540.544) 12:05:37:031 CUserProfile::CleanupUserProfile: Ref Count is not 0

USERENV(540.544) 12:05:37:031 CUserProfile::CleanupUserProfile: Ref Count is not 0

USERENV(540.544) 12:05:37:031 CUserProfile::CleanupUserProfile: Ref Count is not 0

USERENV(540.c28) 12:06:42:226 PolicyChangedThread: UpdateUser failed with 1008.

USERENV(540.544) 12:06:53:013 MyRegUnLoadKey:  Failed to unmount hive 00000005

USERENV(540.544) 12:06:53:013 DumpOpenRegistryHandle: 2 user registry Handles leaked from \Registry\User\S-1-5-21-1960408961-1336601894-725345543-17900

USERENV(540.544) 12:06:53:013 UnloadUserProfileP: Didn't unload user profile <err = 5>

USERENV(540.544) 12:06:53:694 UnloadUserProfile: UnloadUserProfileP failed with 0

USERENV(540.544) 12:07:03:959 Profile was loaded but the Ref Count is 1 !!!

USERENV(540.b64) 12:07:40:022 ProcessGPOs: Extension Software Installation ProcessGroupPolicy failed, status 0x643.

USERENV(540.f58) 12:07:40:022 PolicyChangedThread: UpdateUser failed with 1008.

USERENV(540.544) 12:26:47:595 UnloadUserProfileP: Didn't unload user profile <err = 19>

USERENV(540.544) 12:29:19:353 Profile was loaded but the Ref Count is 1 !!!

USERENV(540.a5c) 12:29:51:523 ProcessGPOs: Extension Software Installation ProcessGroupPolicy failed, status 0x643.

USERENV(540.d68) 12:29:51:523 PolicyChangedThread: UpdateUser failed with 1008.

USERENV(540.f68) 12:31:14:737 ProcessGPOs: Forced option changed policy mode.

USERENV(540.86c) 12:31:14:737 PolicyChangedThread: UpdateUser failed with 1008.

USERENV(540.544) 12:31:33:798 UnloadUserProfileP: Didn't unload user profile <err = 19>

USERENV(540.544) 12:31:55:063 Profile was loaded but the Ref Count is 1 !!!

USERENV(540.370) 12:32:26:983 ProcessGPOs: Extension Software Installation ProcessGroupPolicy failed, status 0x643.

USERENV(540.e98) 12:32:26:983 PolicyChangedThread: UpdateUser failed with 1008.

USERENV(540.4c0) 14:04:30:395 PolicyChangedThread: UpdateUser failed with 1008.

USERENV(540.544) 15:17:17:748 UnloadUserProfileP: Didn't unload user profile <err = 19>

USERENV(540.544) 15:18:12:907 Profile was loaded but the Ref Count is 1 !!!

USERENV(540.3e4) 15:18:44:783 ProcessGPOs: Extension Software Installation ProcessGroupPolicy failed, status 0x643.

USERENV(540.ff0) 15:18:44:783 PolicyChangedThread: UpdateUser failed with 1008.

USERENV(540.d10) 16:50:48:593 PolicyChangedThread: UpdateUser failed with 1008.

USERENV(540.fa4) 18:45:52:159 PolicyChangedThread: UpdateUser failed with 1008.

USERENV(540.ec0) 20:20:56:074 PolicyChangedThread: UpdateUser failed with 1008.

USERENV(540.968) 22:19:59:534 PolicyChangedThread: UpdateUser failed with 1008.

USERENV(540.f10) 00:08:03:407 PolicyChangedThread: UpdateUser failed with 1008.

USERENV(540.b58) 02:01:07:652 PolicyChangedThread: UpdateUser failed with 1008.

USERENV(540.884) 03:48:11:739 PolicyChangedThread: UpdateUser failed with 1008.

USERENV(540.5b4) 05:27:15:737 PolicyChangedThread: UpdateUser failed with 1008.

USERENV(540.968) 07:22:19:367 PolicyChangedThread: UpdateUser failed with 1008.

USERENV(540.544) 08:40:31:523 UnloadUserProfileP: Didn't unload user profile <err = 19>

USERENV(540.544) 08:40:43:242 Profile was loaded but the Ref Count is 1 !!!

USERENV(540.e20) 08:41:15:773 ProcessGPOs: Extension Software Installation ProcessGroupPolicy failed, status 0x643.

USERENV(540.eec) 08:41:15:788 PolicyChangedThread: UpdateUser failed with 1008.
 
 

MSI
 

 error.

=== Logging stopped: 10/7/2008  8:41:15 ===

Open in new window

0
 
LVL 40

Expert Comment

by:Vadim Rapp
Comment Utility
This single "error." - is that all Installer logged in MSI*.log ?? See http://support.microsoft.com/kb/223300

If it was already enabled and "error." is indeed all it logged, then obviously installation was not even launched, most likely because of the multiple errors in userenv endong with "Extension Software Installation ProcessGroupPolicy failed, status 0x643"


0
 

Author Comment

by:smuth
Comment Utility
That is all it logged and I have "voicewarmupx" in the reg key for logging. I also enabled it in GP for that test OU. Do you know what those errors in the userenv.log are telling me?  Why do I see the adobe 9 install start upon logon if it is not being launched?
0
 
LVL 40

Expert Comment

by:Vadim Rapp
Comment Utility
Maybe you are looking in the wrong place for the file? look in machine's %temp%, usually %windir%\temp .

If it different if you add it from add/remove programs -> add new programs?

Is it different if you just run the msi?

If you assign another package in the same way, will that one work?
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 

Author Comment

by:smuth
Comment Utility
No, I was looking at the right one. It was in %windir%\temp. I just tried to add it from add\remove programs and it comes up with a popup and just says error. I then checked the log and nothing new.

I then tried to run the msi from the network location and it runs, but the serial # is not automatically in that field. I guess I do not know enough about the adobe wizard. If I customize the install, (which I did) shouldn't that information be in there, or just when it is run from GP? I would think it should still be using the MST file even when you double click the MSI rather then using GP. Is this the case? Maybe the CD key is the problem. This is somewhat new to me and I am a little lost.
0
 
LVL 40

Expert Comment

by:Vadim Rapp
Comment Utility
> I would think it should still be using the MST file even when you double click the MSI rather then using GP. Is this the case?

no, you have to specify it:

msiexec /i mymsi.msi TRANSFORMS=mytransform.mst

Can you "add new programs" for other packages?
 
0
 
LVL 40

Accepted Solution

by:
Vadim Rapp earned 500 total points
Comment Utility
...and in GP, you have to specify transform(s) on the page "modifications".
0
 

Author Comment

by:smuth
Comment Utility
The add remove buttons on the modifications tab are grayed out
0
 

Author Comment

by:smuth
Comment Utility
Never mind, I figured it out. I am going to re-image the machine and start from scratch. I will post back when I am done
0
 

Author Closing Comment

by:smuth
Comment Utility
That was it. Thank you very much!
0

Featured Post

Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

Join & Write a Comment

*Adobe Acrobat 9 was used for this article. Particular steps may vary depending on software versions. 1. Create a framework of your form in Word, leaving space where you’d ultimately like the Adobe fields to appear.  (Note: I use the blank lines …
PaperPort is a popular document imaging/management product from Nuance Communications (http://www.nuance.com/). It is in widespread use by both individuals (http://www.nuance.com/for-individuals/by-product/paperport/index.htm) and businesses (http:/…
In this second video of the Xpdf series, we discuss and demonstrate the PDFimages utility, which, in a single command, is able to extract all the images from a PDF file and save each one in a separate image file (PBM, PPM, or JPG). Download and inst…
In this fifth video of the Xpdf series, we discuss and demonstrate the PDFdetach utility, which is able to list and, more importantly, extract attachments that are embedded in PDF files. It does this via a command line interface, making it suitable …

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now